X
Tryk her for at gå til webstedets mobilversion.

Supportforum

How do I disable the mouseover url popups?

Dim
Skrevet

Hi! When I mouse over a link on a page, a white text popup appears showing the url of the link page. And it won’t go away sometimes, just sit there blocking the stuff I actually want to read on a page or even can’t click on the link. How do I disable this annoying feature of Firefox? I tried browser.chrome.toolbar_tips but it doesn’t work. It occurs with Firefox 68 and 66 one. Thank you

Hi! When I mouse over a link on a page, a white text popup appears showing the url of the link page. And it won’t go away sometimes, just sit there blocking the stuff I actually want to read on a page or even can’t click on the link. How do I disable this annoying feature of Firefox? I tried ''browser.chrome.toolbar_tips'' but it doesn’t work. It occurs with Firefox 68 and 66 one. Thank you
Vedhæftede skærmbilleder
Citér

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 32.0 r0

Program

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Yderligere information

Luk
jscher2000
  • Top 10 Contributor
8684 løsninger 70998 svar

Hi Dim, the most common ways this could happen would be:

(1) Title attribute

The page author might have set the "title" of a range of characters to be a URL. There is a brief delay before Firefox shows the "title" associated with hovered text, and it should be shown below the mouse pointer to avoid blocking the hovered text.

I'm not aware of any built-in setting to turn this off. Add-ons could remove title's from a page but I haven't searched for one.

(2) Mouseover script

The page author might have attached a mouseover script to a range of characters to trigger the display of a custom tooltip. Sites usually do this to show richer and more formatted text/images than Firefox allows with the title attribute. Your screenshot doesn't seem to fit the pattern.

I'm not aware of any built-in setting to disable mouseover scripts. Add-ons could remove mouseover handlers from a page but I haven't searched for one.

(3) Generated content

The page author might have attached a custom style rule for when you hover a range of characters to trigger the display of generated text. There isn't a good reason to use this more complex method where the title attribute would work equally well, so I doubt this is the explanation.

I'm not aware of any built-in setting to disable generated content. Add-ons probably could hide hover-triggered generated content in a page but I haven't searched for one.

Note: Firefox normally displays the URL of links in the lower left corner of the browser, sometimes the lower right corner. This should not float up over the main part of the page.

I tried browser.chrome.toolbar_tips but it doesn’t work.

Preferences that contain the word "chrome" generally refer to the user interface area. So that one might be for toolbar button tooltips.

Hi Dim, the most common ways this could happen would be: (1) Title attribute The page author might have set the "title" of a range of characters to be a URL. There is a brief delay before Firefox shows the "title" associated with hovered text, and it should be shown below the mouse pointer to avoid blocking the hovered text. I'm not aware of any built-in setting to turn this off. Add-ons could remove title's from a page but I haven't searched for one. (2) Mouseover script The page author might have attached a mouseover script to a range of characters to trigger the display of a custom tooltip. Sites usually do this to show richer and more formatted text/images than Firefox allows with the title attribute. Your screenshot doesn't seem to fit the pattern. I'm not aware of any built-in setting to disable mouseover scripts. Add-ons could remove mouseover handlers from a page but I haven't searched for one. (3) Generated content The page author might have attached a custom style rule for when you hover a range of characters to trigger the display of generated text. There isn't a good reason to use this more complex method where the title attribute would work equally well, so I doubt this is the explanation. I'm not aware of any built-in setting to disable generated content. Add-ons probably could hide hover-triggered generated content in a page but I haven't searched for one. ''Note:'' Firefox normally displays the URL of links in the lower left corner of the browser, sometimes the lower right corner. This should not float up over the main part of the page. <blockquote> I tried ''browser.chrome.toolbar_tips'' but it doesn’t work. </blockquote> Preferences that contain the word "chrome" generally refer to the user interface area. So that one might be for toolbar button tooltips.
Fandt du dette nyttigt?
Citér
cor-el
  • Top 10 Contributor
  • Moderator
17467 løsninger 157838 svar

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?


Quote: And it won’t go away sometimes, just sit there blocking the stuff...

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)? ---- Quote: ''And it won’t go away sometimes, just sit there blocking the stuff...'' Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Fandt du dette nyttigt?
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.