X
Tryk her for at gå til webstedets mobilversion.

Supportforum

turn off address bar searching

Skrevet

How do I turn off the drop down address bar menu so that when I type an address and HIT ENTER it goes there instead of forcing me to mouse over to the green arrow and click.

How do I turn off the drop down address bar menu so that when I type an address and HIT ENTER it goes there instead of forcing me to mouse over to the green arrow and click.

Valgt løsning

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

In Firefox Safe mode these changes are effective:

  • hardware acceleration is disabled (Options/Preferences -> General -> Performance)
    *https://support.mozilla.org/en-US/kb/performance-settings
  • all extensions are disabled (about:addons)
  • default theme is used (no lightweight theme)
  • default toolbar layout is used
  • xulstore.json is ignored
  • userChrome.css and userContent.css are ignored (chrome folder in profile folder)
  • JavaScript JIT compilers are disabled
Læs dette svar i sammenhæng 0
Citér
McCoy
  • Top 10 Contributor
534 løsninger 5035 svar

Hello jdevlin,

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

keyword.enabled and set its value to false

Then close and restart Firefox.

Hello jdevlin, Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''keyword.enabled''' and set its value to '''false''' Then close and restart Firefox.
Fandt du dette nyttigt?
Citér
McCoy
  • Top 10 Contributor
534 løsninger 5035 svar

Just to "cover all bases" you could also check the value of this preference :

browser.urlbar.oneOffSearches (make sure its set to false)

Just to "cover all bases" you could also check the value of this preference : '''browser.urlbar.oneOffSearches''' (make sure its set to '''false''')
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

Neither one fixed it. Just as an example to be clear of what is happening. If I type "about:config" and hit 'enter' nothing happens. I must go the green arrow and click with my mouse.

Neither one fixed it. Just as an example to be clear of what is happening. If I type "about:config" and hit 'enter' nothing happens. I must go the green arrow and click with my mouse.
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

I have also discovered that using CNTRL-ENTER no longer insets the www. and .com like previous versions.

I have also discovered that using CNTRL-ENTER no longer insets the www. and .com like previous versions.
Fandt du dette nyttigt?
Citér
cor-el
  • Top 10 Contributor
  • Moderator
17473 løsninger 157934 svar

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

It works in safe mode.

The following addons are installed Adblckplus Easy youtube video downloader new tab override no script open in chrome video download helper

and a chrome.css mod to get tabs below address bar.

It works in safe mode. The following addons are installed Adblckplus Easy youtube video downloader new tab override no script open in chrome video download helper and a chrome.css mod to get tabs below address bar.
Fandt du dette nyttigt?
Citér
cor-el
  • Top 10 Contributor
  • Moderator
17473 løsninger 157934 svar

Valgt løsning

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

In Firefox Safe mode these changes are effective:

  • hardware acceleration is disabled (Options/Preferences -> General -> Performance)
    *https://support.mozilla.org/en-US/kb/performance-settings
  • all extensions are disabled (about:addons)
  • default theme is used (no lightweight theme)
  • default toolbar layout is used
  • xulstore.json is ignored
  • userChrome.css and userContent.css are ignored (chrome folder in profile folder)
  • JavaScript JIT compilers are disabled
If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via one of these: *"3-bar" menu button -> Exit (Power button) *Windows: File -> Exit *Mac: Firefox -> Quit Firefox *Linux: File -> Quit *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems In Firefox Safe mode these changes are effective: *hardware acceleration is disabled (Options/Preferences -> General -> Performance)<br>*https://support.mozilla.org/en-US/kb/performance-settings *all extensions are disabled (about:addons) *default theme is used (no lightweight theme) *default toolbar layout is used *xulstore.json is ignored *userChrome.css and userContent.css are ignored (chrome folder in profile folder) *JavaScript JIT compilers are disabled
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

It appears to be the tabs on bottom userchrome.css mod that is causing the issue. Thanks I will have to look into an update.

It appears to be the tabs on bottom userchrome.css mod that is causing the issue. Thanks I will have to look into an update.
Fandt du dette nyttigt?
Citér

Spørgsmålsstiller

problem resolved. The issue was not the tabs on bottom. It was in the classic theme restore portion of the userchrome.css.

problem resolved. The issue was not the tabs on bottom. It was in the classic theme restore portion of the userchrome.css.
Fandt du dette nyttigt?
Citér
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.