Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am author of www.shrewsburylightorchestra.org.uk and have recently added a dropdown menu nav bar, some of which works and one doesn't - why?

  • 4 replies
  • 1 has this problem
  • 1 view
  • Last reply by despslo

more options

The drop down menu that doesn't work in Firefox is the Gallery - this should then show Photos 1, Photos 2 and sketches. Photos 2 has not yet been completed but the others have. The drop down menus About Us and Members work OK and I cant see why the Gallery one doesn't. They all work in Internet Explorer.

The drop down menu that doesn't work in Firefox is the Gallery - this should then show Photos 1, Photos 2 and sketches. Photos 2 has not yet been completed but the others have. The drop down menus About Us and Members work OK and I cant see why the Gallery one doesn't. They all work in Internet Explorer.

Chosen solution

You closed the li by accident, so the UL that opens the drop down list is not in that LI section. There are two </li> present in the code and you should remove the one after the <a> tag.

 <li><a href ="#">Gallery</a></li>
  <ul>
   <li><a href="photos - 1.html">Photos 1</a></li>
   <li><a href="#">Photos 2</a></li>
   <li><a href="sketches.html">Sketches</a></li>
  </ul></li>

Firefox shows the second </li> in red in the page code because that tag had already been closed.

  • Firefox > Web Developer > Page Source
  • Tools > Web Developer > Page Source (Ctrl+U)
  • right-click on a web page to open the context menu and select View Page Source

Note that the page code shows more stray end tags in red, so check them all.
You can hover a red tag to get an explaining tooltip.

 </tr> (should be: <tr>)
  <td>Leroy Anderson Favourites</td>
  <td><i>Arr.</i> Calvin Custer</td>
 </tr>

http://www.shrewsburylight-orch.org.uk/

Read this answer in context 👍 0

All Replies (4)

more options

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

more options

No, this made no difference at all - the drop down menu that didn't work still doesn't, but the others do. And it still works in IE but not in Chrome .

more options

Chosen Solution

You closed the li by accident, so the UL that opens the drop down list is not in that LI section. There are two </li> present in the code and you should remove the one after the <a> tag.

 <li><a href ="#">Gallery</a></li>
  <ul>
   <li><a href="photos - 1.html">Photos 1</a></li>
   <li><a href="#">Photos 2</a></li>
   <li><a href="sketches.html">Sketches</a></li>
  </ul></li>

Firefox shows the second </li> in red in the page code because that tag had already been closed.

  • Firefox > Web Developer > Page Source
  • Tools > Web Developer > Page Source (Ctrl+U)
  • right-click on a web page to open the context menu and select View Page Source

Note that the page code shows more stray end tags in red, so check them all.
You can hover a red tag to get an explaining tooltip.

 </tr> (should be: <tr>)
  <td>Leroy Anderson Favourites</td>
  <td><i>Arr.</i> Calvin Custer</td>
 </tr>

http://www.shrewsburylight-orch.org.uk/

Modified by cor-el

more options

Thank you, yes that has worked very well. I have now changed all the pages with that error on and the site is now as I wanted it. I'll check all the other stray end tags as well. Thanks again for your help.