Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

YouTube videos and YouTube Shorts on Firefox 117.0 getting slower and jerky / stuttering

  • 7 replies
  • 2 have this problem
  • 47 views
  • Last reply by guidox11

more options

I hoped the problem was solved with Firefox 117.0. But still YouTube videos and YouTube Shorts on Firefox 117.0 getting slower and jerky / stuttering. I have 15-20 tabs open and one to five of them are YouTube tabs. After refreshing Firefox (Settings -> Help -> More troubleshooting information -> Refresh Firefox), it is OK, but only for a short while. Then the problem starts again. Same YouTube videos are running fine with Chrome at the same time.

RAM use of Firefox goes up to over 5 GB.

Running Windows 11 Pro (Clean windows setup not long ago and the issue was there from the beginning.) German Language Firefox 117.0.2 Build ID 20230824132758 Intel CPU i7-1360P, 16 GB RAM, 1TB M.2 SSD

I hoped the problem was solved with Firefox 117.0. But still YouTube videos and YouTube Shorts on Firefox 117.0 getting slower and jerky / stuttering. I have 15-20 tabs open and one to five of them are YouTube tabs. After refreshing Firefox (Settings -> Help -> More troubleshooting information -> Refresh Firefox), it is OK, but only for a short while. Then the problem starts again. Same YouTube videos are running fine with Chrome at the same time. RAM use of Firefox goes up to over 5 GB. Running Windows 11 Pro (Clean windows setup not long ago and the issue was there from the beginning.) German Language Firefox 117.0.2 Build ID 20230824132758 Intel CPU i7-1360P, 16 GB RAM, 1TB M.2 SSD

All Replies (7)

more options

Does it still happen with hardware acceleration disabled?

more options

With Firefox 117.0 and hardware acceleration disabled the problem is solved. (With Firefox 116 that was not the case.)

more options

Thank you very much!

more options

You might need to update your graphics drivers if you want hardware acceleration to work better with video. You can disable it just for video by going to about:config in the address bar and changing media.hardware-video-decoding.enabled to false then restart the browser.

more options

The graphics driver is on the latest version according to Lenovo Vantage. But the Diver- und Support-Assistent tells me that: "A customized computer manufacturer driver is installed on your computer. The Intel Driver & Support Assistant is not able to update the driver. Installing a generic Intel driver instead of the customized computer manufacturer driver may cause technical issues. Contact Lenovo for the latest driver for your computer."

Why is Lenovo not using the Intel grafik driver?

I found a new Intel VGA driver on the Lenovo support web page and installed it. Wondering why Lenovo Vantage is not showing or updating it.

more options

With the new Intel VGA driver found on the Lenovo support web page, the problem is gone without the need for hardware acceleration disabled.

Still wondering why Lenovo Vantage was not updating it automatically or at least telling that there is a new graphic driver is available.

The answer from the Lenovo Support Hotline, why Lenovo Vantage didn't update the driver, was really not satisfying. They said, Lenovo Vantage will only show updates when there is an issue with Software from Lenovo. As Firefox is no Lenovo software, the graphic diver was not automatically updated. That leaves me just speechless. :-(

Modified by guidox11

more options

The issue accured again with the new driver and also with hardware acceleration disabled. With YouTube videos and YouTube shorts.

Same videos are running fine on Chrome.