Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Outlook 2010 Opens in Internet Explorer Instead of Firefox

  • 1 reply
  • 1 has this problem
  • 9 views
  • Last reply by jscher2000

more options

When I view an Outlook 2010 email message in web browser, it automatically opens in Internet Explorer instead of Firefox. My Windows 10 settings indicate that Firefox is my default web browser. When I go to settings and try to tell Windows 10 that I want mht and mhtml files to open in Firefox, that option isn't listed. The only options listed are Internet Explorer, Microsoft Word and the Microsoft Store.

Anyone got any idea how I can force Outlook 2010 Professional to use Firefox as the default browser to view emails in the web browser?

All Replies (1)

more options

Hi dmcaissie, Firefox probably is your default viewer for .htm and .html files and http: and https: links (so far so good), but Firefox doesn't take over all the different file extensions and protocols that Windows opens in IE.

In particular, Outlook sometimes offers a "View in browser" feature in the message header area -- links in the message body should be fine because they generally send you to a real website -- and this generates a local file in .mht format. Since this is not a format that Firefox can display, Internet Explorer usually remains your default viewer for .mht files and mhtml: protocol links.

Here's an old screenshot illustrating that:

<center></center>

So unfortunately, your setup is correct and this is just a known annoyance.