Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesn't play sounds.

  • 7 replies
  • 1 has this problem
  • Last reply by ARMAN KHAN

more options

I have pulseaudio installed on my system (Linux), and the Firefox options are set to play audio and video (I get video, but no audio).

I have pulseaudio installed on my system (Linux), and the Firefox options are set to play audio and video (I get video, but no audio).

All Replies (7)

more options

Hello Mnrwest,

Alsa support was dropped starting Firefox 52.0 and later. Some Linux distros may have delayed this change with their own Firefox packages.

You could compile Firefox yourself with --disable-pulseaudio --enable-alsa

Keep in mind that if you do this you will not get updates from Mozilla as it will be a third-party build.

Bug 1247056 - Require PulseAudio to play sound on Linux

I hope resolve the problem

Thank you

Modified by Roland Tanglao

more options

But the audio in Firefox worked fine earlier today (with Firefox 77.0). And I have Firefox 77.0.1 on my system now.

Modified by mnrwest

more options

Did you try to reboot the computer?

Any related messages in the Web Console ?

more options

Yes, I rebooted my computer (still no sound out of Firefox), but my other media players work fine (my operating system is VLocity64, if that is of any help.

more options

Make sure you have the latest FFmpeg and libavcodec packages installed.

more options

Hi mnrwest,

Its a bug.

It can be automatically fixed by following steps:-

  1. Close firefox.
  2. Open any other browser and play the youtube video.
  3. Close that browser.
  4. Open firefox and browse youtube.

PS: I hope you already have pulseaudio installed and the only problem exists due to firefox unable to start pulseaudio ( I believe ). This probably will be related to some permission issues which I don't know how to fix for the current time.

Modified by Shashank Shekhar

more options

hello mnrwest,

please check the given instruction on your computer/laptop: Unmute Firefox and plugins

  1. Open Firefox and play content that should play sound, such as this Firefox video or a Flash video with sound.
  2. Click the volume icon in the Windows taskbar.
  3. Click Mixer. The Volume Mixer window will appear.
  4. Make sure the sliders for Mozilla Firefox and Plugin Container for Firefox (for plugin content such as Adobe Flash) are not muted or at the bottom.

Please click the link show helpfully image :

click me I am image

Check your audio device

Make sure that the audio device (such as speakers or headphones) are turned on and connected to the computer properly.

Other solutions

Check out whether other applications on your computer can play sounds. If they can't:

  • Follow Microsoft's Fix sound problems tutorial.

If Firefox is the only application that you can't hear sound in:

  • Try the solutions in Fix common audio and video issues.

i hope resolve the problem