Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't play programmes in ' catch up ' TV using Firefox , getting error message " Sorry there is a problem with this video. We could not load the video stream

  • 1 reply
  • 2 have this problem
  • 3 views
  • Last reply by cor-el

more options

Hi , I can no longer watch catch up TV using Firefox. After clicking on a programme , I get the error message ..." Sorry there is a problem with this video . We could not load the video stream you selected " I ' trashed ' Firefox and re-installed it , but still no go. The new download retained all my old speed dials , is this normal ? Could it be picking up bad habits from the ' trashed ' version ? I hope you can help....I hate Safari !! Mac OS 10.13

Hi , I can no longer watch catch up TV using Firefox. After clicking on a programme , I get the error message ..." Sorry there is a problem with this video . We could not load the video stream you selected " I ' trashed ' Firefox and re-installed it , but still no go. The new download retained all my old speed dials , is this normal ? Could it be picking up bad habits from the ' trashed ' version ? I hope you can help....I hate Safari !! Mac OS 10.13

All Replies (1)

more options

Is there a better message in the Web Console?


You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache:

  • Options/Preferences -> Privacy & Security -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Options/Preferences -> Privacy & Security -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window