Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

SmartSource says Java is disabled. but it isn't and correct version. won't print coupons

  • 8 replies
  • 8 have this problem
  • 572 views
  • Last reply by SuzieJ

more options

I installed Java as requested and it is the current version. But every time I try to print coupons it comes back and says I don't have the correct version. They tell me how to check but their instructions are horrible can't follow them

All Replies (8)

more options

What exactly was requested, Java, or Javascript? These are completely different things.

more options

This was done when trying to print a coupon from Command products. New computer so they asked to download Java if I didn't have it. which I did. I use Firefox. then they tell me it won't print because I don't have correct version I do then SmartSource.com says "do this" Can't figure the heck out of what they say to do and video view is so small you can't see instructions.

more options

What is the difference between Java and Javascript?

more options

On your question about Java versus JavaScript, see JavaScript is not Java.

The SmartSource coupon printer requires Java according to http://help.smartsource.com/customer/portal/articles/1385803-why-do-i-need-to-install-java-?b_id=719

You have Java installed according to your plugins list. You probably need to activate it, since the default setting for Java is "Ask to Acivate" in the Firefox Addons Manager. Use the Java plugin to view interactive content on websites has details. . To protect against potential Java vulnerabilities, Firefox asks you by default, to activate Java for each website you visit that uses Java. If you trust the website, you can allow Java to run by clicking on the "Activate Java" message. If there is no visible area to activate Java content in the page, look for the plugin icon in the address bar, then click it and, in the message panel that opens, choose "Allow Now". For more information, see the How to allow Java on trusted sites article.

more options

With a little bit of back and forth, finally able to print. didn't see above the "allow" feature. thank you all

more options

went to Command email to print and got the same old can't print do where to allow should since i clicked Allow and remember Ugh!

more options

You can try changing the Java plugin setting from "Ask to Activate" to "Always Activate" in the Firefox Addons Plugins list - see Use the Java plugin to view interactive content on websites under "Enabling Java".

If that doesn't work then you could contact http://help.smartsource.com/

more options

As I've mentioned in another post, their response got me nowhere. couldn't see the video (too small) made no sense. I'm so aggravated I give up. Not that computer savvy and don't have anyone close to come to house.