X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to clear search history from LOCATION BAR

Kuphostiwe

I'm using FF 22.0. I tried various methods to clear the search history from *location* bar (not the search bar). Here's what hasn't worked:

* Tools->Options->Privacy->clear your recent history
* Shift-Ctrl-Del while in FF
* Extension "Form History Control 1.3.1.0
* Disabling all Extensions and Plugins (there are no services)
   - Then clearing recent history via GUI and Shift-Ctrl-Del
* Disabling all Extensions and Plugins
   - Ending all FF sessions and starting up a Private session
   - Then clearing recent history via GUI and Shift-Ctrl-Del

Thanks.

I'm using FF 22.0. I tried various methods to clear the search history from *location* bar (not the search bar). Here's what hasn't worked: * Tools->Options->Privacy->clear your recent history * Shift-Ctrl-Del while in FF * Extension "Form History Control 1.3.1.0 * Disabling all Extensions and Plugins (there are no services) - Then clearing recent history via GUI and Shift-Ctrl-Del * Disabling all Extensions and Plugins - Ending all FF sessions and starting up a Private session - Then clearing recent history via GUI and Shift-Ctrl-Del Thanks.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Google Update
  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Enables the interaction of Mathematica content with the latest installed version of Mathematica.
  • 5.1.20125.0
  • NPWLPG

Isisebenziso

  • Firefox 22.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • I-URL Yokweseka: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Izandiso

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Form History Control 1.3.1.0 (formhistory@yahoo.com) (Akusebenzi)
  • SQLite Manager 0.8.0 (SQLiteManager@mrinalkant.blogspot.com) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2: NVIDIA GeForce 310M
  • adapterDeviceID: 0x0046
  • adapterDeviceID2: 0x0a70
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 512
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 400
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'8.1500.1000.2202']
  • directWriteEnabled: False
  • directWriteVersion: 6.1.7600.16972
  • driverDate: 4-21-2010
  • driverDate2: 12-16-2010
  • driverVersion: 8.15.10.2119
  • driverVersion2: 8.17.12.6132
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics)
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.google.ca/
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.closeWindowWithLastTab: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1373179090
  • places.history.expiration.transient_current_max_pages: 101992
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.flash: 2
  • plugin.state.java: 2
  • plugin.state.npctrl: 2
  • plugin.state.npdeployjava: 2
  • plugin.state.npgoogleupdate: 2
  • plugin.state.npitunes: 0
  • plugin.state.npmathplugin: 2
  • plugin.state.nppdf: 0
  • plugin.state.nppdfxcviewnpplugin: 0
  • plugin.state.npwlpg: 2
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1371934346

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
kobe 441 izisombululo 5048 izimpendulo
Kuphostiwe

right click search bar, hit delete

right click search bar, hit delete

Okulungisiwe ngu kobe

Impendulo Ewusizo

Hi, Waka,

This post is about entries typed into the location bar. I should have specified that I'm using Firefox on a Windows 7 laptop.

Hi, Waka, This post is about entries typed into the location bar. I should have specified that I'm using Firefox on a Windows 7 laptop.
jscher2000
  • Top 10 Contributor
8838 izisombululo 72234 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Are the search history entries part of your visited page history (i.e., they appear in the auto-suggest drop-down with other history entries) or do they appear in their own drop-down list?

If they are standard history entries, see Remove websites from the address bar suggestions.

Are the search history entries part of your visited page history (i.e., they appear in the auto-suggest drop-down with other history entries) or do they appear in their own drop-down list? If they are standard history entries, see [[Remove websites from the Awesome Bar suggestions]].

Umnikazi wombuzo

That's it! I saw the "awesome bar" and ignored it, thinking that it was some add-in.

Also, just for future reference, the popdown list also includes matching bookmarks, which can be controlled from Tools->Options->Privacy.

Thanks!

That's it! I saw the "awesome bar" and ignored it, thinking that it was some add-in. Also, just for future reference, the popdown list also includes matching bookmarks, which can be controlled from Tools->Options->Privacy. Thanks!
Mr-Love 0 izisombululo 9 izimpendulo
Kuphostiwe

I've tried that too, and even though all history is cleared, sites previously visited keeps coming up in address bar when I start typing...

Only way to prevent this seems to be to go to Options, Privacy, and under Location Bar just select Bookmarks. Problem is, I do want suggestions from history, I just want to delete the current one first...

I've tried that too, and even though all history is cleared, sites previously visited keeps coming up in address bar when I start typing... Only way to prevent this seems to be to go to Options, Privacy, and under Location Bar just select Bookmarks. Problem is, I '''do''' want suggestions from history, I just want to delete the current one first...

Okulungisiwe ngu Mr-Love

jscher2000
  • Top 10 Contributor
8838 izisombululo 72234 izimpendulo
Kuphostiwe

Hi Mr-Love, is the problem with the sites listed in the drop-down, or the suggestions that appear directly in the address bar? The second, called autofill, can be turned off if you like. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste urlb and pause while the list is filtered

(3) Double-click the browser.urlbar.autoFill preference to switch it from its default value of true to false.

Does that help?

Hi Mr-Love, is the problem with the sites listed in the drop-down, or the suggestions that appear directly in the address bar? The second, called autofill, can be turned off if you like. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box that appears above the list, type or paste '''urlb''' and pause while the list is filtered (3) Double-click the '''browser.urlbar.autoFill''' preference to switch it from its default value of true to false. Does that help?
Mr-Love 0 izisombululo 9 izimpendulo
Kuphostiwe

Thanks, but problem is that I want this autofill when I start typing in the location bar (or address bar, or awesome bar, now that's such a stupid name but anyway) - problem is I first want to get rid of the current history. Which I seemingly have - when I check my History it's empty, but when I start to type in the location bar, it's still there. Very weird...

I may add, that when I click the downpointing arrow to the right of the location bar, nothing comes up. But as soon as I type, all history is still there.

Thanks, but problem is that I '''want''' this autofill when I start typing in the location bar (or address bar, or awesome bar, now that's such a stupid name but anyway) - problem is I first want to get rid of the current history. Which I seemingly have - when I check my History it's empty, but when I start to type in the location bar, it's still there. Very weird... I may add, that when I click the downpointing arrow to the right of the location bar, nothing comes up. But as soon as I type, all history is still there.

Okulungisiwe ngu Mr-Love

Mr-Love 0 izisombululo 9 izimpendulo
Kuphostiwe

This is the only thing that works for me - which obviously takes forever, having to delete each history entry one by one.

As I've previously replied, I've emptied all History, but all pages still comes up in the location bar.

This is the only thing that works for me - which obviously takes forever, having to delete each history entry one by one. As I've previously replied, I've emptied all History, but all pages still comes up in the location bar.
jscher2000
  • Top 10 Contributor
8838 izisombululo 72234 izimpendulo
Kuphostiwe

Hi Mr-Love, if you type part of a word does the drop-down populate or only the in-urlbar autofill?

Do you experience the same phenomenon in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Hi Mr-Love, if you type part of a word does the drop-down populate or only the in-urlbar autofill? Do you experience the same phenomenon in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?
cor-el
  • Top 10 Contributor
  • Moderator
17690 izisombululo 160039 izimpendulo
Kuphostiwe
You can check for problems with the places.sqlite database file in the Firefox profile folder. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file