X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Wish to change default language

Kuphostiwe

I want English as default language (FireFox for Mac) Preferences / Content / Choose a language It is set to English Yet on Googling it appears to be Polish

How do I change that ?

I want English as default language (FireFox for Mac) Preferences / Content / Choose a language It is set to English Yet on Googling it appears to be Polish How do I change that ?

Okulungisiwe ngu minkowski

Isisombululo esikhethiwe

I found that links by clicking the gear icon on a results page, then Search Settings, then in the left navigation column, Languages. Probably better to bookmark the link.

Funda le mpendulo ngokuhambisana nalesi sihloko 6

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Version 3.13.2.11592
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Nexus Plugin, providing authentication and signing features
  • Net iD Plugin
  • Microsoft Office for Mac SharePoint Browser Plug-in

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17411 izisombululo 157274 izimpendulo
Kuphostiwe

You can check the order of the installed Languages.

  • Firefox > Preferences > Content > Languages

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > Cookies: "Show Cookies"
You can check the order of the installed Languages. *Firefox > Preferences > Content > Languages Clear the cache and the cookies from sites that cause problems. "Clear the Cache": *Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox > Preferences > Privacy > Cookies: "Show Cookies"

Umnikazi wombuzo

You said Preferences > Advanced > Network > Cached Web Content: "Clear Now" I did that at it says: "cache is currently using 90 kB" Why not 0 kB ? Then you said: Preferences > Privacy > Cookies: "Show Cookies" But I have no Show Cookies Instead there I see: Remove Individual Cookies Which I did. I removed all Cookies and now the language is Swedish. Why Swedish ? I have no idea. I am stationed in Sweden. I use FF v 18.0.2

You said Preferences > Advanced > Network > Cached Web Content: "Clear Now" I did that at it says: "cache is currently using 90 kB" Why not 0 kB ? Then you said: Preferences > Privacy > Cookies: "Show Cookies" But I have no Show Cookies Instead there I see: Remove Individual Cookies Which I did. I removed all Cookies and now the language is Swedish. Why Swedish ? I have no idea. I am stationed in Sweden. I use FF v 18.0.2

Okulungisiwe ngu minkowski

cor-el
  • Top 10 Contributor
  • Moderator
17411 izisombululo 157274 izimpendulo
Kuphostiwe

Some sites automatically redirect you to a site in the local language, based on where your IP locates you.

There is usually a link on such websites choose a language or go to an international version that allows to choose the language.
Such a choice is stored in a cookie on your computer, so you need to keep (allow) this Google cookie. .... If the Google page is in the wrong language then see:

Some sites automatically redirect you to a site in the local language, based on where your IP locates you. There is usually a link on such websites choose a language or go to an international version that allows to choose the language.<br /> Such a choice is stored in a cookie on your computer, so you need to keep (allow) this Google cookie. .... If the Google page is in the wrong language then see: * Google: http://www.google.com/support/bin/answer.py?answer=873

Umnikazi wombuzo

Again Polish (when searching on Google) . Cant get rid of it

Again Polish (when searching on Google) . Cant get rid of it

Okulungisiwe ngu minkowski

Umnikazi wombuzo

As said - the problem is not solved

As said - the problem is not solved

Okulungisiwe ngu minkowski

hegi108 0 izisombululo 8 izimpendulo
Kuphostiwe

My problem is reverse: I live in Switzerland and my new Firefox speaks English instead of German!!

How can we change the deafult language?

My problem is reverse: I live in Switzerland and my new Firefox speaks English instead of German!! How can we change the deafult language?

Umnikazi wombuzo

This problem is not possible to solve unless you reformat and reiinstall your computer alltogher, which of course is not worth the time and effort. It has somethiing to do with Firefox or Google, I don't understand why it should be so difficult

This problem is not possible to solve unless you reformat and reiinstall your computer alltogher, which of course is not worth the time and effort. It has somethiing to do with Firefox or Google, I don't understand why it should be so difficult

Okulungisiwe ngu minkowski

jscher2000
  • Top 10 Contributor
8633 izisombululo 70605 izimpendulo
Kuphostiwe

By default, Google sniffs your internet connection and redirects to a localized version. The URL to override this if you always want google.com is:

https://www.google.com/ncr

Presumably this generates a special cookie and only lasts as long as you keep cookies.

If you prefer to always use a different country site, you might want to get a search engine plugin specific to that site. Possibly available on the following site or someone could create one just for you.

http://mycroftproject.com/google-search-plugins.html

By default, Google sniffs your internet connection and redirects to a localized version. The URL to override this if you always want google.com is: https://www.google.com/ncr Presumably this generates a special cookie and only lasts as long as you keep cookies. If you prefer to always use a different country site, you might want to get a search engine plugin specific to that site. Possibly available on the following site or someone could create one just for you. http://mycroftproject.com/google-search-plugins.html
jscher2000
  • Top 10 Contributor
8633 izisombululo 70605 izimpendulo
Kuphostiwe

Hi hegi108, if you mean the language throughout the browser is not German, you may need to reinstall Firefox using the German-language installer. I suggest making a backup of your personal settings folder first.

Hi hegi108, if you mean the language throughout the browser is not German, you may need to reinstall Firefox using the German-language installer. I suggest making a backup of your personal settings folder first. * [[Back up and restore information in Firefox profiles]] * Full range of available languages: http://www.mozilla.org/firefox/all

Umnikazi wombuzo

tried your suggestion with no success. I am MAC user

tried your suggestion with no success. I am MAC user

Okulungisiwe ngu minkowski

jscher2000
  • Top 10 Contributor
8633 izisombululo 70605 izimpendulo
Kuphostiwe

Hi minkowski, could you clarify which site you want to use, is it the .com? And are you redirecting to a country-specific site, or is the language changing on the .com site?


Is it possible you are blocking Google cookies? When on the .com site (or whatever site you want to be using), use

Tools menu > Page Info > Permissions

For "Set Cookies" do you have an effective permission of Allow?

Some privacy related add-ons may separately intercept or block Google cookies.

Hi minkowski, could you clarify which site you want to use, is it the .com? And are you redirecting to a country-specific site, or is the language changing on the .com site? ---- Is it possible you are blocking Google cookies? When on the .com site (or whatever site you want to be using), use Tools menu > Page Info > Permissions For "Set Cookies" do you have an effective permission of Allow? Some privacy related add-ons may separately intercept or block Google cookies.
hegi108 0 izisombululo 8 izimpendulo
Kuphostiwe

I deleted all cookies (for Mozilla and Google) and installed the new Firefox 20.0.1 Deutsch from the recommended page, but all texts stay in English.

I tried the add-on "Deutsch (DE) Language Pack", but nothing happens: it stays in English.

What got a Google-Cookie to do with the default language of Firefox?

I deleted all cookies (for Mozilla and Google) and installed the new Firefox 20.0.1 Deutsch from the recommended page, but all texts stay in English. I tried the add-on "Deutsch (DE) Language Pack", but nothing happens: it stays in English. What got a Google-Cookie to do with the default language of Firefox?
cor-el
  • Top 10 Contributor
  • Moderator
17411 izisombululo 157274 izimpendulo
Kuphostiwe

Can you attach a screenshot to make sure we understand your problem?

Use a compressed image type like PNG or JPG to save the screenshot.

Can you attach a screenshot to make sure we understand your problem? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem Use a compressed image type like PNG or JPG to save the screenshot.
hegi108 0 izisombululo 8 izimpendulo
Kuphostiwe

The Menu Bar and all the sub-menus and all other Mozilla pages should be in German. See as an example the uploaded image of the welcome page.

The Menu Bar and all the sub-menus and all other Mozilla pages should be in German. See as an example the uploaded image of the welcome page.
cor-el
  • Top 10 Contributor
  • Moderator
17411 izisombululo 157274 izimpendulo
Kuphostiwe

Download a new copy of the Firefox program and save the disk image (dmg) file to the desktop

Your profile data is stored elsewhere in the Firefox Profile Folder, so you won't lose your bookmarks and other personal data if you uninstall and (re)install Firefox.

Download a new copy of the Firefox program and save the disk image (dmg) file to the desktop *Firefox 20.0: http://www.mozilla.org/en-US/firefox/all.html *Trash the current Firefox application (e.g. open the Applications folder in the Finder and drag the Firefox application to the Trash) to do a clean (re-)install *Install the new version that you have downloaded *https://support.mozilla.org/kb/Installing+Firefox+on+Mac Your profile data is stored elsewhere in the Firefox Profile Folder, so you won't lose your bookmarks and other personal data if you uninstall and (re)install Firefox. *http://kb.mozillazine.org/Profile_folder_-_Firefox

Umnikazi wombuzo

I raised this issue on 6 feb 2013 and still no solution. I also asked my acquaintances, nobody can change the default language Some problems never get solved. but dissolved. I mean, after a while you don't bother about it, although the problem is still there.

I raised this issue on 6 feb 2013 and still no solution. I also asked my acquaintances, nobody can change the default language Some problems never get solved. but dissolved. I mean, after a while you don't bother about it, although the problem is still there.

Okulungisiwe ngu minkowski

hegi108 0 izisombululo 8 izimpendulo
Kuphostiwe

I got it!!

I downloaded from http://www.mozilla.de.

Many thanks to everybody who tried to help me.

I got it!! I downloaded from http://www.mozilla.de. Many thanks to everybody who tried to help me.
cor-el
  • Top 10 Contributor
  • Moderator
17411 izisombululo 157274 izimpendulo
Kuphostiwe

Hi minkowski

Did you try to download and save the German Firefox version and save the DMG file to your computer?

Current Firefox 20.0 release:

Hi minkowski Did you try to download and save the German Firefox version and save the DMG file to your computer? *http://download.mozilla.org/?lang=de&product=firefox-20.0&os=osx Current Firefox 20.0 release: *http://download.mozilla.org/?lang=en-US&product=firefox-20.0&os= *https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/20.0/mac/de/
devagu 0 izisombululo 3 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hi,

this may be confusing, the initial question from minkowski wanted English, instead of Polish (where minkowski is situated), not German. hegi108 joined the discussion and wanted German, not English. hegi108 solved it, no surprise since situated in a German speaking country.

Like minkowski, my system is US English, I am situated in a German speaking country, and I would like to have hegi108's problem, English Firefox.

I downloaded English-US firefox about three times and the menu is still German. (mac)

I installed the Quick locale switcher and switched my locale to en-US - locale seems ok, but the menu is still German https://addons.mozilla.org/en-US/firefox/addon/quick-locale-switcher/.

I modified general.useragent.locale to en-US in about:config, restarted, still everything in German.

I quit and deleted the prefs.js, still German.

I deleted all cookies related to moxilla and firefox, still German.

When I go to the third menu from right (Tools, I think Extras in German) > Quick Locale Switcher , the language is set to English, but the first menu option is still "Restore default de-DE".

Same when I go to the bottom right and click the language flag, I get the option Restore default (de-DE).

under Extras (Tools?) > Sprachen (Languages), there is only one language - German.

So one possibility could be, how do I get firefox to change this default to en-US? on mac.

help appreciated.

Hi, this may be confusing, the initial question from minkowski wanted English, instead of Polish (where minkowski is situated), not German. hegi108 joined the discussion and wanted German, not English. hegi108 solved it, no surprise since situated in a German speaking country. Like minkowski, my system is US English, I am situated in a German speaking country, and I would like to have hegi108's problem, English Firefox. I downloaded English-US firefox about three times and the menu is still German. (mac) I installed the Quick locale switcher and switched my locale to en-US - locale seems ok, but the menu is still German https://addons.mozilla.org/en-US/firefox/addon/quick-locale-switcher/. I modified general.useragent.locale to en-US in about:config, restarted, still everything in German. I quit and deleted the prefs.js, still German. I deleted all cookies related to moxilla and firefox, still German. When I go to the third menu from right (Tools, I think Extras in German) > Quick Locale Switcher , the language is set to English, but the first menu option is still "Restore default de-DE". Same when I go to the bottom right and click the language flag, I get the option Restore default (de-DE). under Extras (Tools?) > Sprachen (Languages), there is only one language - German. So one possibility could be, how do I get firefox to change this default to en-US? on mac. help appreciated.

Okulungisiwe ngu devagu

cor-el
  • Top 10 Contributor
  • Moderator
17411 izisombululo 157274 izimpendulo
Kuphostiwe

You first need to download and install the en-US Firefox version or another preferred language version or language pack.
After installing this version, possibly via a clean install and first delete the Firefox program folder then you need to make sure that the general.useragent.locale pref is set to the correct locale.

Note that this doesn't necessarily effect the language of pages send by a server as this can be caused by the order of installed languages in "Tools > Options > Content > Languages" and the server may do a reverse DNS look up to present you pages in the local language.

You first need to download and install the en-US Firefox version or another preferred language version or language pack.<br /> After installing this version, possibly via a clean install and first delete the Firefox program folder then you need to make sure that the general.useragent.locale pref is set to the correct locale. Note that this doesn't necessarily effect the language of pages send by a server as this can be caused by the order of installed languages in "Tools > Options > Content > Languages" and the server may do a reverse DNS look up to present you pages in the local language.