Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

All versions after 121 are corrupting my profile . Tested multiple times

  • 15 uphendule
  • 0 zinale nkinga
  • 12 views
  • Igcine ukuphendulwa ngu jdop

more options

I'm a long time FF user. Version 121 works perfectly .

 Ever since 121.01 , updating breaks EVERYTHING.   Most of my add ons cant access their data, websites dont work, etc.  
 Not only that ,  but reverting to 121 does not help.   So the profile data itself is being trashed. 
 Restoring the full profile from a backup is successful, but only with version 121.   Any version beyond that breaks it. 
 I also tried a full delete and reinstall of Firefox, but that did not work.  Same problem.
 A full rebuild of all the add ons from scratch  might be my only option at this point if we cant figure out why this is happening.
I'm a long time FF user. Version 121 works perfectly . Ever since 121.01 , updating breaks EVERYTHING. Most of my add ons cant access their data, websites dont work, etc. Not only that , but reverting to 121 does not help. So the profile data itself is being trashed. Restoring the full profile from a backup is successful, but only with version 121. Any version beyond that breaks it. I also tried a full delete and reinstall of Firefox, but that did not work. Same problem. A full rebuild of all the add ons from scratch might be my only option at this point if we cant figure out why this is happening.

All Replies (15)

more options

Should have mentioned

 Windows 10 64 bit

Helpful?

more options

What do you mean with versions beyond 121 (Beta, Developer Edition)?

Firefox 121.0.1 is still the current release, Firefox 122.0 is scheduled for release January 23.

Helpful?

more options

121.01 was the next version after 121.

 That current release and a later beta I tested  both cause the corruption 
 121.0 works fine
  I already tried a 122 beta, still a problem. 
  I should mention I've used FF pretty much since it was released , and have never seen anything like this happen .   
  I'm not getting errors messages, but something changed in that .01 release  which totally hoses the  profile. 
  Is there something I can check in the about pages ?

Okulungisiwe ngu jdop

Helpful?

more options

Doesn't look like help is forthcoming here.

Helpful?

more options

You did create or use a new/separate profile for Firefox 122 beta as downgrading a profile isn't recommended?

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works, you can transfer files from a previously used profile to the new profile, but be careful not to copy corrupted files to avoid carrying over problems.

Helpful?

more options

The problem is , everything is fine until the update.

  If something was corrupted , I'd have a problem with 121 , which I don't .  Not a thing. 
  As soon as I update FF to anything beyond 121.0   , IT is causing the corruption. 
  A new profile was tried , and of course it works, without any add-ons .   
  I also disabled all add-ons ,  and started enabling one by one, but soon ran into the same problems. 
  As I said, even going back to 121.0  after running  121.0.1    , the corruption is still present in the profile that was touched by 121.01 or later betas.  
  Clearly, this is something specific to my set of add-ons (there are about 10) , so Im going to have to rebuild  from scratch with a new Profile .     
 Would prefer to narrow down exactly what's happening, but no idea how to get to that , without some error messages .

Helpful?

more options

You don't give much detail about in what way you have a profile corruption. Extensions rely on the extensions.webextensions.uuids pref stored in about config for the UUID that links the extension to their moz-extension folder in indexedDB (storage\default). This means that if prefs are cleared, then extensions lose their settings.

You can check for issues with Storage (indexedDB).

What security software do you have in case that is causing the problem?

Helpful?

more options

Clean storage. Pic attached

 I tried to explain that most of my addons simply stop working, and websites break (reddit) . 
 Those that can still respond to icon clicks (Feedbro, Duck Duck Go Privacy) act as if there  are no  settings. 
 Distill Web Monitor, trashed. None of the saved data accessible.  
 Basically everything breaks, there is no other way to describe it.  
  I have to assume its a local problem and not universal, but seems awfully strange since Im having ZERO issues unless I do these updates. 
 Tried a bunch of permutations, and lost track of exactly what  worked and didnt.  Mostly nothing worked.
 Unless theres some way for Firefox to tell me what it doesnt like about the update, Im not going to waste 10 hours on it .     I'll do a addon   rebuild, keeping my bookmarks and other settings.   If that somehow fails then we can get medieval about it.

Okulungisiwe ngu jdop

Helpful?

more options

Try deleting extensions.databaseSchema in about:config then restart the browser.

Helpful?

more options

Haven't tried that yet, but the value is .... 35 .

Does that sound right ?

Helpful?

more options

deleting extensions.databaseSchema does nothing, and its recreated with the same 35 value

Helpful?

more options

Looks to me like the internal pointer to the storage for these add ons is destroyed, or looking in the wrong place

  Its all complicated enough, so not being familiar with the code, hard to tell if things Im seeing are bad or not, like the uuid naming looking odd to me, not matching up with what I see in the browser-extention-data folder. 
 Who knows.

Helpful?

more options

No idea if this is related, but seems odd to me that there are TWO INSTALL ID's when I only have one Firefox program install. This is profiles.ini , and installs.ini

Might be a remnant from a deleted Firefox ?

Take a look "Installs.ini"

[308046B0AF4A3956] Default=Profiles/mmgjvn3l.Amd Locked=1

[CDFCF4B7528A39A6] Default=Profiles/mmgjvn3l.Amd Locked=1


===========================================================

"Profiles.ini"


[Install308046B0AF4A3956] Default=Profiles/mmgjvn3l.Amd Locked=1

[Profile2] Name=test IsRelative=1 Path=Profiles/pajpxvo0.test

[Profile1] Name=VPN IsRelative=1 Path=Profiles/4jr1bx9c.VPN

[Profile0] Name=JoeAmd IsRelative=1 Path=Profiles/mmgjvn3l.Amd

[BackgroundTasksProfiles] MozillaBackgroundTask-CDFCF4B7528A39A6-defaultagent=aqgv7ui6.MozillaBackgroundTask-CDFCF4B7528A39A6-defaultagent

[General] StartWithLastProfile=1 Version=1

[InstallCDFCF4B7528A39A6] Default=Profiles/mmgjvn3l.Amd Locked=1

[Profile3] Name=default-release IsRelative=1 Path=Profiles/jpakkpbd.default-release

Okulungisiwe ngu jdop

Helpful?

more options

No idea if this is related, but seems odd to me that there are TWO INSTALL ID's when I only have one Firefox program install. This is profiles.ini , and installs.ini

Might be a remnant from a deleted Firefox ?

Take a look "Installs.ini"

[308046B0AF4A3956] Default=Profiles/mmgjvn3l.Amd Locked=1

[CDFCF4B7528A39A6] Default=Profiles/mmgjvn3l.Amd Locked=1


===========================================================

"Profiles.ini"


[Install308046B0AF4A3956] Default=Profiles/mmgjvn3l.Amd Locked=1

[Profile2] Name=test IsRelative=1 Path=Profiles/pajpxvo0.test

[Profile1] Name=VPN IsRelative=1 Path=Profiles/4jr1bx9c.VPN

[Profile0] Name=JoeAmd IsRelative=1 Path=Profiles/mmgjvn3l.Amd

[BackgroundTasksProfiles] MozillaBackgroundTask-CDFCF4B7528A39A6-defaultagent=aqgv7ui6.MozillaBackgroundTask-CDFCF4B7528A39A6-defaultagent

[General] StartWithLastProfile=1 Version=1

[InstallCDFCF4B7528A39A6] Default=Profiles/mmgjvn3l.Amd Locked=1

[Profile3] Name=default-release IsRelative=1 Path=Profiles/jpakkpbd.default-release

Helpful?

more options

Very feeble support here , disappointed to say the least

 Is this the best mozilla can do after  20 years ?
 Guess Im on my own

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.