Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Videos freeze when scrubbing back

  • 13 uphendule
  • 1 inale nkinga
  • 872 views
  • Igcine ukuphendulwa ngu Herry

more options

For a few months, I have encountered an issue with videos playback on my browser. On most websites (including Reddit, Dailymotion, and even some videos on YouTube), whenever I scrub back a video, it will stop for about ten seconds, while the audio keeps playing.

My current extensions are: Metamask, Bionic Reader, uBlock Origin, Return Youtube Dislike, and TWP Translate Web Pages. I have tried using Troubleshooting mode, but the problem persisted, so I think it's not because of my extension.

My OS is Opensuse Tumbleweed, with Firefox version 155.0.3. I didn't have this issue with Firefox ESR on my previous Debian 11 installation. I hope someone can find a solution for this, as it is extremely troublesome switching to Chrome whenever I want to watch videos.

For a few months, I have encountered an issue with videos playback on my browser. On most websites (including Reddit, Dailymotion, and even some videos on YouTube), whenever I scrub back a video, it will stop for about ten seconds, while the audio keeps playing. My current extensions are: Metamask, Bionic Reader, uBlock Origin, Return Youtube Dislike, and TWP Translate Web Pages. I have tried using Troubleshooting mode, but the problem persisted, so I think it's not because of my extension. My OS is Opensuse Tumbleweed, with Firefox version 155.0.3. I didn't have this issue with Firefox ESR on my previous Debian 11 installation. I hope someone can find a solution for this, as it is extremely troublesome switching to Chrome whenever I want to watch videos.
Ama-screenshot ananyekiwe

Okulungisiwe ngu xuantung.trinh.63

All Replies (13)

more options

You need ffmpeg. If you are using flatpak:

flatpak install org.freedesktop.Platform.ffmpeg-full

Otherwise:

sudo zypper install ffmpeg-5

more options
sudo zypper install ffmpeg-5

I installed it as you advised. However, the issue still remains.

Okulungisiwe ngu xuantung.trinh.63

more options

Any change if you go to about:config in the address bar and change media.gmp.decoder.enabled to false then restart the browser?

more options

zeroknight said

Any change if you go to about:config in the address bar and change media.gmp.decoder.enabled to false then restart the browser?

That still doesn't solve the problem.

I also tried changing other configs in the past, such as gfx.direct3d11.reuse-decoder-device and media.wmf.zero-copy-nv12-textures, but to no avail.

I also added a gif to the question, so you can have a clearer picture of my issue.

more options

Provide a link to video. Have you ever tried this site? ---> https://www.opensuse-community.org/

All of my laptops are Tumbling so let me see if I can replicate. Are you in X11 or Wayland? What desktop?


Operating System: openSUSE Tumbleweed 20230806 KDE Plasma Version: 5.27.7 KDE Frameworks Version: 5.108.0 Qt Version: 5.15.10 Kernel Version: 6.4.8-1-default (64-bit) Graphics Platform: X11 Processors: 16 × AMD Ryzen 7 5825U with Radeon Graphics Memory: 62.1 GiB of RAM Graphics Processor: AMD Radeon Graphics Manufacturer: HP Product Name: HP ProBook 455 15.6 inch G9 Notebook PC

more options

Here is a link to the video describing the problem: https://streamable.com/7x37o2

Have you ever tried this site? ---> https://www.opensuse-community.org/ Are you in X11 or Wayland? What desktop?

I'm currently using QtileWM and Xfce4 (X11 of course), so chose to download & install the codecs for Gnome. Still doesn't change anything, even after a reboot.

Here is the specs of my system: Host: 20UD0004CD ThinkPad T14 Gen 1 Kernel: 6.4.8-1-default DE: Xfce 4.18 WM: Xfwm4 CPU: AMD Ryzen 7 PRO 4750U with Radeon Graphics (16) @ 1.7GHz GPU: AMD ATI 07:00.0 Renoir Memory: 14.84GiB

more options

If you're experiencing issues where videos freeze when you're scrubbing back (rewinding) or fast-forwarding, there could be several reasons behind this problem. Here are some steps you can take to troubleshoot and potentially resolve the issue:

Internet Connection: Slow or unstable internet connections can cause videos to freeze during scrubbing. Make sure you have a stable and fast internet connection. If you're using Wi-Fi, try moving closer to the router or using a wired connection if possible.

Video Player: The video player you're using might have bugs or compatibility issues. Try using a different video player or updating the current one to the latest version.

Hardware Acceleration: If hardware acceleration is enabled, it can sometimes cause issues with video playback. Try disabling hardware acceleration in the settings of your video player or web browser and see if that improves the situation.

Video Format: Certain video formats might not be well-supported by your player or device. If you're experiencing this issue with a specific video, try converting it to a different format and see if the problem persists.

Device Performance: Older or less powerful devices might struggle with fast-forwarding or rewinding videos, especially if the videos are of high resolution. Ensure that your device meets the minimum requirements for playing back the videos smoothly.

Clear Cache: Clearing the cache of your video player or web browser can sometimes help resolve playback issues. Cached data can become corrupted and cause freezing.

Software Updates: Make sure that your operating system, video player, and web browser are all up to date. Sometimes, updates include bug fixes and improvements that could help resolve playback issues.

Regards, Jimmy

more options
  • I think we can rule out internet connection, as this happens everywhere everytime.
  • I already turned off hardware acceleration and cleared the cache (several times), but the problems is still not solved.
  • I also update my system daily.
more options

xuantung.trinh.63 said

I also tried changing other configs in the past, such as gfx.direct3d11.reuse-decoder-device and media.wmf.zero-copy-nv12-textures, but to no avail.

Those setting are only relevant to Windows.

Can you confirm which Firefox package you are using? If you open Help > About Firefox, does it mention flatpak?

Does it still happen with the archive package downloaded from mozilla.org?

more options

zeroknight said

Can you confirm which Firefox package you are using? If you open Help > About Firefox, does it mention flatpak? Does it still happen with the archive package downloaded from mozilla.org?

I'm using the Firefox for openSUSE package from Opensuse Repository. Definitely not from Flatpak. I haven't tried the archive package from Mozilla website yet.

UPDATE: I downloaded and used the mozilla.org's package inside my home directory, but the problem still appears.

Okulungisiwe ngu xuantung.trinh.63

more options

Isisombululo Esikhethiwe

more options

zeroknight said

Try installing ffmpeg with this guide: https://en.opensuse.org/SDB:Installing_codecs_from_Packman_repositories

I have all those codecs already (except for the vlc one, which I fathom does not relate to the issue): - ffmpeg-5 version 5.1.3-2.2 - gstreamer-plugins-bad version 1.22.5-2.1 - gstreamer-plugins-ugly version 1.22.5-2.1 - libavcodec57, libavcodec58_134, libavcodec59, libavcodec60.

However, I notice that there are other (and newer) versions of the ffmpeg package. I will try installing/updating/replacing this package and report back the result.

more options

zeroknight said

Try installing ffmpeg with this guide: https://en.opensuse.org/SDB:Installing_codecs_from_Packman_repositories

Thank you so much for your commitment in the last few days! After replacing ffmpeg-5 with ffmpeg-6, the problem has disappeared!