Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Youtube most of the time has terrible connection speed

  • 3 uphendule
  • 1 inale nkinga
  • 87 views
  • Igcine ukuphendulwa ngu cor-el

more options

Lately for the last 3ish days my YouTube connection speed on Firefox and only Firefox has been terribly slow. So slow that it can't even watch normal HD content. But not always, sometimes it does work at normal internet speeds which is so weird. I have around 500 Mbps download speed internet so I know it's not the issue. The picture with the slow download speed is on Firefox and the fast/normal download speed is on Chrome. Sometimes in a private window Firefox runs at normal speed but not always, I don't think it's an extension issue.

Lately for the last 3ish days my YouTube connection speed on Firefox and only Firefox has been terribly slow. So slow that it can't even watch normal HD content. But not always, sometimes it does work at normal internet speeds which is so weird. I have around 500 Mbps download speed internet so I know it's not the issue. The picture with the slow download speed is on Firefox and the fast/normal download speed is on Chrome. Sometimes in a private window Firefox runs at normal speed but not always, I don't think it's an extension issue.
Ama-screenshot ananyekiwe

Okulungisiwe ngu Firefox696969

Isisombululo esikhethiwe

This could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps.

See also:

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (3)

more options

Isisombululo Esikhethiwe

This could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps.

See also:

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

cor-el said

This could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps. See also: Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.
  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

The first suggestion changing the Zero Round Trip Time Resumption to false fixed the problem! What does this even do normally?

more options

See this blog page for more info: