Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 111.0 freezes on start up

  • 13 uphendule
  • 13 zinale nkinga
  • 19 views
  • Igcine ukuphendulwa ngu wolf68k

more options

I just updated to FF 111.0. After restarting FF comes up but then nothing. After a bit of I got the option to force close it. I tried opening a Private Browser and that worked fine so I figured it was one of my add-ons. However after closing the Private Browser and trying opening normally again it worked just fine. Disable all of my add-ons and for the same issue.

Renamed my AppData/Roaming/Mozilla folder and starting as normal worked fine. What a giant pain in the <bleep> trying to set everything back up.

Performed some more science and noticed this. After setting my Mozilla folder back, starting FF, and looking at the TaskManager, There would be 3 processes, one of those after a bit of time would show in red as Not Responding (or words to that effect). Clicking the window a few times to get the force close dialog again. Trying to open FF again, it opened just fine.

So I'm tempted to blame something in the update that is causing this. Yes, I could just start with a fresh Mozilla folder and reinstall all of my add-ons and blah blah blah, but whose to say that after setting everything back up the way I had it the problem won't come back.

I have thought about rolling back to FF 110.0.1, and suppressing the update check.

OS: Windows 10 64-bit Firefox: 111.0 64-bit

I just updated to FF 111.0. After restarting FF comes up but then nothing. After a bit of I got the option to force close it. I tried opening a Private Browser and that worked fine so I figured it was one of my add-ons. However after closing the Private Browser and trying opening normally again it worked just fine. Disable all of my add-ons and for the same issue. Renamed my AppData/Roaming/Mozilla folder and starting as normal worked fine. What a giant pain in the <bleep> trying to set everything back up. Performed some more science and noticed this. After setting my Mozilla folder back, starting FF, and looking at the TaskManager, There would be 3 processes, one of those after a bit of time would show in red as Not Responding (or words to that effect). Clicking the window a few times to get the force close dialog again. Trying to open FF again, it opened just fine. So I'm tempted to blame something in the update that is causing this. Yes, I could just start with a fresh Mozilla folder and reinstall all of my add-ons and blah blah blah, but whose to say that after setting everything back up the way I had it the problem won't come back. I have thought about rolling back to FF 110.0.1, and suppressing the update check. OS: Windows 10 64-bit Firefox: 111.0 64-bit

All Replies (13)

more options

I just updated to FF 111.0, and after the install FF sites with one window open and a spinning circle. The mail PID is (per ProcessExplorer) at xll.dll!XRE_GetBootstrap+0x9edde0 . The other two subordinate PIDS are at WRusr.dllSynProc+0x4910. I believe that WRusr.dll is Webroot Secure Anywhere. I cancelled the primary PID, and I restarted FF; the same thing occurred.

OS: Windows 10 64-bit 22H2 Firefox: 111.0 64-bit

more options

I just shutdown Webroot, cancelled the primary FF process. and then restarted FF. The primary PID is still waiting at the same place, but the two subsidiary PIDs are now waiting at firefox.exe!s.SandboxedProcess+0x1c30.

more options

Do either of you use any other anti-exploit-type software, or any IEAK mitigations?

more options

Anti-exploit software? I'm going to say no since I have no idea what you're talking about.

more options

I use MS Defender. I have Webroot Secure Anywhere also. There have been a few times when WRSA has prevented me from accessing a bad malware site. But I did do the test with WRSA not running. Does the info from ProcessExplorer tell you anything about what is happening?

more options

Getting the same after the update, the first time i try open firefox it will be just a blank page, opening TaskManager can see there would be 3 processes running for firefox one of those would be show in red as Not Responding, ending task and reopening firefox then run fine,

the problem will be back again then next time you close and try open firefox.

im seeing a few report of this bug on reddit and here on help forum tho no fix yet other then the nuclear option of a new profile.

it's a weird one tho as when you get it running it work fine as long as you dont close it, the bug is only in the first launch.

more options

I'm not sure which Reddit threads are relevant. I found this one:

https://www.reddit.com/r/firefox/comments/11tlk8u/woke_up_this_morning_and_firefox_on_desktop_is/

In sharing external URLs here, please break the URL before the top-level domin to avoid delays in sharing links. In other words:

https://www.reddit. com/r/firefox/

I'm trying to think of why a new profile might be helpful. Perhaps during the initial setup Firefox does an environment check and decides whether to turn on a particular feature/capability.

Has anyone tested starting Firefox in Troubleshoot Mode? That disables hardware acceleration of graphics and JavaScript compilers (as well as add-ons): Diagnose Firefox issues using Troubleshoot Mode. Hold down the Shift key when launching Firefox, then click Open in the little dialog.

more options
more options

Hi joelol, your reply is the link spam moderation queue (I can see, but can't release). Break the links

https://www.reddit. [here] com/

to avoid the queue.

more options

like this? reddit. com/r/firefox/comments/11s2293/firefox_freezes_up_on_pc_after_1110_when_trying/

reddit. com/r/firefox/comments/11r85pf/firefox_v1110_released/jc758lc/?context=3

i found it has all so been reported on bugzilla now aswell bugzilla.mozilla. org/show_bug.cgi?id=1822502

more options

Thank you for the threads.

It is interesting that other users also report that killing the stalled Firefox process and immediately restarting it works for them.

I don't know what to make of the report that it works using a desktop shortcut but not a pinned Taskbar icon.

Also, one Mac user reported the issue.

more options

The mail PID is (per ProcessExplorer) at xll.dll!XRE_GetBootstrap+0x9edde0 . The two subsidiary PIDs are waiting at firefox.exe!s.SandboxedProcess+0x1c30. Does anyone know what is occurring at these two points in the source code?

more options

joelol said

like this? reddit. com/r/firefox/comments/11s2293/firefox_freezes_up_on_pc_after_1110_when_trying/ reddit. com/r/firefox/comments/11r85pf/firefox_v1110_released/jc758lc/?context=3 i found it has all so been reported on bugzilla now aswell bugzilla.mozilla. org/show_bug.cgi?id=1822502

Thank you for this. It at least confirms it's not just me, which makes me feel better.