Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Search suggestion cannot be disabled

  • 11 uphendule
  • 0 zinale nkinga
  • 38 views
  • Igcine ukuphendulwa ngu SupportGB

more options

I have firefox set up so that it does not suggest anything except for my bookmarks.

So when I type in the address bar the only suggestions that come up are my bookmarks, no other suggestions.

For example when I need to translate something quick and want to go to the bookmarked page for google translate as soon as I type "trans..." it will suggest the link, Which is what I want and expect and is efficient.

But as has happened before, now I get a random suggestion coming up first so I have type more just to get to the same result otherwise I end up following a link to a suggested site which is at best aggravating.

I checked my seeting and there is one box ticked in the search suggestion settings that I cannot disable. I have tried and it always comes back.

How can I fix this?

Thanks in advance.

I have firefox set up so that it does not suggest anything except for my bookmarks. So when I type in the address bar the only suggestions that come up are my bookmarks, no other suggestions. For example when I need to translate something quick and want to go to the bookmarked page for google translate as soon as I type "trans..." it will suggest the link, Which is what I want and expect and is efficient. But as has happened before, now I get a random suggestion coming up first so I have type more just to get to the same result otherwise I end up following a link to a suggested site which is at best aggravating. I checked my seeting and there is one box ticked in the search suggestion settings that I cannot disable. I have tried and it always comes back. How can I fix this? Thanks in advance.
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

You can check for problems with preferences. You can delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

If you use external cleanup software like CCleaner, check the settings for Firefox.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 3

All Replies (11)

more options

If you have disabled the search suggestions like your screenshot shows then that choice doesn't apply. You need to enable the two settings above it temporarily to be able to untick that specific search setting.

I assume that you modified these settings as well ?

You can set what suggestions show when you enter an URL in the location/address bar bar.

  • Settings -> Privacy & Security
    Address Bar: When using the location bar, suggest:
    History
    Bookmarks
    Open tabs
    Top sites
    Shortcuts
    Search Suggestions
more options

I appreciate you responding, however I had already tried that before posting the question. THe box just becomes re checked as soon as you refresh firefox.

So I am still left with issue.

The only suggestions coming up when I type in the address bar should be my bookmarks, that's it.

more options

What do you mean with "as soon as you refresh firefox" ?

If you use the Firefox refresh feature then a new profile will be created and you lose settings.

more options

Simply put, your suggestion does not work.

As soon as I try to type an address in the address bar then I get suggestions that are not from my bookmarks.

And when I go back to my settings to check, the box is checked again.

I have done this signed in to my firefox acct and signed out, it doesn't make a difference.

The checked box which I showed in the image in my original post always returns and I am getting suggestions in the address bar when I start typing other than my bookmarks.

Perhaps there is someone else that has an idea how to resolve this?

more options

Anyone else able to help with this.

It is really annoying and the fact that I cannot set it up the way it was is very frustrating.

Any help appreciated.

more options

Just go to Settings -> Search -> Search suggestions, and then you can choose what you need.

more options

SupportGB said

Just go to Settings -> Search -> Search suggestions, and then you can choose what you need.

Sorry, but this does not help.

Please read the original post with attached screenshot and previous comments and then see if you can help.

more options

Dropa said

Your reply to what your referring to Refresh don't make sense... I can change mine and have no issue when closing and opening Firefox. Did you change Firefox defaults using userChrome.css or other 3rd party Addon/extension.

OK so forget the word refresh, when I close firefox after making the changes it will revert back to the previous setting when I open firefox again.

So when I start typing in address bar it should only show my bookmarks but instead it also shows suggestions.

This is the problem.

No I did not make any changes to firefox defaults using userhcrome.css or other 3rd party Addon/extension.

Previously It worked as it should have.

This is not the first time this has happened either, it comes after an update to firefox. But this time I have not been able to revert it to the way I want it.

more options

Isisombululo Esikhethiwe

You can check for problems with preferences. You can delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

If you use external cleanup software like CCleaner, check the settings for Firefox.

more options

cor-el said

You can check for problems with preferences. You can delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases. You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory). If you use external cleanup software like CCleaner, check the settings for Firefox.

Thankyou for this!

So for some reason the profile that I was using was the problem.

When I opened the alternate profile and tweaked the settings everything worked as I wanted.

Just means I have to set everything up again, but small price to pay.

Thank you so much, have a great day!

more options

mdamarell schrieb

SupportGB said

Just go to Settings -> Search -> Search suggestions, and then you can choose what you need.

Sorry, but this does not help.

Please read the original post with attached screenshot and previous comments and then see if you can help.

We are very sorry that we could not help you, SupportGB is based on videos, answers and questions from the Internet and is not personal to the question to cut, nevertheless, it often agrees. We would be pleased if you could describe your question in detail so that we can answer you individually.