Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

the latest firefox update overfills my screen so I can't see or access words, links or whatever on top, bottom and sides. Unusable now.

  • 12 uphendule
  • 1 inale nkinga
  • 54 views
  • Igcine ukuphendulwa ngu Paul

more options

I don;t know if I chose the right "best describes the question" because the first half of the option is off the screen to the left, and there's no way to scroll over. I would like to go back to the version that preceded this latest update please. It worked well. Please reply by email, [email-removed], because I can't read most of what's on the screen here. I hope someone pays attention to this, because otherwise I'll have to abandon Firefox, and it's been by far my preferred browser. Can't think what you've done to it. Your updates in the past all worked fine. I'm on a Lenovo ThinkPad S145 with Windows10.

I don;t know if I chose the right "best describes the question" because the first half of the option is off the screen to the left, and there's no way to scroll over. I would like to go back to the version that preceded this latest update please. It worked well. Please reply by email, [email-removed], because I can't read most of what's on the screen here. I hope someone pays attention to this, because otherwise I'll have to abandon Firefox, and it's been by far my preferred browser. Can't think what you've done to it. Your updates in the past all worked fine. I'm on a Lenovo ThinkPad S145 with Windows10.

Okulungisiwe ngu cor-el

Isisombululo esikhethiwe

My suggestion about the xulstore.json file is related to the outer size of the Firefox window, not the content of the window. This is ancient advice, not related to any changes in recent years.

Two other things you can do are (A) work with a maximized window, or (B) shrink a resizable window. The oldest of old school methods for those are:

Press Alt+Spacebar to drop a control menu from the upper left of the window. The menu varies based on whether the window is already maximized or is resizeable:

If a resizable window is too big, you can maximize it to stay within the bounds Windows allows for maximized windows, or manually resize it. To resize manually:

  • Alt+Spacebar
  • tap S
  • tap the Right arrow key to select the right edge
  • hold down the Left arrow key to move the right edge inwards
  • when it reaches a good place, press Enter to save the position
  • Alt+Spacebar
  • tap S
  • tap the Down arrow key to select the bottom edge
  • hold down the Up arrow key to move the bottom edge upwards
  • when it reaches a good place, press Enter to save the position
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (12)

more options

Anything here that helps ?

  • /questions/1384204 SINCE THE LAST UPDATE, THE FIREFOX SCREEN DOES NOT FIT MY SYSTEM SETTING(125%)

Helpful?

more options

I appreciate the information, very much, but as I can't access the address bar or indeed any navigation or other input areas, I can't even try it. I did rescale my desktop on Windows, but as you point out, Firefox has decided to override that. Do they only serve those with massive screens now? I'm so disappointed to lose Firefox, but I guess it's Opera from now on. I'll continue to bring it up periodically, to see if they've had the sense to do another update that solves this issue, but... what else can I do?

Helpful?

more options

BTW - I clicked a thumbs-up because I appreciated the information, but the algo seems to think this has "Solved the problem". It hasn't.

Helpful?

more options

Firefox 103 now applies the Windows "Make text bigger" setting as a zoom multiplier (Release Notes).

Your options:

(A) If you do not need "Make text bigger" for other applications, the simplest thing you can do is reset that to 100% to resolve the issue:


(B) Firefox 103 has 3 interrelated hidden settings that control the overall zoom level and whether it considers information from the system. This one seems to be working for many people to revert the change -- are you able to do this with the extreme enlargement?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste ui.textScaleFactor and pause while the list is filtered.

Normally, Firefox will display a bar with Boolean Number String and a plus button. If Firefox displays a row that already has a number value, skip to step 5.

(3) Click the circular button in front of Number and then click the + button to create a new preference. (See composite screenshot below.)

(4) Firefox should display an editing field, and show a value of 0 -- edit the value to 100 then press Enter or click the blue check mark button to save the change.

(5) If the current value of ui.textScaleFactor is NOT 100, then double-click the preference to display an editing field, and change the value to 100 then press Enter or click the blue check mark button to save the change.

Helpful?

more options

vshelford said

I appreciate the information, very much, but as I can't access the address bar or indeed any navigation or other input areas, I can't even try it.

How much browser can you see? I can suggest how to create and drop in a settings file, but the easiest way to access the folder where you'll need to drop the file is to click a button on an internal page. See whether you can get this far.

  • Start Firefox
  • Open the Troubleshooting Information page by pressing Alt+H to drop the Help menu, then T to open the page
  • Scroll down to the "Profile folder" line, and click the "Open Folder" button to launch a new Windows File Explorer window listing your profile folder contents

Can you get that far?

Helpful?

more options

Thank you! Yes, the final step was tricky, as I had to guess on which line it was on, but I got into the Windows Explorer file. Now what? (I won't be able to pursue this further until tomorrow, but will definitely follow whatever advice you suggest. Thank you for taking the time!)

Helpful?

more options

Okay, what you're going to do is create a file named user.js with one line of code, and then restart Firefox. At startup, Firefox will read that file and apply its settings. (Then you can remove the file as it has done its job.)

The contents of the file will be simple:

user_pref("ui.textScaleFactor", 100);

However, you need to make sure to create a .js file and not a .js.txt file, otherwise Firefox will ignore it.

Preliminary Step

(1) Set Windows to show all file extensions. This page has the steps, although I guess you'll need to view this article in a different browser:

https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

In Windows File Explorer

(2) Right-click a blank area of the profile folder and choose New > Text Document

Windows will create the file with the initial name "New Text Document.txt" and highlight it for renaming. (If Windows doesn't highlight it for renaming, right-click > Rename on the file.)

(3) Rename the file to user.js making sure to delete the .txt file extension. When you press Enter to save the name, Windows will ask if you know that changing a file extension can cause issues. Confirm that.

(4) Right-click the file and choose Edit. If Windows asks you what program to use, Notepad is fine, this is simple one. The only catch here is not to use a program that inserts any formatting codes, the more basic the editor, the better.

(5) In the editor, paste the code

user_pref("ui.textScaleFactor", 100);

Then save the file (Ctrl+S or File > Save).

You're ready to restart Firefox. Firefox should import that value into your settings and, presumably, will apply it immediately.

Success?

Helpful?

more options

Once again, thank you for plugging away at this. It did have an effect, but not the intended one. It used to cover the whole screen except the bottom bar where you can access the start button and the icons of the programs in use. It took the "100%" part seriously, and covered that too, without diminishing the loss of top and sides within the program. I had to use ctrl-alt-del to get the task manager up to close it again. What were the people thinking, who threw this at us???

Helpful?

more options

Hi, the textScaleFactor doesn't set the window size, that probably got messed up by the too large state. Hopefully you can get "maximized" windows back to filling everything above the Taskbar but, if not, you can remove a settings file to clear stored window and dialog sizes. I'll give the details below, but wouldn't try this as the first step.


Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > Help > More Troubleshooting Information
  • (menu bar) Help > More Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then:

Right-click xulstore.json then Rename to something like xulstoreOLD.json

Start Firefox back up again. Do windows display normally again?

That mini-reset may hide the bookmarks toolbar and/or menu bar. You can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key or F10 key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

Helpful?

more options

The "too large" state IS the problem, it never was the text size. I'm not sure what your next suggestion will do except take me back to where we were, which I can also do by uninstalling Firefox and reinstalling it without the .js file in there. And the instructions for getting the bars back doesn't help, because the bars are there, they are just off the screen. Also, you said you don't suggest this as a first step. I'm not sure what you mean. Is there something else I should do first? I've already screwed it up with the first, first step... I can't tell you how pissed off I am with the designers of this "update". I'd be curious to know how many users they're losing because of it. My system is as ordinary as it comes.

Helpful?

more options

Isisombululo Esikhethiwe

My suggestion about the xulstore.json file is related to the outer size of the Firefox window, not the content of the window. This is ancient advice, not related to any changes in recent years.

Two other things you can do are (A) work with a maximized window, or (B) shrink a resizable window. The oldest of old school methods for those are:

Press Alt+Spacebar to drop a control menu from the upper left of the window. The menu varies based on whether the window is already maximized or is resizeable:

If a resizable window is too big, you can maximize it to stay within the bounds Windows allows for maximized windows, or manually resize it. To resize manually:

  • Alt+Spacebar
  • tap S
  • tap the Right arrow key to select the right edge
  • hold down the Left arrow key to move the right edge inwards
  • when it reaches a good place, press Enter to save the position
  • Alt+Spacebar
  • tap S
  • tap the Down arrow key to select the bottom edge
  • hold down the Up arrow key to move the bottom edge upwards
  • when it reaches a good place, press Enter to save the position

Helpful?

more options

Hi

While there is not an easy way to revert this our product team did suggest this about:config preference change as the optimal solution at this time.

  1. In the address bar, type about:config and press the Enter key.
  2. The about:config warning page may appear. Click Accept the Risk and Continue to continue to the about:config page.
  3. In the search field, enter browser.display.os-zoom-behavior, select the pencil "edit" icon and change the number to 0.
  4. Select the check mark and restart Firefox.

They did note they would look into alternative options which may be present in a future update.

WARNING from the moderator team: Changing Firefox pref from the about:config page can sometimes break Firefox or cause strange behavior. You should only do this if you know what you're doing.

Please read Firefox advanced customization and configuration options to learn more.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.