Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Access to HSBC online banking

  • 4 uphendule
  • 1 inale nkinga
  • 95 views
  • Igcine ukuphendulwa ngu FredMcD

more options

For years I’ve had no difficulty accessing online my HSBC bank accounts in UK using Firefox. In recent days they have changed their security access method whereby their site now requests a security number generated on one’s phone using the HSBC App (it used to be a random number from an HSBC supplied handheld device) which then has to be input via my Windows 10 PC to access my data. If I use Microsoft Edge as browser, everything works fine, but when I try Firefox my system just hangs after I’ve put my bank ID into the HSBC opening page (the first security step) and simply never opens the next HSBC page which would ask me to generate the said code on my phone. Seems a browser related problem. Any ideas why Edge works but Firefox does not?

For years I’ve had no difficulty accessing online my HSBC bank accounts in UK using Firefox. In recent days they have changed their security access method whereby their site now requests a security number generated on one’s phone using the HSBC App (it used to be a random number from an HSBC supplied handheld device) which then has to be input via my Windows 10 PC to access my data. If I use Microsoft Edge as browser, everything works fine, but when I try Firefox my system just hangs after I’ve put my bank ID into the HSBC opening page (the first security step) and simply never opens the next HSBC page which would ask me to generate the said code on my phone. Seems a browser related problem. Any ideas why Edge works but Firefox does not?

Isisombululo esikhethiwe

This is called 2FA (Two-Factor Authentication).

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

Isisombululo Esikhethiwe

This is called 2FA (Two-Factor Authentication).

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

Are you using the VPN when this happens or is the VPN disabled when you access the bank site (recommended) ?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

See also:

more options

Thanks very much FredMcD. Safe mode demonstrated new 2 step authentication on personal banking HSBC site working fine with Firefox. Subsequent tests isolated the problem to the Privacy Possum add-on I was using. Once disabled so was the problem. Also thanks cor-el. I had suspected VPN first off, but had proved that wasn't the problem. Job done thanks to you guys!

more options

Glad to help. Safe Surfing.


As to Privacy Possum: Load the web page. After the page is loaded, click the AdBlock icon. Now select Disable on <website>. After, reload the page.