Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Font Corruption on Sent emails compared to Composed/Write emails

  • 44 uphendule
  • 1 inale nkinga
  • 464 views
  • Igcine ukuphendulwa ngu david

more options

When I compose/write a new email the text correctly displays the font and size I have selected In PREFERENCES -COMPOSITION - HTML STYLE which is Times New Roman with FONT SIZE selected as Medium.

However when I view the very same email composed with line and length and breaks fitting Times New Roman Medium in my SENT box the font and size has been changed to what appears to be a HELVETICA font with the SIZE being larger than medium and this causes sentence wraparounds and corruption of the entire appearance of the email composed/written

How and what do I set to ensure the compose/write fonts display the same in SENT/RECEIVED.

When I compose/write a new email the text correctly displays the font and size I have selected In PREFERENCES -COMPOSITION - HTML STYLE which is Times New Roman with FONT SIZE selected as Medium. However when I view the very same email composed with line and length and breaks fitting Times New Roman Medium in my SENT box the font and size has been changed to what appears to be a HELVETICA font with the SIZE being larger than medium and this causes sentence wraparounds and corruption of the entire appearance of the email composed/written How and what do I set to ensure the compose/write fonts display the same in SENT/RECEIVED.

Isisombululo esikhethiwe

Miles, I'm never sure how you're sending messages. If you follow instructions carefully - - setting LATIN to desired font and size - setting OTHER WRITING SYSTEMS to desired font and size - setting composition for HTML to 'variable width' and medium font (You can see this when composing if the font 'variable width' is shown, not times roman. )

then your recipients would see your mail in their font and size, not yours. But if they are seeing your messages in your font and size, then you are sending HTML with times roman set as default. Can you post that outgoing mail showing source code? That may confirm what you're doing.

And, if you do send in HTML, one of the downsides is that responses may be different, because in HTML you will receive messages based on THEIR chosen font size. The downside of HTML (with email clients other than TB) there is ALWAYS a default font size, so recipients are always seeing mail as the sender prefers. I would like to help you wrap this up, so please send a message to me directly at dskirk at gmail dot com and then we can wrap this up more quickly.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (20)

more options

In viewing sent mail, click cntl-U to view source and confirm that it is your preferred font in the HTML code. Could you please post a small sample of this, one screenshot in compose window and another in sent or draft folder? Normally, they should be the same.

As an aside, if your preference for Times Roman is only for your own viewing, you can achieve this in Tools>Preferences>General and avoid reliance on HTML.

more options

Good Morning David:

Please find attached 3 files for (1) Write/Compose test email using the correct TR Medium Font, (2) the test Sent email in showing non TR (Arial or Helvetica) and (3) the actual view of the different file showing non TR (Arial or Helvetica) font received together with the Control U output.

Regards, Miles Conway.

more options

Thanks, Miles. Only one screenshot showed up, but it may be of value. It shows that you do not have Times Roman configured as your default in tools>preferences>Compose. Seeing the other screenshots will help. Until then, my inference is that you have font setting, at least partially, in tools>preferences>general. For now, it's puzzling. I look forward to more screenshots. This time, please also include a screenshot of your font settings in tools>preferences>general. Thanks.

more options

Attached is tools, preference, compose setting of TR Medium.

I will have to send another jpeg separately as I am having size limitation problems and this platform does not allow pdfs.

more options

Smaller control U file.

more options

Miles, The cntl U shows that it is not Times Roman, but the font you specified in tools>preferences>general. Per my earlier response, you can specify TimesRoman there, if intended only for your viewing. I do not know why the default composition is not times roman, but I saw that in earlier post. Do you have any addons that might influence font use? If you want outgoing mail to be in TimesRoman, I suggest you reconfigure that again. To see if it works, click to compose a message and you should see that in compose window, not 'Variable Width'. That's where the problem lies for your HTML compositions. Let me know.

more options

The only add on I have is the import/export NG which I cannot believe would impact fonts. My preferences general IS set as TR as per attached screenshot as are my advanced setting as shown. When I launch WRITE the viewing box shows TR alone and when I start to actually type it changes to TR san serif as shown in the screen shots.

I cannot understand with all settings in TR how SENT changes to an Arial/Helvetica class of font when that is not set anywhere ?

more options

First, you're making progress. The first screenshot you posted showed 'variable width', so your new emails should be in HTML with a font specified. For tools>preferences>general, you showed settings for Latin. Please ALSO do duplicate settings for 'Other Writing Systems' from the same pulldown menu and click OK when done. If both are set, your emails will show to you as Times Roman, whether recipient sees it or not. You can test that by resetting the Compose font to variable width. Then compose a message and it should appear in times roman even though compose window says variable width. And that may be what you wanted all along.

However, if your intent is that recipients see your messages in TimesRoman, then I suggest you reinstall TB on top of your current one. It should not change to sans serif, times roman when you start typing. If you want to see exactly what is being inserted as HTML as you type, you may want to add the addon, Thunderbirdhtmledit, as that adds a tab on compose window to let you toggle to.from HTML view while composing. Let me know how it goes. If the solution in paragraph one works for you, then you can mark this closed. Otherwise, let's keep on.

more options

I have made some progress in that compose, sent and received are all now showing TNR serif text.

The incompatibility I am now running into is the different font size.

In compose mode the TNR text showing looks about 10pt - the Pref Compo setting in the HTML section is TNR LARGE

In the Sent and received emails the TNR text is larger either 12 or 14pt - the Pref Compo Fonts& Colors Default Font is TNR 12

                                                                                                                      -  the advanced settings are shown in the attached file.

How do I bring these compose/sent/received TNR font sizes into parity - which Pref setting controls which

more options

Just try this before you waste more time on fonts.

Go to preferences / Options / Settings and search on Plain. In the send options button make sure send messages in plain text if possible is not selected. This setting removes all font settings when enabled ;)

This sounds like a conversion issue to me, not a font issue.

Note: Sending messages in plain text and HTML is a maximum compatibility thing and should be selected, even if you never want to send a plain text message. Please resist the urge to set it to HTML. Someone getting your mail might need it to be plain text to suit their phone or something

more options

Sorry Matt, but where is Preferences / Options ? Is it under General or Composition. I cannot find it under either subsection

more options

That location is tools>preferences>composition>HTML Style and a button 'send options'. However, I have the plain text option ticked and it has never interfered with HTML messages.

Please continue with my earlier post as that will free you from HTML dependency in composing and viewing messages in Times Roman.

more options

Good Morning David:

I have followed you most recent instruction to the T by checking the plain text box.

It does not fix the font size problem of composing in TNR in Large which display at 10pt and send receive text being 14pt ?

If I choose EXTRA LARGE is display in 12pt and send and received is 16pt.

So send and receive inflates the size of the compose of the HTML font size selection

more options

Dave/Matt:

Please be aware in previous version of TB I never encountered this problem as a send and receive character coding control box was available. See attached screenshot.

Does TB91 have a similar control box as this appears to be where fonts and font size is controlled both at the front and back end.

more options

Miles, YES, this is the panel I've been referencing at tools>preferences>general>fonts&Colors and the advanced button. Set this for LATIN and OTHER WRITING SYSTEMS to the font of your choice and the font size of your choice. Both must be set. Please set the tools>preferences>composition settings back to 'variable length' and medium font as that is not where the problem is. Once you have both the latin and other writing systems matching, you will have consistent font for composing and reviewing in sent folder. AND, your recipients can view in whatever font they wish. And you still will enjoy the ability to set HTML characteristics, such as bold, italic, etc., in compositions.

However, if what you want is for recipients to see TimesRoman, then the preferences/composition area is where to set that. But, you're getting a bug there, as it changes to sanserif,times roman when you do that. If that is your goal, you may need to reinstall TB to see if that fixes the issue. Please don't mix the solutions on this paragraph with the prior paragraph. They are two different approaches. Both will show in sent folder and compose window alike, once you establish the right compose font.

more options

David:

I think The Other Writing Systems setting to the same as Latin may have fixed it.

It is as is intended on my side and I am waiting for confirmation from a number of my colleagues to see their screenshots of what they received.

Stay tuned but I think you may nailed it ...... ?

more options

Sounds great. You can also see this if you have web access to your account. The recipients will see the message in their own font, not TimesRoman. This solution frees you from needing to deal with HTML display on different computers. If all is well, be sure to close this thread so it will be deleted from open issues list. I've enjoyed working with you.

more options

Good Afternoon David:

(1) I followed your prior instruction to reset HTML style back to MEDIUM from the prior setting of LARGE and unfortunately doing that it does indeed upset the apple cart by changing the size of composition which in turns changes the sizes of sent and received from the desired 12pt TNR. I have re-set it back to large which is back to where I was satisfied with what I was generating on my end.

(2) That said, an unexpected result has now arisen from the feedback I received from my recipients in the 90% of them are indeed receiving TRM 12pt emails from me. The unexpected portion is that when they forward back to me the 12pt version of the email I am now receiving that back is a smaller pt size compared to 12pt sent and 12 pt received by them.

This not a train smash but the forwarded text it is just a little difficult to read as it is closer to 8-9pt.

(3) Could you please advise when in Pref/Compo do I reset "variable length" - under "send options there is no variable length options.

more options

Isisombululo Esikhethiwe

Miles, I'm never sure how you're sending messages. If you follow instructions carefully - - setting LATIN to desired font and size - setting OTHER WRITING SYSTEMS to desired font and size - setting composition for HTML to 'variable width' and medium font (You can see this when composing if the font 'variable width' is shown, not times roman. )

then your recipients would see your mail in their font and size, not yours. But if they are seeing your messages in your font and size, then you are sending HTML with times roman set as default. Can you post that outgoing mail showing source code? That may confirm what you're doing.

And, if you do send in HTML, one of the downsides is that responses may be different, because in HTML you will receive messages based on THEIR chosen font size. The downside of HTML (with email clients other than TB) there is ALWAYS a default font size, so recipients are always seeing mail as the sender prefers. I would like to help you wrap this up, so please send a message to me directly at dskirk at gmail dot com and then we can wrap this up more quickly.

more options

Dear David:

This email has been sent to you with the below and I have followed all of your instructions EXACTLY with the exception of the Medium as that selection reduced everything by at least 2pts.

I am as frustrated as you are and also wish to get this wrapped up.

For decades I used TB 2.0 and have never, ever encountered this level of difficulty with simple fonts and sizes.

The only reason I upgraded to TB 91.1 is because of all of the remote code loading which choke TB 2.0 but for that I would have happily and reliably stayed where I was.

I have posted a screenshot jpeg of this email to you.

Regards, Miles Conway

  1. 1
  2. 2
  3. 3