X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Links from external applications aren't opening in Firefox

Kuphostiwe

When I have Firefox 67 (FF) set as my default browser in Windows 10, embedded hyperlinks in third party applications won't open in FF. If I change my default browser to Edge or Chrome these links will open in either application but if I switch back to FF as the default browser they won't open again in FF.

Is there a setting somewhere I could have accidentally set when implementing the privacy features within FF or is there some other reason someone can assist with as to why this would start happening.

Thanks.

When I have Firefox 67 (FF) set as my default browser in Windows 10, embedded hyperlinks in third party applications won't open in FF. If I change my default browser to Edge or Chrome these links will open in either application but if I switch back to FF as the default browser they won't open again in FF. Is there a setting somewhere I could have accidentally set when implementing the privacy features within FF or is there some other reason someone can assist with as to why this would start happening. Thanks.

Isisombululo esikhethiwe

Thanks for your help My_Cheese_Is_Slippin'.

I've just upgraded to Firefox 68 and it now functions as expected.

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

UBlock Origin Firefox Containers OneTab Bloody Vikings! FoxyTab Grammarly Enhance for YouTube Bitwarden

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Eminye Imininingwane

My_Cheese_Is_Slippin'
  • Top 10 Contributor
39 izisombululo 453 izimpendulo
Kuphostiwe

Hi Andrew, In Windows Settings -> Apps -> Default Apps -> Set Defaults by App you should see htm, html, http and https set for Firefox (see screenshot).

Hi Andrew, In Windows Settings -> Apps -> Default Apps -> Set Defaults by App you should see htm, html, http and https set for Firefox (see screenshot).
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

Thanks but these are already set as FF as default.

Thanks but these are already set as FF as default.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 10 Contributor
39 izisombululo 453 izimpendulo
Kuphostiwe

Hello again, Are the hyperlinks for opening files, like pdf's, or for websites?

Hello again, Are the hyperlinks for opening files, like pdf's, or for websites?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Websites

Websites
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 10 Contributor
39 izisombululo 453 izimpendulo
Kuphostiwe

Hi, Firefox has a Safe Mode which disables your add-ons. You can rule out those as interfering with hyperlinks. Click the Menu button (3-bar button) Select Help Select Restart With Add-ons Disabled Firefox will start up with the Firefox Safe Mode dialog. Don't choose Refresh. Try a hyperlink and see if it opens in Firefox.

To Exit Safe Mode close Firefox.

Hi, Firefox has a Safe Mode which disables your add-ons. You can rule out those as interfering with hyperlinks. Click the Menu button (3-bar button) Select Help Select Restart With Add-ons Disabled Firefox will start up with the Firefox Safe Mode dialog. Don't choose Refresh. Try a hyperlink and see if it opens in Firefox. To Exit Safe Mode close Firefox.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

Thanks but that unfortunately doesn't resolve the issue.

Thanks but that unfortunately doesn't resolve the issue.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 10 Contributor
39 izisombululo 453 izimpendulo
Kuphostiwe

Andrew, I've looked through some other posts with the same issue and it appears that you might have some Registry problems. Hyperlinks from any program other than firefox will not open hyperlink in outlook will not open

You may need to completely uninstall Firefox, clean up your registry and re-install Firefox. You will be able to restore your Profile with all of your bookmarks, passwords, history, etc. See these articles: Back up and restore information in Firefox profiles Firefox keeps crashing at startup (Scroll down to Try a clean install)

Of course, you can wait to do this, and maybe someone with a less dramatic solution can help.

Andrew, I've looked through some other posts with the same issue and it appears that you might have some Registry problems. [https://support.mozilla.org/en-US/questions/1260781?page=1 Hyperlinks from any program other than firefox will not open] [https://support.mozilla.org/en-US/questions/1204353#answer-1136652 hyperlink in outlook will not open] You may need to completely uninstall Firefox, clean up your registry and re-install Firefox. You will be able to restore your Profile with all of your bookmarks, passwords, history, etc. See these articles: [https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles Back up and restore information in Firefox profiles] [https://support.mozilla.org/en-US/kb/firefox-keeps-crashing-startup Firefox keeps crashing at startup] (Scroll down to Try a clean install) Of course, you can wait to do this, and maybe someone with a less dramatic solution can help.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Isisombululo Esikhethiwe

Thanks for your help My_Cheese_Is_Slippin'.

I've just upgraded to Firefox 68 and it now functions as expected.

Thanks for your help My_Cheese_Is_Slippin'. I've just upgraded to Firefox 68 and it now functions as expected.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 10 Contributor
39 izisombululo 453 izimpendulo
Kuphostiwe

Great news! I'm glad that you didn't have to go through a time consuming solution.

Great news! I'm glad that you didn't have to go through a time consuming solution.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.