X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

"Turn blocking off for this site" option is missing

Kuphostiwe

Well... The option to turn off content blocking on a site is missing, not there, invisible, gone, unavailable and or otherwise not reachable for me in the Control Center Panel that comes up when I click the shield icon like the many pages and levels of your support insists it is.

Finally figured out how to at least get here to try and email someone or thing capable of more than telling me its there. Please advise how to do whatever magic is required to retrieve this option.

And please pardon me for being a little short but I've been clicking on "contact us" and getting looped back to FAQ's for it seems like hours.. and oddly enough the answer never changed and the option to turn off blocking has yet to magically appear. I had expected to come to something like this page when I clicked on "Contact Us" at the bottom of the webpage as is customary.

Specifically the site Funimation.com seems to think I'm blocking them as no streaming content will play through my premium account now.

The only other blocking I have is Hostman (a custom host file utility which I can and have easily turned off).

Well... The option to turn off content blocking on a site is missing, not there, invisible, gone, unavailable and or otherwise not reachable for me in the Control Center Panel that comes up when I click the shield icon like the many pages and levels of your support insists it is. Finally figured out how to at least get here to try and email someone or thing capable of more than telling me its there. Please advise how to do whatever magic is required to retrieve this option. And please pardon me for being a little short but I've been clicking on "contact us" and getting looped back to FAQ's for it seems like hours.. and oddly enough the answer never changed and the option to turn off blocking has yet to magically appear. I had expected to come to something like this page when I clicked on "Contact Us" at the bottom of the webpage as is customary. Specifically the site Funimation.com seems to think I'm blocking them as no streaming content will play through my premium account now. The only other blocking I have is Hostman (a custom host file utility which I can and have easily turned off).

Isisombululo esikhethiwe

karen72687 said

I can look at the cookies, go to firefox content blocking, or popup permissions. I'm not able to add or change anything.

The different site lists on the Options/Preferences page work differently:

  • Content Blocking section => Manage Exceptions button: you can remove, but not add sites that are allowed to track
  • Cookies and Site Data section => Manage Permissions button: you can add (Allow, Allow for Session, Block) and remove cookie permissions
  • Permissions section => Exceptions button to the right of "Block pop-up windows": you can add (Allow) and remove popup permissions
Funda le mpendulo ngokuhambisana nalesi sihloko 1
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 28.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Three initial thoughts:

(1) Is there an error message shown by the site that would provide more direction, or just blank space?

(2) If the site uses DRM on its videos, make sure that is enabled in Firefox. See: Watch DRM content on Firefox.

(3) Your Firefox reported having a rather old Flash plugin, so please update that in case the site needs Flash: Flash Plugin - Keep it up to date and troubleshoot problems


If you have a shield icon in the site identity area, then you should have a section of the drop-down for Content Blocking. I can't think of a reason for it to be missing. Is there only one site where it's missing?

I'm attaching a screenshot from my visit to the home page in a private window (with standard/basic content blocking enabled) for comparison.

Do you have a shield icon without a Content Blocking section on other sites, or just this one?

Three initial thoughts: (1) Is there an error message shown by the site that would provide more direction, or just blank space? (2) If the site uses DRM on its videos, make sure that is enabled in Firefox. See: [[Watch DRM content on Firefox]]. (3) Your Firefox reported having a rather old Flash plugin, so please update that in case the site needs Flash: [[Flash Plugin - Keep it up to date and troubleshoot problems]] ---- If you have a shield icon in the site identity area, then you should have a section of the drop-down for Content Blocking. I can't think of a reason for it to be missing. Is there only one site where it's missing? I'm attaching a screenshot from my visit to the home page in a private window (with standard/basic content blocking enabled) for comparison. Do you have a shield icon without a Content Blocking section on other sites, or just this one?
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17416 izisombululo 157344 izimpendulo
Kuphostiwe

You can check the Web Console to see if there is detail available about blocked content.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

See also:

You can check the Web Console to see if there is detail available about blocked content. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Web_Console ---- If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems See also: *https://support.mozilla.org/en-US/kb/tracking-protection *https://support.mozilla.org/en-US/kb/content-blocking
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
Pj 42 izisombululo 869 izimpendulo
Kuphostiwe

kenjesse said

The option to turn off content blocking on a site is missing, not there, invisible, gone, unavailable and or otherwise not reachable for me in the Control Center Panel that comes up when I click the shield icon...

Have you tried to switch to 'Standard' Content Blocking in the Options area - Privacy & Security?


~Pj

''kenjesse [[#question-1255000|said]]'' <blockquote> The option to turn off content blocking on a site is missing, not there, invisible, gone, unavailable and or otherwise not reachable for me in the Control Center Panel that comes up when I click the shield icon... </blockquote> Have you tried to switch to 'Standard' Content Blocking in the '''Options''' area - '''Privacy & Security'''? ~Pj
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
karen72687 0 izisombululo 4 izimpendulo
Kuphostiwe

Impendulo Ewusizo

I am trying to turn off content blocking for my website. I have paypal buttons and they are not working. When I go into content blocking below cookies there should be a check box to turn off content blocking for my website, but there is none. I put paypalobjects in allow for cookies but it's showing under third party cookies and is not allowing. I've reinstalled firefox 67 (3) times and it's still the same. Help me fix this please. Thanks.

I am trying to turn off content blocking for my website. I have paypal buttons and they are not working. When I go into content blocking below cookies there should be a check box to turn off content blocking for my website, but there is none. I put paypalobjects in allow for cookies but it's showing under third party cookies and is not allowing. I've reinstalled firefox 67 (3) times and it's still the same. Help me fix this please. Thanks.
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Hi karen72687, your Firefox is blocking Tracking Cookies, but the PayPal cookie is listed under third party, not tracking, so Firefox isn't blocking that cookie. I think the problem is something else, but I can't tell what it is.


You could create a cookie exception for it anyway if you like. I think you need to enter the exception(s) under cookies. Here's how:

On the Privacy & Security panel, Cookies & Site Data section, click Manage Permissions... and then paste each of these addresses and click the Allow button after each one. Finally, click Save Changes at the bottom.

Then reload your page and checked the blocked cookies list again. Got "Allowed" now? (Don't click that "X"!)


Hi karen72687, your Firefox is blocking Tracking Cookies, but the PayPal cookie is listed under third party, not tracking, so Firefox isn't blocking that cookie. I think the problem is something else, but I can't tell what it is. ---- You could create a cookie exception for it anyway if you like. I think you need to enter the exception(s) under cookies. Here's how: On the Privacy & Security panel, Cookies & Site Data section, click '''Manage Permissions...''' and then paste each of these addresses and click the Allow button after each one. Finally, click Save Changes at the bottom. * https://paypalobjects.com * https://www.paypalobjects.com Then reload your page and checked the blocked cookies list again. Got "Allowed" now? (Don't click that "X"!) ---- <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-07-09-15-05-20-ef6f92.png" width="500">
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
karen72687 0 izisombululo 4 izimpendulo
Kuphostiwe

HI jscher2000, That's the other problem I can't enter anything under manage permissions. It's all grayed out and won't let me add anything. Any other ideas?

HI jscher2000, That's the other problem I can't enter anything under manage permissions. It's all grayed out and won't let me add anything. Any other ideas?
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

karen72687 said

HI jscher2000, That's the other problem I can't enter anything under manage permissions. It's all grayed out and won't let me add anything. Any other ideas?

If you add a Content Blocking exception from the Site Info panel on a website where content is blocked, then it will show up in that box and you will be able to remove it. There's no way to type in exceptions manually as far as I can tell.

The cookie exceptions are accessed through the Manage Permissions button in the Cookies & Site Data section.

''karen72687 [[#answer-1236007|said]]'' <blockquote> HI jscher2000, That's the other problem I can't enter anything under manage permissions. It's all grayed out and won't let me add anything. Any other ideas? </blockquote> If you add a Content Blocking exception from the Site Info panel on a website where content is blocked, then it will show up in that box and you will be able to remove it. There's no way to type in exceptions manually as far as I can tell. The ''cookie exceptions'' are accessed through the Manage Permissions button in the Cookies & Site Data section.
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17416 izisombululo 157344 izimpendulo
Kuphostiwe

The button to disable tracking protection should be in the drop-down list that opens if you click the shield and not in one of the sub panels. The third screenshot in your above reply shows the panel that open if you click blockable items (Trackers, Cookies) and this panel only has a 'x' to disable the block and allow a specific domain.

The button to disable tracking protection should be in the drop-down list that opens if you click the shield and not in one of the sub panels. The third screenshot in your above reply shows the panel that open if you click blockable items (Trackers, Cookies) and this panel only has a 'x' to disable the block and allow a specific domain.
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
karen72687 0 izisombululo 4 izimpendulo
Kuphostiwe

There is no shield in the address bar, only an 'i' that shows the content blocking, cookies and popup permissions. Manage exceptions is not working for me. It's blank and I can't add anything to it.

There is no shield in the address bar, only an 'i' that shows the content blocking, cookies and popup permissions. Manage exceptions is not working for me. It's blank and I can't add anything to it.
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

karen72687 said

There is no shield in the address bar, only an 'i' that shows the content blocking, cookies and popup permissions.

Nothing is being blocked in that page by Firefox's Content Blocking feature.

''karen72687 [[#answer-1236027|said]]'' <blockquote> There is no shield in the address bar, only an 'i' that shows the content blocking, cookies and popup permissions.</blockquote> Nothing is being blocked in that page by Firefox's Content Blocking feature.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
karen72687 0 izisombululo 4 izimpendulo
Kuphostiwe

This is the information drop down panel. I can look at the cookies, go to firefox content blocking, or popup permissions. I'm not able to add or change anything.

This is the information drop down panel. I can look at the cookies, go to firefox content blocking, or popup permissions. I'm not able to add or change anything.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

karen72687 said

I can look at the cookies, go to firefox content blocking, or popup permissions. I'm not able to add or change anything.

The different site lists on the Options/Preferences page work differently:

  • Content Blocking section => Manage Exceptions button: you can remove, but not add sites that are allowed to track
  • Cookies and Site Data section => Manage Permissions button: you can add (Allow, Allow for Session, Block) and remove cookie permissions
  • Permissions section => Exceptions button to the right of "Block pop-up windows": you can add (Allow) and remove popup permissions
''karen72687 [[#answer-1236031|said]]'' <blockquote> I can look at the cookies, go to firefox content blocking, or popup permissions. I'm not able to add or change anything. </blockquote> The different site lists on the Options/Preferences page work differently: * Content Blocking section => '''Manage Exceptions''' button: you can remove, but not add sites that are allowed to track * Cookies and Site Data section => '''Manage Permissions''' button: you can add (Allow, Allow for Session, Block) and remove cookie permissions * Permissions section => '''Exceptions''' button to the right of "Block pop-up windows": you can add (Allow) and remove popup permissions
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Thanks all for the answers and suggestions. Seems Funimation has been bought out and now seems to be using 3rd party trackers which is were I believe my problem is coming from.

Again thanks for the help.

Thanks all for the answers and suggestions. Seems Funimation has been bought out and now seems to be using 3rd party trackers which is were I believe my problem is coming from. Again thanks for the help.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
josephfg105 0 izisombululo 10 izimpendulo
Kuphostiwe

None of the answers here are helpful to me. I have exact same problem the O.P. had. The popup window I see when I click the 'i' icon is exactly like the example on this page this page, except there is no button labeled "Turn off Blocking for This Site." It just isn't there. Is my version of Firefox corrupt?

None of the answers here are helpful to me. I have exact same problem the O.P. had. The popup window I see when I click the 'i' icon is exactly like the example on this page [https://www.mozilla.org/en-US/firefox/68.0.1/content-blocking/start/?step=3&newtab=true this page], except there is no button labeled "Turn off Blocking for This Site." It just isn't there. Is my version of Firefox corrupt?

Okulungisiwe ngu josephfg105

Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Hi josephfg105, your problem is that you cannot play premium content on the Funimation site?

If there is no button to turn off content blocking for the site, then the Content Blocking feature is not blocking anything. Something else must be causing the problem.

Could you start a new question with your system details and what you have tried so far -- keep scrolling down past article suggestions to continue with the form:

https://support.mozilla.org/questions/new/desktop/websites

Hi josephfg105, your problem is that you cannot play premium content on the Funimation site? If there is no button to turn off content blocking for the site, then the Content Blocking feature is not blocking anything. Something else must be causing the problem. Could you start a new question with your system details and what you have tried so far -- keep scrolling down past article suggestions to continue with the form: https://support.mozilla.org/questions/new/desktop/websites
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.