Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why do all websites bring up 'insecure connection' page whenever I enable the HotSpot Shield VPN add-on?

  • 7 uphendule
  • 1 inale nkinga
  • 19 views
  • Igcine ukuphendulwa ngu James

more options

I installed the HotSpot Shield add-on to my Firefox browser and whenever I enable it, every website (even ones I've never been to before) show an 'Insecure Connection' page error. I have Avast Premium, but I tried disabling every feature on it, including manually unchecking the 'Enable HTTPS Scanning' option. Nothing has worked. Also, I don't have Avast's VPN feature. Likewise, whenever I toggle HotSpot Shield off, I can access websites normally.

Please help.

All Replies (7)

more options

Here is the image

more options

If you didn't have the problem before, you should contact Hotspot Shield support and ask questions. Perhaps one of its settings if off.

more options

This is the first time I've installed Hotspot Shield, I've never used a VPN before

more options

jjones1 said

This is the first time I've installed Hotspot Shield, I've never used a VPN before

Unfortunately FF enduser forum can't provide support for VPN request. If your planning to use such software you should really contact them before using the software if your not familiar with them.

more options

It's a ff add on

more options

Then you should contact its support.

more options

WestEnd, people here are welcome to help people in using Firefox extensions.