X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Is it possible to set up 'word wrap' in Thunderbird Emails?

Kuphostiwe

I have Thunderbird Version/Edition: 52.3.0 (32 bit).

I would love to make the margins of my composed messages narrower by default, so that words automatically went on to a new line.

If this IS possible to do, can anyone simply give me layperson's plain-English guidance as to how to set 'word wrap' or 'margin widths' up?

An example of the 'route' I should take to set this up would be brilliant.

And, if I needed to use HTML, where could I access a 'dictionary' of this, so that I could see what words and punctuation to use, and where one should put spaces, or not.

(I would prefer HTML to CSS as I'm more familiar with HTML).

Many thanks.

I have Thunderbird Version/Edition: 52.3.0 (32 bit). I would love to make the margins of my composed messages narrower by default, so that words automatically went on to a new line. If this IS possible to do, can anyone simply give me layperson's plain-English guidance as to how to set 'word wrap' or 'margin widths' up? An example of the 'route' I should take to set this up would be brilliant. And, if I needed to use HTML, where could I access a 'dictionary' of this, so that I could see what words and punctuation to use, and where one should put spaces, or not. (I would prefer HTML to CSS as I'm more familiar with HTML). Many thanks.

Okulungisiwe ngu Catherine Barber UK

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063

Eminye Imininingwane

Corey 'linuxmodder' Sheldon 21 izisombululo 223 izimpendulo
Kuphostiwe

This IS possible via the 'use paragraph setting in your composition settings. (see the attached pics)

1) Menu > Account Settings 2) Select Composition settings 3) Select Global Composition Settings button 4) Ensure the check IS in the 'Use paragraph....' 5) Save above settings ( click the save button to the bottom right of last screen) 6) Enjoy desired behavior.

This IS possible via the 'use paragraph setting in your composition settings. (see the attached pics) 1) Menu > Account Settings 2) Select Composition settings 3) Select Global Composition Settings button 4) Ensure the check IS in the 'Use paragraph....' 5) Save above settings ( click the save button to the bottom right of last screen) 6) Enjoy desired behavior.

Umnikazi wombuzo

Thanks Corey!

I'll give this all a go, and see how far I get....


[Later in the day] (Hope the Attachments open; this is the first time Ive uploaded images. Ive numbered yours 1, 2,and 3, and the one, numbered as 0 - with the orange title bar - which shows my own settings. Sorry I couldn't get them into numerical order).

Well, the problem is that - in my own settings (see attachment 0) - I can get as far as 'Global Composing Preferences'......

Frustratingly thereon, it seems that I lack an 'Active Window' setting, which lists a 'Thunderbird Preferences' option. This option is shown in attachment 1 - one of the three attachments that Mozilla Support had shown.

So, I cannot get into 'Thunderbird Preferences', which looks tantalizingly like the sort of setting I'm looking for....!

Could this be something to do with my particular version/edition of Thunderbird 52.3.0 (32 bit) ?

Thanks Corey! I'll give this all a go, and see how far I get.... [Later in the day] (Hope the Attachments open; this is the first time Ive uploaded images. Ive numbered yours 1, 2,and 3, and the one, numbered as 0 - with the orange title bar - which shows my own settings. Sorry I couldn't get them into numerical order). Well, the problem is that - in my own settings (see attachment 0) - I can get as far as 'Global Composing Preferences'...... Frustratingly thereon, it seems that I lack an 'Active Window' setting, which lists a 'Thunderbird Preferences' option. This option is shown in attachment 1 - one of the three attachments that Mozilla Support had shown. So, I cannot get into 'Thunderbird Preferences', which looks tantalizingly like the sort of setting I'm looking for....! Could this be something to do with my particular version/edition of Thunderbird 52.3.0 (32 bit) ?

Okulungisiwe ngu Catherine Barber UK

sfhowes
  • Top 10 Contributor
1691 izisombululo 8208 izimpendulo
Kuphostiwe

'Thunderbird Preferences' is the Linux/OSX equivalent of 'Options' for Windows TB users (menu differences). 'Global Composing Preferences' is the same as Tools/Options/Composition.

In any case, checking 'Use paragraph format...' on the Tools/Options/Composition/General tab will just make paragraphs separated by two lines instead of one when you press Enter.

'Thunderbird Preferences' is the Linux/OSX equivalent of 'Options' for Windows TB users ([http://kb.mozillazine.org/Menu_differences_in_Windows%2C_Linux%2C_and_Mac menu differences]). 'Global Composing Preferences' is the same as Tools/Options/Composition. In any case, checking 'Use paragraph format...' on the Tools/Options/Composition/General tab will just make paragraphs separated by two lines instead of one when you press Enter.

Umnikazi wombuzo

Sorry - a belated thanks for your reply SF.

Thanks for your explanations, and the link to explaining menu terminology differences.

Sorry - a belated thanks for your reply SF. Thanks for your explanations, and the link to explaining menu terminology differences.

Okulungisiwe ngu Catherine Barber UK

Zenos 2265 izisombululo 12258 izimpendulo
Kuphostiwe

For most of us, messages wrap at the right-hand margin, both when composing and when reading. If you resize the window, it reflows the text to fit. The width of the displayed text is therefore totally under the control of whoever is reading it. Fixed-length lines don't play well if they are shown on an narrower screen, since they would have your own hard line returns, and long lines would either wrap to fit a narrower window, or would extend off beyond the visible window.

So I can replicate the effect thus:

For most of us, messages wrap at the right-hand margin, both when composing and when reading. If you resize the window, it reflows the text to fit. The width of the displayed text is therefore totally under the control of whoever is reading it. Fixed-length lines don't play well if they are shown on an narrower screen, since they would have your own hard line returns, and long lines would either wrap to fit a narrower window, or would extend off beyond the visible window.

Are you saying that your own messages don't wrap when you are composing them? This is a problem that is occasionally reported here on this forum, but I've never seen any definitive way to replicate it at will. Occasionally we see long lines going off the edge when Thunderbird is used to view messages written in other mail clients that don't use standard formatting practices, but that is another issue.

How and why do you expect to be using html markup? Most users are using it without being aware that they are. They just compose in Thunderbird and use the on-screen tools for formatting their messages.

For most of us, messages wrap at the right-hand margin, both when composing and when reading. If you resize the window, it reflows the text to fit. The width of the displayed text is therefore totally under the control of whoever is reading it. Fixed-length lines don't play well if they are shown on an narrower screen, since they would have your own hard line returns, and long lines would either wrap to fit a narrower window, or would extend off beyond the visible window. So I can replicate the effect thus: For most of us, messages wrap at the right-hand margin, both when composing and when reading. If you resize the window, it reflows the text to fit. The width of the displayed text is therefore totally under the control of whoever is reading it. Fixed-length lines don't play well if they are shown on an narrower screen, since they would have your own hard line returns, and long lines would either wrap to fit a narrower window, or would extend off beyond the visible window. Are you saying that your own messages don't wrap when you are composing them? This is a problem that is occasionally reported here on this forum, but I've never seen any definitive way to replicate it at will. Occasionally we see long lines going off the edge when Thunderbird is used to view messages written in other mail clients that don't use standard formatting practices, but that is another issue. How and why do you expect to be using html markup? Most users are using it without being aware that they are. They just compose in Thunderbird and use the on-screen tools for formatting their messages.

Okulungisiwe ngu Zenos

Umnikazi wombuzo

I've managed to set things up so that my messages at least do wrap when they reach the righthand side of the screen, instead of going on and on. Sorry, I can't remember offhand what I now did to set this up - something to do with 'mail word wrap'? and setting this to '0'.

Annoyingly, it seems that if one set the wraplength to a number of one's own choice (I wanted a max of 50 characters) I was told this could come out differently on a recipient's screen. (Noted what you said that "fixed-length lines don't play well if they are shown on an narrower screen, since they would have your own hard line returns, and long lines would either wrap to fit a narrower window, or would extend off beyond the visible window."). And, of course, all this whole set up/programming or whatever, is geared more for tablet and phone screens than for wide-screen desktop computers!

You wrote: "The width of the displayed text is therefore totally under the control of whoever is reading it." Were you meaning the reader to be the 'composer' of the text, or the recipient reading it on their own screen?

I'd been thinking that if I could use HTML (or CSS?) markup that I could somehow embed commands to reformat things like font size, colour, and layouts such as body text width, so that these were the defaults. Fanciful, probably, I know!

I've managed to set things up so that my messages at least do wrap when they reach the righthand side of the screen, instead of going on and on. Sorry, I can't remember offhand what I now did to set this up - something to do with 'mail word wrap'? and setting this to '0'. Annoyingly, it seems that if one set the wraplength to a number of one's own choice (I wanted a max of 50 characters) I was told this could come out differently on a recipient's screen. (Noted what you said that "fixed-length lines don't play well if they are shown on an narrower screen, since they would have your own hard line returns, and long lines would either wrap to fit a narrower window, or would extend off beyond the visible window."). And, of course, all this whole set up/programming or whatever, is geared more for tablet and phone screens than for wide-screen desktop computers! You wrote: "The width of the displayed text is therefore totally under the control of whoever is reading it." Were you meaning the reader to be the 'composer' of the text, or the recipient reading it on their own screen? I'd been thinking that if I could use HTML (or CSS?) markup that I could somehow embed commands to reformat things like font size, colour, and layouts such as body text width, so that these were the defaults. Fanciful, probably, I know!
Zenos 2265 izisombululo 12258 izimpendulo
Kuphostiwe

Catherine Barber UK said

I've managed to set things up so that my messages at least do wrap when they reach the righthand side of the screen, instead of going on and on. Sorry, I can't remember offhand what I now did to set this up - something to do with 'mail word wrap'? and setting this to '0'.
I am surprised that you needed to change anything. It wraps by default.
Annoyingly, it seems that if one set the wraplength to a number of one's own choice (I wanted a max of 50 characters) I was told this could come out differently on a recipient's screen. (Noted what you said that "fixed-length lines don't play well if they are shown on an narrower screen, since they would have your own hard line returns, and long lines would either wrap to fit a narrower window, or would extend off beyond the visible window.").

Old timers in newsgrous seem to like fixed line lengths and plain text (no fonts, no colours, no decorations.). Most users just use what is given and find that it wraps dynamically to the screen, both for the sender and the recipient. So the text fits regardless of your screen size.

And, of course, all this whole set up/programming or whatever, is geared more for tablet and phone screens than for wide-screen desktop computers!
I cannot agree with you there, and I say that historically it's quite the opposite. Thunderbird belongs to a desktop and laptop era and was not intended and isn't built for use on modern smaller touch screens. I use it myself on various computers with screens approximating the 16:9 aspect ratio of a widescreen TV.

You wrote: "The width of the displayed text is therefore totally under the control of whoever is reading it."

Were you meaning the reader to be the 'composer' of the text, or the recipient reading it on their own screen?
Both. That's the whole point. Everyone gets to see it as they want, and recipients do not have the author's choice imposed on them.
I'd been thinking that if I could use HTML (or CSS?) markup that I could somehow embed commands to reformat things like font size, colour, and layouts such as body text width, so that these were the defaults. Fanciful, probably, I know!

Look at the Stationery add-on. It lets you choose a template which can define default styles.

I'm always wary of talk about "margins" and "pages". These indicate a mindset based on the use of documents printed on paper, where the final document size and layout are known, and so it's perfectly reasonable to then set an abosulute font size.

Email has no concept of a page (up until you print it onto paper), so width and margins are meaningless. And that's why I balk at talk of fixed line lengths; it carries an implicit assumption that the recipient will see it just as the sender does, and that isn't a reasonable expectation, since as you recognize, others may be using tablets and phones.

''Catherine Barber UK [[#answer-1011504|said]]'' <blockquote> I've managed to set things up so that my messages at least do wrap when they reach the righthand side of the screen, instead of going on and on. Sorry, I can't remember offhand what I now did to set this up - something to do with 'mail word wrap'? and setting this to '0'. </blockquote>I am surprised that you needed to change anything. It wraps by default.<blockquote> Annoyingly, it seems that if one set the wraplength to a number of one's own choice (I wanted a max of 50 characters) I was told this could come out differently on a recipient's screen. (Noted what you said that "fixed-length lines don't play well if they are shown on an narrower screen, since they would have your own hard line returns, and long lines would either wrap to fit a narrower window, or would extend off beyond the visible window."). </blockquote> Old timers in newsgrous seem to like fixed line lengths and plain text (no fonts, no colours, no decorations.). Most users just use what is given and find that it wraps dynamically to the screen, both for the sender and the recipient. So the text fits regardless of your screen size. <blockquote>And, of course, all this whole set up/programming or whatever, is geared more for tablet and phone screens than for wide-screen desktop computers!</blockquote>I cannot agree with you there, and I say that historically it's quite the opposite. Thunderbird belongs to a desktop and laptop era and was not intended and isn't built for use on modern smaller touch screens. I use it myself on various computers with screens approximating the 16:9 aspect ratio of a widescreen TV. <blockquote> You wrote: "The width of the displayed text is therefore totally under the control of whoever is reading it." Were you meaning the reader to be the 'composer' of the text, or the recipient reading it on their own screen?</blockquote>Both. That's the whole point. Everyone gets to see it as they want, and recipients do not have the author's choice imposed on them. <blockquote>I'd been thinking that if I could use HTML (or CSS?) markup that I could somehow embed commands to reformat things like font size, colour, and layouts such as body text width, so that these were the defaults. Fanciful, probably, I know! </blockquote> Look at the Stationery add-on. It lets you choose a template which can define default styles. I'm always wary of talk about "margins" and "pages". These indicate a mindset based on the use of documents printed on paper, where the final document size and layout are known, and so it's perfectly reasonable to then set an abosulute font size. Email has no concept of a page (up until you print it onto paper), so width and margins are meaningless. And that's why I balk at talk of fixed line lengths; it carries an implicit assumption that the recipient will see it just as the sender does, and that isn't a reasonable expectation, since as you recognize, others may be using tablets and phones.

Okulungisiwe ngu Zenos

WebDev 0 izisombululo 16 izimpendulo
Kuphostiwe

I have this issue also, but in a peculiar way. My wife, who also uses the current version of Thunderbird, sent out an e-mail to a friend, and the friend sent her a response which she then forwarded to me. She verifies that word wrap was working correctly on her screen in all cases. When I got the forwarded copy, word wrap was OFF both for her message and for her friend's reply. As far as I can tell, it works normally on my system except in this case. Any clue?

I have this issue also, but in a peculiar way. My wife, who also uses the current version of Thunderbird, sent out an e-mail to a friend, and the friend sent her a response which she then forwarded to me. She verifies that word wrap was working correctly on her screen in all cases. When I got the forwarded copy, word wrap was OFF both for her message and for her friend's reply. As far as I can tell, it works normally on my system except in this case. Any clue?