Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

When I play videos on ESPN I get a grey screen works on Chrome

  • 6 uphendule
  • 10 zinale nkinga
  • 42 views
  • Igcine ukuphendulwa ngu ad24rouse

more options

When I click on an ESPN video, I get a grey screen. The sound works and the video appears to run, but nothing shows. When hover the mouse over the progress bar, it shows a snapshot of the video. I've disabled and enabled adblocker. When I right click on the video and it asks for "player" it shows the video is HTML5. I've tried several HTML5 plug-ins but none of them work. Running Windows 10, Firefox 48.0.2

All Replies (6)

more options

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

more options

They all say either Ask to Activate or Always activate.

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

Yes. There appeared to be no difference when Firefox was started in Safe Mode

more options

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

dcbroten said

When I click on an ESPN video, I get a grey screen. The sound works and the video appears to run, but nothing shows. When hover the mouse over the progress bar, it shows a snapshot of the video. I've disabled and enabled adblocker. When I right click on the video and it asks for "player" it shows the video is HTML5. I've tried several HTML5 plug-ins but none of them work. Running Windows 10, Firefox 48.0.2

I have this exact problem.....almost word for word...except when I right click on the video, it doesn't really say anything. It just says "GENERAL, PLUGINS and SOURCE," but there's not anything underneath. When I hover over the progress bar, I can see actual images. I can watch the videos just fine on Chrome, so I don't think it's a problem with my computer. Also, I was able to go to WatchESPN and videos showed just fine there.

Did anyone come up with a solution to this?

  • I'm on Windows 7 Home Premium.

Okulungisiwe ngu ad24rouse