Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to stop Mozilla from removing a SIGNED add on?

  • 11 uphendule
  • 4 zinale nkinga
  • 142 views
  • Igcine ukuphendulwa ngu AliceWyman

more options

I installed the signed version of my YAHOO toolbar, but Mozilla keeps disabling it. I need this toolbar and have used it for years. It was removed as of this morning and I cannot get it back. I am not happy.

Isisombululo esikhethiwe

Update: The Yahoo toolbar add-on was updated on December 29, 2015. The latest version fixes an issue where the Yahoo toolbar becomes disabled after restarting Firefox.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (11)

more options

The other day I saw several threads where users said they could enable Yahoo for their current session, but when they closed the last Firefox window and started Firefox again, the extension was disabled. If you check the Add-ons page, is that the pattern you're seeing? Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then check at the bottom of the list on the right side for a disabled Yahoo Toolbar extension and see whether you can enable it there.

more options

I tried this. Yahoo Toolbar is listed as disabled and that it could not be verified by Mozilla.

more options

Could you check which version you have? If you go to the Add-ons page and click the "More" link for Yahoo Toolbar, does it show

Yahoo! Toolbar 3.2.12.20150813125909.1-signed

I have attached a screen shot of what I see. Note: I had previously removed the version from February a while ago, in case timing matters.

more options

I see exactly the same thing except that after "signed," it says "disabled."

Earlier, I was able to reinstall the toolbar from the Yahoo website, but as soon as I left, Mozilla, it disappeared again.

Since several people have reported this issue as of this morning, could Firefox have suddenly added this to its list of no-no's? After all, it has been working just fine for years.

It's the "signed" part that I don't get. It should be enabled.

more options

Is there an explanation for the disablement? If not, can it be re-enabled (you might need to scroll to see the button)?

I can't think of any reason for the Yahoo Toolbar extension to be blocked.

more options

All the explanation I get is that the toolbar is not verified fo use by Firefox. I removed it again and reinstalled it. Initially it was blocked by Firefox, so I tried again. It installed, then, I closed Firefox. When reopened, the toolbar was gone with an indication that an add-on was blocked by Firefox.

There is no button to re-enable it.

more options

It seems that Firefox is mixed up because the Yahoo! Toolbar on the Mozilla Add-ons site is signed/verified. Perhaps some information about the Yahoo! Toolbar installed directly from Yahoo! has gotten jumbled together with the newer one.

I'll give you two suggestions, one or both of which you might already have seen in another thread:

(1) You could clear the file Firefox uses to store information about extensions and let Firefox rebuild it to see whether that clears up the situation.

(2) You could try making a temporary exception to the signing requirement. This will only work in Firefox 43.


For #1: Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename any of these files that you find:

  • compatibility.ini to something like compatibility-old.ini
  • extensions.ini to something like extensions-old.ini
  • extensions.json to something like extensions-old.json
  • extensions.sqlite to something like extensions-old.sqlite (might not exist depending on how long you've been using this settings folder)

When you start Firefox back up again, it should explore your profile folder, other folders, and the Windows registry to rebuild the list. It probably will ask you to approve some of the extensions. Once things settle down, any improvement with the Yahoo toolbar?


For #2: You can make a temporary exception to the signing requirement -- this is global for all extensions, there's currently no way to only make an exception for one specific extension.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste xpin and pause while the list is filtered

(3) Double-click the xpinstall.signatures.required preference to switch it from true to false -- note that this is for Firefox 43 only

more options

Actually, I don't know if this solves the problem or not; I haven't tried the suggestions. I've decided to live without the Yahoo toolbar for now. I do, however, offer you my sincere thanks for working with this issue.

more options

<deleted>

Okulungisiwe ngu AliceWyman

more options

Isisombululo Esikhethiwe

Update: The Yahoo toolbar add-on was updated on December 29, 2015. The latest version fixes an issue where the Yahoo toolbar becomes disabled after restarting Firefox.

more options

P.S. If you changed the xpinstall.signatures.required preference to false in the Firefox Configuration Editor (about:config page) as a workaround for the Yahoo toolbar problem, you should reset the preference back to true (the default value).