X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Scripts not running

Kuphostiwe

I am getting problems with scripts not running on various web sites that I access every day.

For example, two today: resource://gre/modules/commonj…nsion/data/jquery-2.1.0.min.js:4 resource://gre/modules/commonj…nsion/data/jquery-2.1.0.min.js:2

This has just started happening in the last week or so.

System: Windows 7 64bit; Firefox 42.0; RAM 6Gb; Processor i5 2430M 2.4Ghz

Mike

I am getting problems with scripts not running on various web sites that I access every day. For example, two today: resource://gre/modules/commonj…nsion/data/jquery-2.1.0.min.js:4 resource://gre/modules/commonj…nsion/data/jquery-2.1.0.min.js:2 This has just started happening in the last week or so. System: Windows 7 64bit; Firefox 42.0; RAM 6Gb; Processor i5 2430M 2.4Ghz Mike

Isisombululo esikhethiwe

Hi DionysusMike, I don't think you need to spend hours. The following takes a few minutes, so if you encounter a bunch of long commercials you can do it then:

(1) Disable Skype Click-to-Call Extension

Start on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find Skype on the right and click Disable. If Firefox says you need to restart Firefox to make the disabling effective, you can use the link provided for that.

(2) Disable Flash plugin protected mode

A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

Close all tabs using Flash for at least 3 minutes to allow this to take effect.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • Reader Library Helper Plugin
  • Shockwave Flash 19.0 r0
  • Shockwave Flash 16.0 r0
  • 5.1.40728.0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4396 izisombululo 61661 izimpendulo
Kuphostiwe

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.


Separate Issue; Your System Details shows;

Installed Plug-ins

Shockwave Flash 19.0 r0 Shockwave Flash 16.0 r0
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Note: Edge on Win10 does not use ActiveX version but its own Flash.

Flash: Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac

Then reinstall the latest version.

Flash Player Version 19.0.0.245
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users should download the ‘’’active_x’’’ for “Internet Explorer,” and the ‘’’plugin’’’ for “Plugin-based browsers” (like Firefox).

Adobe still offers Flash 18.0.0.255 as its extended support release further down

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart. -------------- Separate Issue; Your System Details shows; Installed Plug-ins Shockwave Flash 19.0 r0 Shockwave Flash 16.0 r0 <br>Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer. Note: Edge on Win10 does not use ActiveX version but its own Flash. Flash: Grab the uninstaller from here: '''[http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows]''' '''[http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac]''' Then reinstall the latest version. Flash Player '''Version 19.0.0.245<br>https://www.adobe.com/products/flashplayer/distribution3.html''' '''Note: Windows users''' should download the ‘’’active_x’’’ for “Internet Explorer,” '''and''' the ‘’’plugin’’’ for “Plugin-based browsers” (like Firefox). Adobe still offers Flash 18.0.0.255 as its extended support release further down
cor-el
  • Top 10 Contributor
  • Moderator
17865 izisombululo 161655 izimpendulo
Kuphostiwe

Do you have a Skype extension in Firefox?

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Do you have a Skype extension in Firefox? Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Umnikazi wombuzo

I have tried the suggested solutions above to no avail.

I am also getting, as is my wife on our other machine, a Dell PC, many "not responding" messages in Firefox 42. I never had these messages before in previous versions of Firefox,

I can only conclude that there is something wrong with Firefox version 42, and I am not prepared to spend hours looking for solutions to plug in/extension problems.

We are therefore reverting , with many regrets, to Internet Explorer and Chrome.

We look forward to Mozilla producing a Firefox version that does not have these script/not responding problems,

I have tried the suggested solutions above to no avail. I am also getting, as is my wife on our other machine, a Dell PC, many "not responding" messages in Firefox 42. I never had these messages before in previous versions of Firefox, I can only conclude that there is something wrong with Firefox version 42, and I am not prepared to spend hours looking for solutions to plug in/extension problems. We are therefore reverting , with many regrets, to Internet Explorer and Chrome. We look forward to Mozilla producing a Firefox version that does not have these script/not responding problems,
cor-el
  • Top 10 Contributor
  • Moderator
17865 izisombululo 161655 izimpendulo
Kuphostiwe

Did you try to disable all extensions?

Does the Browser Console (Firefox menu button or Tools > Web Developer) show a more precise error message?

Did you try to disable all extensions? Does the Browser Console (Firefox menu button or Tools > Web Developer) show a more precise error message? *https://developer.mozilla.org/Tools/Browser_Console
jscher2000
  • Top 10 Contributor
8959 izisombululo 73404 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Hi DionysusMike, I don't think you need to spend hours. The following takes a few minutes, so if you encounter a bunch of long commercials you can do it then:

(1) Disable Skype Click-to-Call Extension

Start on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find Skype on the right and click Disable. If Firefox says you need to restart Firefox to make the disabling effective, you can use the link provided for that.

(2) Disable Flash plugin protected mode

A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

Close all tabs using Flash for at least 3 minutes to allow this to take effect.

Hi DionysusMike, I don't think you need to spend hours. The following takes a few minutes, so if you encounter a bunch of long commercials you can do it then: (1) Disable Skype Click-to-Call Extension Start on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then find Skype on the right and click Disable. If Firefox says you need to restart Firefox to make the disabling effective, you can use the link provided for that. (2) Disable Flash plugin protected mode A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then ''uncheck'' the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps. Close all tabs using Flash for at least 3 minutes to allow this to take effect.

Umnikazi wombuzo

jscher2000 and cor-el

Thank you so much for your help. I implemented your suggestions and my problems stopped.

Eventually I reinstated everything except the Skype "click to call" plug in and again had no problems, so it seems that the Skype plug in is responsible for interference with the running of scripts.

jscher2000 and cor-el Thank you so much for your help. I implemented your suggestions and my problems stopped. Eventually I reinstated everything except the Skype "click to call" plug in and again had no problems, so it seems that the Skype plug in is responsible for interference with the running of scripts.