Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

can't see bengali font properly in any webpage.

  • 8 uphendule
  • 19 zinale nkinga
  • 10535 views
  • Igcine ukuphendulwa ngu drnaseeb

more options

Presenty using Windows 10 and Firefox 41.0b5. Can't see Bengali font properly in any webpage, but Edge or Internet Explorer can show Bengali font nicely.

Isisombululo esikhethiwe

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 4

All Replies (8)

more options

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.


You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

more options

This thing is already checked. Other browsers are showing bengali font correctly. Do I still need to checkf ro duplicate and corrupted fonts from the sites given above?

more options

Do you see any text or do you only see little boxes with the hex code?

You can right-click in the space where text should be and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

more options

To be specific my problem is with the compound characters. Firefox is showing compound characters breaking up into each component and so the whole thing becomes unreadable.

more options

What font is Firefox using for the Bengali glyphs (see my above reply)?

It is possible that this font isn't working properly. You could try a different default font.

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
more options

The Bengai font name is Nirmala. I changed my default font to Adarshalipi but no change. Now I also do a thing: My region was US, I changed it to Bangladesh, but I didn't restarted my machine aftr that change. I did it 'cos my local language might be misunderstood.

more options

Isisombululo Esikhethiwe

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options

Yeeeeeeeeeeeeeeey. Problem solved. 'Use hardware acceleration' was the culprit. Thank u very much indeed.