Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Address bar search redirected

more options

My searches in the address bar seem to be getting redirected to random site. (Random but the sites have a relation to the word I type)

E.g Arsenal -> http://emergencylifeline.com/

      Hope -> http://www.2600.com/
       News -> http://www.news.net

I have tried uninstall and reinstall firefox, I've tried to reset. I've used various virus scanners(McAfee, Malwarebytes). And I can't seem to fix it.

Any ideas? If you need more infolet me know and I'll provide.

Thanks

My searches in the address bar seem to be getting redirected to random site. (Random but the sites have a relation to the word I type) E.g Arsenal -> http://emergencylifeline.com/ Hope -> http://www.2600.com/ News -> http://www.news.net I have tried uninstall and reinstall firefox, I've tried to reset. I've used various virus scanners(McAfee, Malwarebytes). And I can't seem to fix it. Any ideas? If you need more infolet me know and I'll provide. Thanks

All Replies (3)

more options

Hi dellxps15,

How are you typing the words? With a space? And do you have autocomplete on?

Sometimes if there is no space it will autocomplete the url with a www or a .com if you hit enter before you finish typing. Please try with a space and see if this helps.

However since it is not a hijacker search engine, but just a functionality, you can turn off autocomplete in the url bar as well: Address bar autocomplete suggestions in Firefox It should be there, but if that is not it please feel free to post back.

more options

One-word searches (e.g., arsenal or mozilla.org) are special in another way: Firefox will check with your DNS service provider whether they are valid server names. Some providers lie and point Firefox to their own search results page. If yours does this, check the results page for an "opt out" link or button. If there isn't one, and they don't have another way to turn off this "service" you could consider changing DNS service providers to another one such as OpenDNS or Google Public DNS.

more options

On closer reading, you're not getting search results, you're getting a full diversion. It could be a bad DNS provider, but here are a couple other things to check:

(1) Is Firefox set to use a proxy? You can check that here:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

The default setting of "Use system proxy settings" should follow the "LAN" settings in Internet Explorer. But you also could try "No proxy" to see whether you get a different result.

(2) You could test whether one of your extensions is the culprit by testing in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?