X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Youtube (https)security certificate issue

Kuphostiwe

Hi

I'm using latest firefox version with and recently I'm facing this strange issue ... everytime I try to visit youtube, to be specific, when not logged in on any google accounts .. I can visit http://www.youtube.com but when I try to login, in which case it redirects to https:// and It shows the following error(check image url):

https://imageshack.com/i/ezbe0c53j

And if I try to add exception, it shows this screen(check image url):

https://imageshack.com/i/hj41802cj

(PS: Couldn't find upload option here so I had to use otherimage hosts)

Also I tried changing windows time, adding auto time sync from windows site and also tried changing profile, disabling add on and testing and also tried removing cache/cookies from both google.com and youtube.com and so far nothing worked ... I can't seem to access youtube while logged in (https)

Also its only youtube, no other website shows this security certificate error!

please provide a solution to this asap, thanks!

Hi I'm using latest firefox version with and recently I'm facing this strange issue ... everytime I try to visit youtube, to be specific, when not logged in on any google accounts .. I can visit http://www.youtube.com but when I try to login, in which case it redirects to https:// and It shows the following error(check image url): https://imageshack.com/i/ezbe0c53j And if I try to add exception, it shows this screen(check image url): https://imageshack.com/i/hj41802cj (PS: Couldn't find upload option here so I had to use otherimage hosts) Also I tried changing windows time, adding auto time sync from windows site and also tried changing profile, disabling add on and testing and also tried removing cache/cookies from both google.com and youtube.com and so far nothing worked ... I can't seem to access youtube while logged in (https) Also its only youtube, no other website shows this security certificate error! please provide a solution to this asap, thanks!

Isisombululo esikhethiwe

finally i figured out the issue, it seems like i had a IP redirection setup at windows>hosts file for youtube a while back when youtube was blocked by the gov here.

so i removed it and everything seems to be working fine.

Funda le mpendulo ngokuhambisana nalesi sihloko 5

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 14.0 r0
  • Google Update
  • Facebook Video Calling Plugin
  • GEPlugin
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0

Isisebenziso

  • Firefox 30.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/30.0/WINNT/en-US/

Izandiso

  • Firebug 2.0.2 (firebug@software.joehewitt.com)
  • IDM CC 7.3.81 (mozilla_cc@internetdownloadmanager.com)
  • Page Speed 1.12.9.2 ({e3f6c2cc-d8db-498c-af6c-499fb211db97})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.0 (web2pdfextension@web2pdf.adobedotcom) (Akusebenzi)
  • Adobe Contribute Toolbar 6.1 ({01A8CA0A-4C96-465b-A49B-65C46FAD54F9}) (Akusebenzi)
  • avast! Online Security 9.0.2018.95 (wrc@avast.com) (Akusebenzi)
  • Boomerang for GMail 1.2.1 ({65e41d20-f092-41b7-bb83-c6e8a9ab0f57}) (Akusebenzi)
  • FastAccess Web Login 1.12 (fassoxpcom@sensiblevision.com) (Akusebenzi)
  • Hotspot Shield Extension 3.13 (afext@anchorfree.com) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2: NVIDIA GeForce GT 540M
  • adapterDeviceID: 0x0116
  • adapterDeviceID2: 0x0df4
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 3-25-2011
  • driverDate2: 2-8-2014
  • driverVersion: 8.15.10.2342
  • driverVersion2: 9.18.13.3489
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Okuthandwayo Okulungisiwe

  • accessibility.browsewithcaret: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140605174243
  • browser.startup.homepage: http://www.google.com/ncr
  • browser.startup.homepage_override.buildID: 20140605174243
  • browser.startup.homepage_override.mstone: 30.0
  • browser.tabs.warnOnClose: False
  • browser.zoom.full: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 30.0
  • font.internaluseonly.changed: False
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://dts.search.ask.com/sr?src=ffb&gct=ds&appid=128&systemid=488&v=n12521-387&apn_dtid=TCH001&apn_ptnrs=AG1&apn_uid=3504376989504303&o=APN11459&q=
  • network.cookie.prefsMigrated: True
  • network.dns.disableIPv6: True
  • network.http.pipelining: True
  • network.http.pipelining.maxrequests: 8
  • network.http.pipelining.ssl: True
  • places.database.lastMaintenance: 1405957672
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 0
  • plugin.state.nparcpluginff: 0
  • plugin.state.npauthz: 0
  • plugin.state.npdeployjava: 0
  • plugin.state.npgarenatalkplugin: 0
  • plugin.state.npnv3dv: 0
  • plugin.state.npnv3dvstreaming: 0
  • plugin.state.npspwrap: 0
  • plugin.state.npystate: 0
  • privacy.sanitize.migrateFx3Prefs: True
  • security.disable_button.openCertManager: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1404306312

Misc

  • Umsebenzisi JS: Yebo
  • Ukufinyeleleka: Cha
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Ha, I use that same theme on my Firefox for Android, is there a chance that the certificate that was issued may be expired.

Check the certificate manager to see if there is a stored cert.

Also try navigating to [about:permissions] and search for youtube.com or s..ytimg.com

  1. Right click on the youtube page and select "Page Info"
  2. Click on Security
  3. Click on View Cookies
  4. Remove all and reload the page.

Please also see the troubleshooting steps Connection Untrusted Error Message

Ha, I use that same theme on my Firefox for Android, is there a chance that the certificate that was issued may be expired. Check the certificate manager to see if there is a stored cert. Also try navigating to [about:permissions] and search for youtube.com or s..ytimg.com # Right click on the youtube page and select "Page Info" # Click on Security # Click on View Cookies # Remove all and reload the page. Please also see the troubleshooting steps [https://support.mozilla.org/en-US/kb/connection-untrusted-error-message Connection Untrusted Error Message]
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe
[https://www.mozilla.org/en-US/about/governance/policies/security-group/certs/policy/inclusion/]

Umnikazi wombuzo

still the same ... it shows same error with cookies removed/being there ...

still the same ... it shows same error with cookies removed/being there ...

Umnikazi wombuzo

basically my issue falls under this:

"Certificate is only valid for (site name) (site name) uses an invalid security certificate. The certificate is only valid for (site name). (Error code: ssl_error_bad_cert_domain)

This error is telling you that the identification sent to you by the site is actually for another site. While anything you send would be safe from eavesdroppers, the recipient may not be who you think it is.

A common situation is when the certificate is actually for a different part of the same site. For example, you may have visited https://example.com, but the certificate is for https://www.example.com. In this case, if you access https://www.example.com directly, you should not receive the warning. "

but both with www and not with www results in same eror ...

basically my issue falls under this: "Certificate is only valid for (site name) (site name) uses an invalid security certificate. The certificate is only valid for (site name). (Error code: ssl_error_bad_cert_domain) This error is telling you that the identification sent to you by the site is actually for another site. While anything you send would be safe from eavesdroppers, the recipient may not be who you think it is. A common situation is when the certificate is actually for a different part of the same site. For example, you may have visited https://example.com, but the certificate is for https://www.example.com. In this case, if you access https://www.example.com directly, you should not receive the warning. " but both with www and not with www results in same eror ...

Umnikazi wombuzo

gonna try removing the "cert8.db" file and lets see .. what happens ...

gonna try removing the "cert8.db" file and lets see .. what happens ...

Umnikazi wombuzo

nope didn't work ... same ol error remains ...

come on .. no one know how to solve this?

nope didn't work ... same ol error remains ... come on .. no one know how to solve this?
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe
Would this site be considered a third party cookie?[[Delete cookies to remove the information websites have stored on your computer]] or[[Disable third-party cookies in Firefox to stop some types of tracking by advertisers]]
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Also if you have a copy of the cert (via add exception -> view certificate) it would be helpful to investigate cdn configuration. <keeler>

Also if you have a copy of the cert (via add exception -> view certificate) it would be helpful to investigate cdn configuration. <keeler>
jscher2000
  • Top 10 Contributor
8643 izisombululo 70728 izimpendulo
Kuphostiwe

Impendulo Ewusizo

When you click Add Exception, you get a Google error page instead of a pop-up dialog? Or are you saying that after you added the exception, YouTube's home page won't load. That's mildly suspicious...

If you return to the Add Exception dialog and use the View button, how does the certificate compare with the attached screen shot?

When you click Add Exception, you get a Google error page instead of a pop-up dialog? Or are you saying that after you added the exception, YouTube's home page won't load. That's mildly suspicious... If you return to the Add Exception dialog and use the View button, how does the certificate compare with the attached screen shot?
cor-el
  • Top 10 Contributor
  • Moderator
17425 izisombululo 157456 izimpendulo
Kuphostiwe

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored. If that helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate. If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

Umnikazi wombuzo

im npt that much a tech geeky ... so if its not asking for too much, could one of you guys assist me with this using teamvirewer or skype screenshare please .... thanks in advance.

let me know if you're interfered.

im npt that much a tech geeky ... so if its not asking for too much, could one of you guys assist me with this using teamvirewer or skype screenshare please .... thanks in advance. let me know if you're interfered.
jscher2000
  • Top 10 Contributor
8643 izisombululo 70728 izimpendulo
Kuphostiwe

You're up much earlier than me...

What if you try YouTube in a private window? You can launch a new private windows using Ctrl+Shift+p. Does it work any different or better there?

You're up much earlier than me... What if you try YouTube in a private window? You can launch a new private windows using Ctrl+Shift+p. Does it work any different or better there?

Umnikazi wombuzo

in private window ...with http .. works fine ... but with https ... results in same error .... what can i do with this darn issue ...

crying out loud .... someone please help !!!!

in private window ...with http .. works fine ... but with https ... results in same error .... what can i do with this darn issue ... crying out loud .... someone please help !!!!
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Try this temporarily: In order to change your Firefox Configuration please do the following steps :

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise! to continue to the about:config page.
  3. Look for netwrok.websocket.allowInsecureFromHTTPS

but if it works in a private window, go to about:permissions and search for youtube.com. Click "Forget this site" and restart Firefox.

Try this temporarily: In order to change your Firefox Configuration please do the following steps : # In the [[Location bar autocomplete|Location bar]], type '''about:config''' and press '''Enter'''. The about:config "''This might void your warranty!''" warning page may appear. # Click '''I'll be careful, I promise!''' to continue to the about:config page. # Look for netwrok.websocket.allowInsecureFromHTTPS but if it works in a private window, go to about:permissions and search for youtube.com. Click "Forget this site" and restart Firefox.

Umnikazi wombuzo

this is what i see:

please check the image ..

https://imageshack.com/i/f0PC38fcj

now what to do from here?

this is what i see: please check the image .. https://imageshack.com/i/f0PC38fcj now what to do from here?
cor-el
  • Top 10 Contributor
  • Moderator
17425 izisombululo 157456 izimpendulo
Kuphostiwe

Who is the issuer of the certificate?

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

Check out why the site is untrusted and click "Technical Details to expand this section.
If the certificate is not trusted because no issuer chain was provided (sec_error_unknown_issuer) then see if you can install this intermediate certificate from another source.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer of the certificate.

You can see more Details like intermediate certificates that are used in the Details pane.

If "I Understand the Risks" is missing then this page may be opened in an (i)frame and in that case try the right-click context menu and use "This Frame: Open Frame in New Tab".

  • Note that some firewalls monitor (secure) connections and that programs like Sendori or FiddlerRoot can intercept connections and send their own certificate instead of the website's certificate.
  • Note that it is not recommended to add a permanent exception in cases like this, so only use it to inspect the certificate.
Who is the issuer of the certificate? Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar. Check out why the site is untrusted and click "Technical Details to expand this section.<br>If the certificate is not trusted because no issuer chain was provided (sec_error_unknown_issuer) then see if you can install this intermediate certificate from another source. You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates. *Click the link at the bottom of the error page: "I Understand the Risks" Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate". *Click the "View..." button and inspect the certificate and check who is the issuer of the certificate. You can see more Details like intermediate certificates that are used in the Details pane. If <b>"I Understand the Risks"</b> is missing then this page may be opened in an (i)frame and in that case try the right-click context menu and use "This Frame: Open Frame in New Tab". *Note that some firewalls monitor (secure) connections and that programs like Sendori or FiddlerRoot can intercept connections and send their own certificate instead of the website's certificate. *Note that it is not recommended to add a permanent exception in cases like this, so only use it to inspect the certificate.

Umnikazi wombuzo

here is the certificate in export format and an image ....

the cert url: http://fantchofinancial.com/cert/-.googlevideo.com

here is the certificate in export format and an image .... the cert url: http://fantchofinancial.com/cert/-.googlevideo.com

Umnikazi wombuzo

so no one can solve this issue? aww man .. this sucks

so no one can solve this issue? aww man .. this sucks
jscher2000
  • Top 10 Contributor
8643 izisombululo 70728 izimpendulo
Kuphostiwe

I can't figure out why you get a completely different certificate when you visit the site compared with the one I get (*.googlevideo.com vs. www.google.com). Considering that you get Google's 404 error on the URL that should serve the YouTube home page only after you log in, I am suspicious that this could indicate foul play.

Could it be a connection issue? By default, Firefox will piggyback on your IE LAN settings, but you can check and modify that here:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

The default is "Use system proxy settings" but you also could try "No Proxy".

It's possible that extensions also could influence how you connect to YouTube. If you haven't already, could you test the page in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • (menu bar) Help > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

I can't figure out why you get a completely different certificate when you visit the site compared with the one I get (*.googlevideo''.''com vs. www.google''.''com). Considering that you get Google's 404 error on the URL that should serve the YouTube home page only after you log in, I am suspicious that this could indicate foul play. Could it be a connection issue? By default, Firefox will piggyback on your IE LAN settings, but you can check and modify that here: "3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button The default is "Use system proxy settings" but you also could try "No Proxy". It's possible that extensions also could influence how you connect to YouTube. If you haven't already, could you test the page in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * (menu bar) Help > Restart with Add-ons Disabled Not all add-ons are disabled: Flash and other plugins still run After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (''not'' Reset). Any difference?
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

I filed a bug on this and I hope we can get more investigateion: https://bugzilla.mozilla.org/show_bug.cgi?id=1049190

For investigation, can you please add the certificates from the good computer and from the original computer having the issue. Thank you!

I filed a bug on this and I hope we can get more investigateion: [https://bugzilla.mozilla.org/show_bug.cgi?id=1049190] For investigation, can you please add the certificates from the good computer and from the original computer having the issue. Thank you!