搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

youtube comments do not appear

  • 14 回覆
  • 37 有這個問題
  • 16052 次檢視
  • 最近回覆由 Potatoes

more options

When I watch a video on YouTube, the comments section does not load. Comments do load with other browsers (e.g.Safari.)

This has occurred since the change in YouTube's comment policies, November 2013.

Google Product Forum question "Why can't I see any comments on Youtube?" showed suggestions to disable Ad Block. I either don't have Ad Block or am not seeing it in my add-ons. Is there another add-on that could be causing the YouTube comments not to load?

被選擇的解決方法

Probably the problem is caused by lightbeam.

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

從原來的回覆中察看解決方案 👍 4

所有回覆 (14)

more options

選擇的解決方法

Probably the problem is caused by lightbeam.

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Thank you Nellus91. I just started in safe mode and I could see the comments again. Then I restarted the browser and disabled Adblock just on Youtube and hey what do you know the comments were viewable again. Thank you, for a minute there I really thought Google was trying for a takeover of the browsers because I could see the comments in Google Chrome and IE but not Firefox. Strange thing I have Adblock running in my Chrome browser and I had no problem.

more options

I have a similar problem on my Mac running 10.9

I have booted FIrefox into safe mode and when I click on the comment box a new window pops up and then quickly disappears. When I use Safari the box changes or a new window appears with a login option.

I have even booted FIrefox into safe mode with the block pop up windows option turned off and still see the new window briefly open and then close and am unable to comment on youtube videos.

more options

Thanks!

I started in Safe Mode and comments returned. Went through Add Ons; Lightbeam was not the culprit. In my case, the problem was caused by an old anti-tracking extension called "Disconnect 1.01." Disabling (& removing) that one seems to have fixed the problem.

Phew.

more options

For @maximara

In order to be able to find the correct solution to your problem, we require some more non-personal information from you. Please do the following:

  • Click the Firefox button at the top left, then click the Help menu and select Troubleshooting Information from the submenu. If you don't have a Firefox button, click the Help menu at the top and select Troubleshooting Information from the menu.

Now, a new tab containing your troubleshooting information should open.

  • At the top of the page, you should see a button that says "Copy text to clipboard". Click it.
  • Now, go back to your forum post and click inside the reply box. Press Ctrl+V to paste all the information you copied into the forum post.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

Thanks in advance for your help!

more options

Application Basics


Name: Firefox Version: 25.0 User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:25.0) Gecko/20100101 Firefox/25.0

Extensions


Name: 1Password Version: 4.0.1 Enabled: true ID: onepassword4@agilebits.com

Name: McAfee SiteAdvisor Version: 2.0 Enabled: true ID: {4ED1F68A-5463-4931-9384-8FFF5ED91D92}

Name: NoScript Version: 2.6.8.5rc1 Enabled: true ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: User Agent Switcher Version: 0.7.3 Enabled: true ID: {e968fc70-8f95-4ab9-9e79-304de2a71ee1}

Name: Adblock Plus Version: 2.4 Enabled: false ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Flash and Video Download Version: 1.42 Enabled: false ID: {bee6eb20-01e0-ebd1-da83-080329fb9a3a}

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.history_expire_days.mirror: 180 browser.places.createdSmartBookmarks: true browser.places.importBookmarksHTML: false browser.places.importDefaults: false browser.places.leftPaneFolderId: -1 browser.places.migratePostDataAnnotations: false browser.places.smartBookmarksVersion: 4 browser.places.updateRecentTagsUri: false browser.sessionstore.upgradeBackup.latestBuildID: 20131025151332 browser.startup.homepage: file:///Users/brucegrubb/Documents/Document-Library/HTML/Personal_Favorites.html browser.startup.homepage_override.buildID: 20131025151332 browser.startup.homepage_override.mstone: 25.0 dom.mozApps.used: true dom.w3c_touch_events.expose: false extensions.lastAppVersion: 25.0 font.internaluseonly.changed: true font.language.group: x-western font.name.serif.x-western: Times New Roman font.size.fixed.x-western: 14 font.size.variable.x-western: 14 gfx.blacklist.direct2d: 3 gfx.blacklist.layers.direct3d9: 3 keyword.URL: http://search.yahoo.com/search?fr=mcafee&p= layers.acceleration.disabled: true network.cookie.cookieBehavior: 1 network.cookie.prefsMigrated: true network.dns.disableIPv6: true places.database.lastMaintenance: 1383850309 places.history.expiration.transient_current_max_pages: 104858 places.history.expiration.transient_optimal_database_size: 128849018 places.last_vacuum: 1296420681 plugin.disable_full_page_plugin_for_types: video/x-ms-wmv,application/pdf plugin.importedState: true plugin.state.adobepdfviewernpapi: 0 plugin.state.google earth web plug-in: 0 plugin.state.nprevweb: 0 plugin.state.silverlight: 0 plugin.state.unity web player: 0 print.macosx.pagesetup-2: PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO print.print_bgcolor: false print.print_bgimages: false print.print_colorspace: print.print_command: print.print_downloadfonts: false print.print_duplex: 0 print.print_evenpages: true print.print_in_color: true print.print_margin_bottom: 0.5 print.print_margin_left: 0.5 print.print_margin_right: 0.5 print.print_margin_top: 0.5 print.print_oddpages: true print.print_orientation: 0 print.print_page_delay: 50 print.print_pagedelay: 500 print.print_paper_data: 0 print.print_paper_height: 11.00 print.print_paper_name: print.print_paper_size: 393235 print.print_paper_size_type: 1 print.print_paper_size_unit: 0 print.print_paper_width: 8.50 print.print_plex_name: print.print_printer: print.print_resolution: 0 print.print_resolution_name: print.print_reversed: false print.print_scaling: 1.00 print.print_shrink_to_fit: true print.print_to_file: false print.print_unwriteable_margin_bottom: 56 print.print_unwriteable_margin_left: 25 print.print_unwriteable_margin_right: 25 print.print_unwriteable_margin_top: 25 privacy.clearOnShutdown.cookies: false privacy.clearOnShutdown.formdata: false privacy.clearOnShutdown.passwords: true privacy.cpd.cookies: false privacy.cpd.formdata: false privacy.item.formdata: false privacy.item.passwords: true privacy.sanitize.migrateFx3Prefs: true security.warn_viewing_mixed: false storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1383579016

Graphics


Device ID: 0x94c8 GPU Accelerated Windows: 0/2 Basic Vendor ID: 0x1002 WebGL Renderer: ATI Technologies Inc. -- ATI Radeon HD 2400 XT OpenGL Engine windowLayerManagerRemote: false AzureCanvasBackend: quartz AzureContentBackend: quartz AzureFallbackCanvasBackend: none AzureSkiaAccelerated: 0

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.1 Version in use: 4.10.1

NSS Expected minimum version: 3.15.2 Basic ECC Version in use: 3.15.2 Basic ECC

NSSSMIME Expected minimum version: 3.15.2 Basic ECC Version in use: 3.15.2 Basic ECC

NSSSSL Expected minimum version: 3.15.2 Basic ECC Version in use: 3.15.2 Basic ECC

NSSUTIL Expected minimum version: 3.15.2 Version in use: 3.15.2

more options

@maximara Try to Update your addons

由 Nellus 於 修改

more options

Considering this behavior occurs when I launch Firefox in safe mode (ie ALL add ons are turned OFF) what goes does updating the add ons (which AFAIK are up to date to begin with) do?

more options

Just to save time here is the troubleshooting information in Safemode:

Application Basics


Name: Firefox Version: 25.0 User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:25.0) Gecko/20100101 Firefox/25.0

Extensions


Name: 1Password Version: 4.0.1 Enabled: false ID: onepassword4@agilebits.com

Name: Adblock Plus Version: 2.4 Enabled: false ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Flash and Video Download Version: 1.42 Enabled: false ID: {bee6eb20-01e0-ebd1-da83-080329fb9a3a}

Name: McAfee SiteAdvisor Version: 2.0 Enabled: false ID: {4ED1F68A-5463-4931-9384-8FFF5ED91D92}

Name: NoScript Version: 2.6.8.5rc2 Enabled: false ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: User Agent Switcher Version: 0.7.3 Enabled: false ID: {e968fc70-8f95-4ab9-9e79-304de2a71ee1}

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.history_expire_days.mirror: 180 browser.places.createdSmartBookmarks: true browser.places.importBookmarksHTML: false browser.places.importDefaults: false browser.places.leftPaneFolderId: -1 browser.places.migratePostDataAnnotations: false browser.places.smartBookmarksVersion: 4 browser.places.updateRecentTagsUri: false browser.sessionstore.upgradeBackup.latestBuildID: 20131025151332 browser.startup.homepage: file:///Users/brucegrubb/Documents/Document-Library/HTML/Personal_Favorites.html browser.startup.homepage_override.buildID: 20131025151332 browser.startup.homepage_override.mstone: 25.0 dom.mozApps.used: true dom.w3c_touch_events.expose: false extensions.lastAppVersion: 25.0 font.internaluseonly.changed: true font.language.group: x-western font.name.serif.x-western: Times New Roman font.size.fixed.x-western: 14 font.size.variable.x-western: 14 gfx.blacklist.direct2d: 3 gfx.blacklist.layers.direct3d9: 3 keyword.URL: http://search.yahoo.com/search?fr=mcafee&p= layers.acceleration.disabled: true network.cookie.cookieBehavior: 1 network.cookie.prefsMigrated: true network.dns.disableIPv6: true places.database.lastMaintenance: 1384023173 places.history.expiration.transient_current_max_pages: 104858 places.history.expiration.transient_optimal_database_size: 128849018 places.last_vacuum: 1296420681 plugin.disable_full_page_plugin_for_types: video/x-ms-wmv,application/pdf plugin.importedState: true plugin.state.adobepdfviewernpapi: 0 plugin.state.google earth web plug-in: 0 plugin.state.nprevweb: 0 plugin.state.silverlight: 0 plugin.state.unity web player: 0 print.macosx.pagesetup-2: PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO print.print_bgcolor: false print.print_bgimages: false print.print_colorspace: print.print_command: print.print_downloadfonts: false print.print_duplex: 0 print.print_evenpages: true print.print_in_color: true print.print_margin_bottom: 0.5 print.print_margin_left: 0.5 print.print_margin_right: 0.5 print.print_margin_top: 0.5 print.print_oddpages: true print.print_orientation: 0 print.print_page_delay: 50 print.print_pagedelay: 500 print.print_paper_data: 0 print.print_paper_height: 11.00 print.print_paper_name: print.print_paper_size: 393235 print.print_paper_size_type: 1 print.print_paper_size_unit: 0 print.print_paper_width: 8.50 print.print_plex_name: print.print_printer: print.print_resolution: 0 print.print_resolution_name: print.print_reversed: false print.print_scaling: 1.00 print.print_shrink_to_fit: true print.print_to_file: false print.print_unwriteable_margin_bottom: 56 print.print_unwriteable_margin_left: 25 print.print_unwriteable_margin_right: 25 print.print_unwriteable_margin_top: 25 privacy.clearOnShutdown.cookies: false privacy.clearOnShutdown.formdata: false privacy.clearOnShutdown.passwords: true privacy.cpd.cookies: false privacy.cpd.formdata: false privacy.item.formdata: false privacy.item.passwords: true privacy.sanitize.migrateFx3Prefs: true security.warn_viewing_mixed: false storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1383579016

Graphics


Device ID: 0x94c8 GPU Accelerated Windows: 0/1 Basic Vendor ID: 0x1002 WebGL Renderer: ATI Technologies Inc. -- ATI Radeon HD 2400 XT OpenGL Engine windowLayerManagerRemote: false AzureCanvasBackend: quartz AzureContentBackend: quartz AzureFallbackCanvasBackend: none AzureSkiaAccelerated: 0

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.1 Version in use: 4.10.1

NSS Expected minimum version: 3.15.2 Basic ECC Version in use: 3.15.2 Basic ECC

NSSSMIME Expected minimum version: 3.15.2 Basic ECC Version in use: 3.15.2 Basic ECC

NSSSSL Expected minimum version: 3.15.2 Basic ECC Version in use: 3.15.2 Basic ECC

NSSUTIL Expected minimum version: 3.15.2 Version in use: 3.15.2

more options

I should add that it is not just Firefox but some versions of Internet Explorer that are affected as well. See http://productforums.google.com/forum/#!topic/youtube/LUTDjJV_ykY[1-25-false] thread regarding this.

more options

Does this still happen in Firefox Safe Mode?


Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

cor-el how about READING before you post?

Name: Firefox Version: 25.0 User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:25.0) Gecko/20100101 Firefox/25.0....

Macintosh is not Windows.

Turns out that issue is that you have to do the following:

WIndows Options > Privacy > History section > Exceptions > Add: "google.com"

Macintosh Preferences > Privacy > History section > Exceptions > Add: "google.com"

So, it turns out Google is doing something goofy. Wonderful.

more options

Hey guys, I had this problem too and actually figured out what was causing it for me!

Don't know how useful this will be to other users as I don't expect most to have this add-on but I thought I'd let the community know anyway.

For me, it was an add-on. It was not hardware acceleration or a theme - just the add-on.

I'm running Firefox 26.0 and I DO have Ad-Block Plus installed, I also have Easy YouTube Video Downloader and DownloadHelper installed. *NONE of these was the culprit* - they are all still installed and enabled and YouTube comments are working FINE! (yay!)

The culprit for me, if you can believe it, was "Dragon NaturallySpeaking Rich Internet Application Support 1.0.0.6". Left this installed, simply disabled it from the add-ons menu and eveything's working properly again!

Again, I don't expect almost anyone to have this add-on (or it's parent application) installed on their system, but, if you do, THIS COULD BE YOUR CULPRIT!

Thanks guys, best of luck!

由 Inochi_Fumetsu 於 修改

more options

Try changing your computer time and date settings. Recently, I've encountered several web issues. I can't view my google maps & images and unable to access comments on youtube. Whenever I sign in to yahoo.com, texts scramble on the left side of my screen. 5 minutes ago, I discovered the solution to my problems! Web errors seem to occur from false date & time feed. To access date & time settings: On your desktop, please refer to the lower right corner of your screen. Left click the displayed time (Mine's 10:56 PM) > Click "Adjust Date/Time" > Change your settings to present time > Click Apply > Click OK.

Then open your browser, go to yahoo.com, and PRESTO! Hope this will work for all of you too. :)