搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How to get rid of plugin in use lego icon?

  • 39 回覆
  • 36 有這個問題
  • 4480 次檢視
  • 最近回覆由 finitarry

more options

How do i get rid of this annoying lego like icon next to the back button whenever i go on facebook, youtube or any site that uses a plugin? When I click the icon it opens a dialog that has 2 buttons, block or continue allowing on the use of the plugin on the site.. Anybody here know of an addon or about:config thing i can set to false to hide the lego icon?

所有回覆 (20)

more options

This is what i am talking about if any of you wanted a screenshot.

more options

You can inspect and manage the permissions for all domains on the about:permissions page or for the domain in the currently selected tab by clicking the "Site Identity Button" (globe/padlock) on the location bar and "More Information" to open "Page Info" and go to the Permissions tab.

You can also check if click-to-play is enabled and disable it when necessary.

more options

@cor-el your reply kinda didn't help. I don't have click to play on at all and i just want to know, is there a way to hide that lego icon thing that appears next to the back button.

more options

Did you check the plugin settings in "Tools > Page Info > Media" while being on a website that shows this icon?

more options

** Speculation Follows **

Are you using the click-to-play feature (toggled plugins.click_to_play preference in about:config from false to true)? Firefox 24 changed this feature: instead of having the click feature be inside each individual instance of the Flash player (for example), it now is set on a site-by-site basis. That might explain the new icon, since otherwise it would not be obvious how to switch the setting. I guess it's too obvious now...

more options

Yes I have done that.

more options

jscher, why would they do that? The beauty of a plugin controller is to be able to pick which items you want to load and block the rest on a page. With this new method, you have to block the plugin to stop it from playing and then click the placeholder when ready to view the item. That is just crazy! This thing is on a site-by-site basis, not even a page-by-page basis?

I hope SeaMonkey is not going to do the same thing with its plugins.click_to_play.

more options

Hi finitarry, there are a variety of use cases... This article has more background on the change: Firefox 24: Restore Click to Play per element | Ghacks.

more options

Actually, I just saw this "lego" piece for a page using Silverlight, and I do not use click-to-play.

It would not be difficult to suppress the little icon using a style rule (userChrome.css or Stylish extension) but this would leave a slim notification area (second frame of attached screen shot). This could be suppressed entirely, but I can't think of a way to suppress it conditionally for some notifications but not for others -- and there are many (third frame of attached screen shot). Perhaps someone else has an idea about that.

more options

Thanks for the link. I got the extension recommended by that page and it does work.

more options

Is there anyway to hide the notification icon for plugins that have been approved for sites? I tried hiding the icon with Stylish, but unless I hide all notifications, it leaves a blank space in the navigation bar for sites that use a plugin. I don't need or want to see the gray icon reminding me that I've allowed a plugin to run.

more options

Hi noOneHere81, if your rule is display:none that will leave a narrower space than visibility:hidden (as shown in my earlier screen shot), but I don't know whether a style rule can be crafted to hide the entire notification area based on the icon displayed in it.

more options

Try the following rule -- the negative margins zap the notification area:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
/* Gray icon saying plugin is active and providing option to block */
#plugins-notification-icon{
  width: 0px !important;
  margin-left: -5px !important;
  margin-right: -5px !important;
}

To remove the site's permission to run a plugin, you have the alternative of accessing the Permissions tab of the Page Info dialog. To call up that dialog, you can choose one of these methods:

  • Click the site identity icon (globe or padlock) > More Information
  • Right-click the page > View Page Info
  • Tools menu > Page Info
more options

Where does one put that code?

more options

Custom style rules can be applied using two different approaches:

Note: Stylish is real time, userChrome.css edits require a restart.

more options

I added that code and it ALMOST works. It takes the lego out of the address bar but moves about 10-10px of it to the space between the address and the first button to the left of it (in my case the home button). Any way to actually get rid of it instead of masking it partially?

more options

Hi FrogSteaks, if I move the Home icon to the left of the address bar, I need to increase the negative margin adjustment to -6px on each side. However, the icon is not visible at all for me and the notification area never escapes outside the address bar.

Can you post a screen shot of your address bar?

Note: I am using the default theme. The background of the Navigation toolbar is not transparent.

more options

Sorry my replies are delayed. Another new feature of FF is causing me to log into every site each time I leave it whether r not I have saved passwords or tell the site to remember me. Ah I so LOVE being protected from myself! ANYWAY, I moded the css to -6 and still no help. here is a snippet of screen from a standard site and youtube. When i load youtube, for a split second the favicon appears and with no hint of the lego but right after the partial lego appears. You will see the issue in the red square.

more options

Hi FrogSteaks, Firefox should still store cookies until the end of the session (or until expiration if you allow that); you'd need an extension to crumble them when you navigate away from them for a while or close the tab.

My style rule isn't fully compatible with whatever theme you are using. If I get time to test with that theme, I will. What theme is it?

more options

This works for me better on Linux (no shifting of the SIB button when switch tabs)

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#plugins-notification-icon {
width:0px !important;
margin-left:-6px !important;
margin-right:-7px !important;
}
  1. 1
  2. 2