X
點擊此處開啟此網站的行動版。

技術支援討論區

Cannot use twitter all of a sudden using Firefox 17

已張貼

Ordinarily I can use twitter no problem with Firefox. But now all of a sudden it logs me in, and takes me to pages but will not allow me to post tweets, reply to others, or retweet or log out or send direct messages. So basically I cannot do anything unless I use internet explorer, where it seems to work. I don't want to use IE or I wouldn't have Firefox! It is not my twitter account because the same thing happens on other accounts logged in on this pc. I have tried downloading a new version of firefox, removing all twitter cookies and everything else. My account and firefox work on the "Tweetdeck" site but not the actual twitter site. Is there anything I can do because you cannot email twitter (well, I don't have an email address that works for them!! )

Ordinarily I can use twitter no problem with Firefox. But now all of a sudden it logs me in, and takes me to pages but will not allow me to post tweets, reply to others, or retweet or log out or send direct messages. So basically I cannot do anything unless I use internet explorer, where it seems to work. I don't want to use IE or I wouldn't have Firefox! It is not my twitter account because the same thing happens on other accounts logged in on this pc. I have tried downloading a new version of firefox, removing all twitter cookies and everything else. My account and firefox work on the "Tweetdeck" site but not the actual twitter site. Is there anything I can do because you cannot email twitter (well, I don't have an email address that works for them!! )

被選擇的解決方法

Thanks. It seems the add on that is causing MY problem is the AVG search toolbar. So I have disabled that. AVG always seems to cause a problem for me!!!

從原來的回覆中察看解決方案 3

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • npsitesafety
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • Logitech Device Detection
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

更多資訊

David Tenser 30 個解決方法 310 個答案

Hi Andromedakraken,

This might be due to updated code on Twitter.com causing Firefox to fail due to obsolete cache. Follow these instructions and see if that solves the issue: https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

Hope this helps!

- David

Hi Andromedakraken, This might be due to updated code on Twitter.com causing Firefox to fail due to obsolete cache. Follow these instructions and see if that solves the issue: https://support.mozilla.org/en-US/kb/how-clear-firefox-cache Hope this helps! - David

提出問題者

Thanks so much for the suggestion but I am afraid following those instructions did not help. I still have the same problem.

Thanks so much for the suggestion but I am afraid following those instructions did not help. I still have the same problem.
Derek C 0 個解決方法 11 個答案

I had this same problem from this morning. So restarted Firefox in 'safe mode' with all addons etc disabled - and twitter worked!

Now all I have to do is work out which addon is the problem... *grumbles* *goes to make another cup of tea*

I had this same problem from this morning. So restarted Firefox in 'safe mode' with all addons etc disabled - and twitter worked! Now all I have to do is work out which addon is the problem... *grumbles* *goes to make another cup of tea*
Derek C 0 個解決方法 11 個答案

有幫助的回覆

Found it. In my case anyway. My problems with twitter not working in firefox were caused by the 'Ghostery 2.8.3' extension. Disabled it and twitter worked fine.

Found it. In my case anyway. My problems with twitter not working in firefox were caused by the 'Ghostery 2.8.3' extension. Disabled it and twitter worked fine.

提出問題者

Very interesting. I don't suppose you could tell me how to do this??

Very interesting. I don't suppose you could tell me how to do this??

提出問題者

Oh it's OK! I just tried it and you are correct! Whichever add on we must both be using is interfering with twitter. It works for me now.

Oh it's OK! I just tried it and you are correct! Whichever add on we must both be using is interfering with twitter. It works for me now.
Derek C 0 個解決方法 11 個答案

有幫助的回覆

If you have Ghostery, it should be in your addons list. Access this through the firefox menu. It should be on the 'extensions' tab.

If you have Ghostery, it should be in your addons list. Access this through the firefox menu. It should be on the 'extensions' tab.
Derek C 0 個解決方法 11 個答案

Cool! Have just checked on the developer's site - and they are aware of the problem and working on a fix.

https://getsatisfaction.com/ghostery/topics/ghostery_breaks_twitter_in_firefox_for_win7x64

Cool! Have just checked on the developer's site - and they are aware of the problem and working on a fix. https://getsatisfaction.com/ghostery/topics/ghostery_breaks_twitter_in_firefox_for_win7x64

選擇的解決方法

Thanks. It seems the add on that is causing MY problem is the AVG search toolbar. So I have disabled that. AVG always seems to cause a problem for me!!!

Thanks. It seems the add on that is causing MY problem is the AVG search toolbar. So I have disabled that. AVG always seems to cause a problem for me!!!
David Tenser 30 個解決方法 310 個答案

Hi Andromedakraken,

The AVG toolbar is useless, to be perfectly honest. It's definitely best to leave it disabled like you did. Glad your problem was solved!

Cheers, David

Hi Andromedakraken, The AVG toolbar is useless, to be perfectly honest. It's definitely best to leave it disabled like you did. Glad your problem was solved! Cheers, David

提出問題者

Hmmm, ok then! Thanks :-)

Hmmm, ok then! Thanks :-)

提出問題者

PS. I have had that toolbar on my browser for aeons so I cannot understand why it would suddenly interfere with twitter. Weird

PS. I have had that toolbar on my browser for aeons so I cannot understand why it would suddenly interfere with twitter. Weird
mt3ch 3 個解決方法 26 個答案

I don't have ghostery or AVG toolbar but in Fx 17 I cannot log into Twitter, follow anyone or post tweets. When I click on login the form that usually drops down does not appear.

I also am not able to log into sites using Facebook connect.

Something is interfering with the javascript libraries they use, no doubt (not "noscript" which I turn off).

Everything works in Chrome and IE.

I don't have ghostery or AVG toolbar but in Fx 17 I cannot log into Twitter, follow anyone or post tweets. When I click on login the form that usually drops down does not appear. I also am not able to log into sites using Facebook connect. Something is interfering with the javascript libraries they use, no doubt (not "noscript" which I turn off). Everything works in Chrome and IE.

由 mt3ch 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17688 個解決方法 160015 個答案

Hi mt3ch

Try to clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
Hi mt3ch Try to clear the cache and the cookies from sites that cause problems. "Clear the Cache": *Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Tools > Options > Privacy > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do not click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
mt3ch 3 個解決方法 26 個答案

I narrowed this problem down to the "ShareMeNot" addon that is blocking certain script libraries used on Twitter and Facebook Connect.

I narrowed this problem down to the "ShareMeNot" addon that is blocking certain script libraries used on Twitter and Facebook Connect.
Derek C 0 個解決方法 11 個答案

Spot the emerging theme.

Seems to me that the twitter button (on websites) is now regarded as a 'tracker' by anti-tracking add-ons. Unless the writer's update their add-ons, users must "whitelist" twitter.com. Hmmm. Interesting. You want to use their website - you must allow them to track you?!

Spot the emerging theme. Seems to me that the twitter button (on websites) is now regarded as a 'tracker' by anti-tracking add-ons. Unless the writer's update their add-ons, users must "whitelist" twitter.com. Hmmm. Interesting. You want to use their website - you must allow them to track you?!

由 Derek C 於 修改

ryderwriter 0 個解決方法 4 個答案

Firefox 18 and same problems with Twitter. I've even tried accessing Twitter while using Firefox in "safe mode" and does not work. I've disabled all add ons and Twitter does not work. What am I missing?

Firefox 18 and same problems with Twitter. I've even tried accessing Twitter while using Firefox in "safe mode" and does not work. I've disabled all add ons and Twitter does not work. What am I missing?
David Tenser 30 個解決方法 310 個答案

ryderwriter, try clearing your cache to rule out that being the issue: https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

ryderwriter, try clearing your cache to rule out that being the issue: https://support.mozilla.org/en-US/kb/how-clear-firefox-cache
cor-el
  • Top 10 Contributor
  • Moderator
17688 個解決方法 160015 個答案

See also:

You can try to reset (power off/on) the router.

See also: *http://kb.mozillazine.org/Error_loading_websites You can try to reset (power off/on) the router.
ryderwriter 0 個解決方法 4 個答案

Cleared the cache. No luck. Cleared cookies, history. No luck. Rebooted. No luck.


The only way Twitter will work with Firefox 18 for me is to use Firefox in Safe Mode.

Cleared the cache. No luck. Cleared cookies, history. No luck. Rebooted. No luck. The only way Twitter will work with Firefox 18 for me is to use Firefox in Safe Mode.