X
點擊此處開啟此網站的行動版。

技術支援討論區

Cannot use twitter all of a sudden using Firefox 17

已張貼

Ordinarily I can use twitter no problem with Firefox. But now all of a sudden it logs me in, and takes me to pages but will not allow me to post tweets, reply to others, or retweet or log out or send direct messages. So basically I cannot do anything unless I use internet explorer, where it seems to work. I don't want to use IE or I wouldn't have Firefox! It is not my twitter account because the same thing happens on other accounts logged in on this pc. I have tried downloading a new version of firefox, removing all twitter cookies and everything else. My account and firefox work on the "Tweetdeck" site but not the actual twitter site. Is there anything I can do because you cannot email twitter (well, I don't have an email address that works for them!! )

Ordinarily I can use twitter no problem with Firefox. But now all of a sudden it logs me in, and takes me to pages but will not allow me to post tweets, reply to others, or retweet or log out or send direct messages. So basically I cannot do anything unless I use internet explorer, where it seems to work. I don't want to use IE or I wouldn't have Firefox! It is not my twitter account because the same thing happens on other accounts logged in on this pc. I have tried downloading a new version of firefox, removing all twitter cookies and everything else. My account and firefox work on the "Tweetdeck" site but not the actual twitter site. Is there anything I can do because you cannot email twitter (well, I don't have an email address that works for them!! )

被選擇的解決方法

Thanks. It seems the add on that is causing MY problem is the AVG search toolbar. So I have disabled that. AVG always seems to cause a problem for me!!!

從原來的回覆中察看解決方案 3

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • npsitesafety
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • Logitech Device Detection
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

更多資訊

cor-el
  • Top 10 Contributor
  • Moderator
17771 個解決方法 160723 個答案

If it works in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")


In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used (localstore-safe.rdf)
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected
If it works in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit") *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- In Firefox Safe mode these changes are effective: *all extensions are disabled *the default theme is used (no persona) *userChrome.css and userContent.css are ignored *the default toolbar layout is used (localstore-safe.rdf) *the Javascript JIT compiler is disabled *hardware acceleration is disabled *plugins are not affected *preferences are not affected
ryderwriter 0 個解決方法 4 個答案

Good tip to close and start firefox after each change. I was going to do the process of elimination, but the close and restart tip was one I'd not factored in. Thanks for the tip. I'll try it and let you know which add-on was causing problems with Twitter. I've been using Firefox in "safe mode" since the middle of last week.

Without "safe mode" new tabs do not open by using ctrl T, or clicking on the "+" sign, or clicking on the new tab option under "file."

Good tip to close and start firefox after each change. I was going to do the process of elimination, but the close and restart tip was one I'd not factored in. Thanks for the tip. I'll try it and let you know which add-on was causing problems with Twitter. I've been using Firefox in "safe mode" since the middle of last week. Without "safe mode" new tabs do not open by using ctrl T, or clicking on the "+" sign, or clicking on the new tab option under "file."
Daronn22 0 個解決方法 3 個答案

I have all the same problems and I've tried all of the mentioned solutions but none seem to work. However *magically* it temporarily works after resetting firefox and opening Twitter right after, but if I reload or open another tab with twitter it goes back to its problematic state. Help! I don't want to have to use another browser.

I have all the same problems and I've tried all of the mentioned solutions but none seem to work. However *magically* it temporarily works after resetting firefox and opening Twitter right after, but if I reload or open another tab with twitter it goes back to its problematic state. Help! I don't want to have to use another browser.

由 Daronn22 於 修改

ryderwriter 0 個解決方法 4 個答案

I disabled add-on's one at a time until I found the culprit. It was and Avery.com add on for downloading templates. I really can't say that was the problem because I had intermittent successes before I attempted the disabling of add-ons. But it's working now.

I disabled add-on's one at a time until I found the culprit. It was and Avery.com add on for downloading templates. I really can't say that was the problem because I had intermittent successes before I attempted the disabling of add-ons. But it's working now.
brettmcleod 0 個解決方法 3 個答案

I have been having this problem too, i was using Firefox 18 yesterday as i have been for a very long time without having any problem then out of know where my twitter doesnt work so i tried updating to Firefox 19, still have this problem, i uninstalled my Firefox browser and went to internet explorer and my twitter works fine with internet explorer, but i would rather be using Firefox, i just reinstalled Firefox from scratch and twitter still doesn't work, i don't have any add on's so it looks like i might just have to switch back to internet explorer until someone can tell me how to fix this problem/ any ideas and no i don't have any add on's at all thanks Brett

I have been having this problem too, i was using Firefox 18 yesterday as i have been for a very long time without having any problem then out of know where my twitter doesnt work so i tried updating to Firefox 19, still have this problem, i uninstalled my Firefox browser and went to internet explorer and my twitter works fine with internet explorer, but i would rather be using Firefox, i just reinstalled Firefox from scratch and twitter still doesn't work, i don't have any add on's so it looks like i might just have to switch back to internet explorer until someone can tell me how to fix this problem/ any ideas and no i don't have any add on's at all thanks Brett
Derek C 0 個解決方法 11 個答案

If you don't have any add-ons or extensions that could be causing the problem, perhaps it could be a settings issue. I have firefox 19 (with Ghostery, NoScript and other add-ons) and twitter works fine for me. The only way I could replicate the problem experienced by brettmcleod is by disabling javascript in the browser. Twitter needs javascript. I would check that this setting in options is enabled - other than that I'm stumped, sorry.

If you don't have any add-ons or extensions that could be causing the problem, perhaps it could be a settings issue. I have firefox 19 (with Ghostery, NoScript and other add-ons) and twitter works fine for me. The only way I could replicate the problem experienced by brettmcleod is by disabling javascript in the browser. Twitter needs javascript. I would check that this setting in options is enabled - other than that I'm stumped, sorry.
brettmcleod 0 個解決方法 3 個答案

thanks, i will check it out tomorrow, i have been using internet explorer all night and i am sick of it already, Firefox is so much more user friendly, i just don't understand how everything was fine for the past 6 months and then all of a sudden it doesn't work, but i will check to see if JavaScript needs an update or something, thanks for your reply, i will let you know how i go with it. cheers Brett

thanks, i will check it out tomorrow, i have been using internet explorer all night and i am sick of it already, Firefox is so much more user friendly, i just don't understand how everything was fine for the past 6 months and then all of a sudden it doesn't work, but i will check to see if JavaScript needs an update or something, thanks for your reply, i will let you know how i go with it. cheers Brett
Daronn22 0 個解決方法 3 個答案

A temporary solution I've been using so far is to use firefox with private browsing.

A temporary solution I've been using so far is to use firefox with private browsing.
cor-el
  • Top 10 Contributor
  • Moderator
17771 個解決方法 160723 個答案

If it works in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used (localstore-safe.rdf)
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected
If it works in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit") *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled *the default theme is used (no persona) *userChrome.css and userContent.css are ignored *the default toolbar layout is used (localstore-safe.rdf) *the Javascript JIT compiler is disabled *hardware acceleration is disabled *plugins are not affected *preferences are not affected
brettmcleod 0 個解決方法 3 個答案

thanks for that, yes it all works with private browsing :)) I will use that until i track down the problem. off to work will try the other options tonight, thank you all for your replies cheers Brett

thanks for that, yes it all works with private browsing :)) I will use that until i track down the problem. off to work will try the other options tonight, thank you all for your replies cheers Brett
cor-el
  • Top 10 Contributor
  • Moderator
17771 個解決方法 160723 個答案

Is Private Browsing the disk cache and the cookies from the regular browser session are disabled.

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.

Is Private Browsing the disk cache and the cookies from the regular browser session are disabled. If clearing cookies doesn't work then it is possible that the <i>cookies.sqlite</i> file that stores the cookies is corrupted. Rename (or delete) <b>cookies.sqlite</b> (cookies.sqlite.old) and delete other present cookie files like <b>cookies.sqlite-journal</b> in the Firefox Profile Folder in case the file cookies.sqlite got corrupted. *http://kb.mozillazine.org/Cookies *https://support.mozilla.org/kb/Deleting+cookies
Daronn22 0 個解決方法 3 個答案

Unfortunately cor-el that didn't help. I deleted the cookies.sqlite and the other cookies._____ files then restarted and nothing has changed. I should also mentioned that if I sign out and sign in again the page is completely functional until I refresh.

Unfortunately cor-el that didn't help. I deleted the cookies.sqlite and the other cookies._____ files then restarted and nothing has changed. I should also mentioned that if I sign out and sign in again the page is completely functional until I refresh.