搜尋 Mozilla 技術支援網站

小心釣魚網站: Mozilla 絕對不會要求您來電,或造訪不是 Mozilla 的網站,請忽略這類請求。

Learn More

Firefox loads pages barely/not

  • 14 回覆
  • 140 有這個問題
  • 1091 次檢視
  • 最近回覆由 pandora1123

more options

Firefox recently doesn't load pages anymore, or it loads them only partially. The startpage (google) is sometimes loaded completely, sometimes it appears only blank. If I go to other pages, FF aborts the loading process and only the background color is loaded, or it appears completely blank. But he states, that the page is loaded... The connection with IE works, and it seems, when I load some pages in IE and visit them after that in FF, a little bit more of the page is loaded. It is no problem with a firewall (since I am not running any, only a hardware-firewall). I have also created a new profile, and reinstalled firefox. Antivir is running but the problem remains when I deactivate its processes. It may have something to do with a virus, which I removed beforehand...

被選擇的解決方法

Do a malware check with a few malware scan programs. You need to use all programs because each detects different malware. Make sure that you update each program to get the latest version of the database.

See also "Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked and What to do when searches take you to the wrong search website


More: http://kb.mozillazine.org/Error_loading_websites

從原來的回覆中察看解決方案 👍 5

所有回覆 (14)

more options

It's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode (don't forget to select Disable all add-ons when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and themes and this one for plugins.

If you need support for one of your add-ons, you'll have to contact its author.

If the problem does not disappear when all add-ons are disabled, please tell me, so we can work from there. Please have no fear of following my instructions to the line, as all can be easily undone.

more options

Ok, I have started FF in safe-mode with disabled add-ons. Unfortunately, that didn't help. After that, I decided to delete all settings by checking every box and clicking "make changes and restart". Now, my FF looks like installed freshly, but the problem persists...

I also made two sample screenshots to illustrate the problem. Sometimes it loads less of the page, sometimes more. But mostly the pages remain blank.

more options

選擇的解決方法

Do a malware check with a few malware scan programs. You need to use all programs because each detects different malware. Make sure that you update each program to get the latest version of the database.

See also "Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked and What to do when searches take you to the wrong search website


More: http://kb.mozillazine.org/Error_loading_websites

more options

Excellent. I've scanned my PC with all of these programs (indeed, all of them found different malware) and after that, FF works finally!

more options

MrMuh: If you come around again would you mind telling us what malware you found? It would be great to know the solution without installing all of these things and running loooooong scans.

more options

Knowing that wouldn't help you. There are a lot of viruses and malware around and only those specialized scanners can detect and remove them safely. If you suspect a malware infection then you need to perform such scans as soon as possible.

more options

I have the same problem and safe mode & disabling of plug ins did not fix it. I full system vitus scan showed no problems, Internet Explorer works fine. But the images do not all load and this includes some functionality as well - such as the buttons to click after one enters a search term at a website, so there is no way to initiate the search and enter does not work either. I have no problem on another computer

more options

By the way, I tried to upload a screenshot of this page which should show the symptom but the 500K never ever finished uploading. Note that the background on this every page I load in Firefox is white. I also uninstalled and reinstalled Firefox with no improvement.

more options

I've seen the same that you keep seeing that spinning image, but it appears that the upload is successful. Only it doesn't indicate that the upload has finished. You can check that by clicking the Preview button, that should show a small thumbnail of the uploaded image.


Did you check for other problems?

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).
See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

Create a new profile as a test to check if your current profile is causing the problems.
See Basic Troubleshooting: Make a new profile
There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins"
If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)
See http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

more options

Thanks so much Cor-el. Making a new profile worked like a charm, though I have no idea why. I had previously tried safe mode so knoew that did not work. I must say it was a tad disappointing to find such a solution, because I spent a lot of time trying to solve this issue and it would seem to me to have been a bug?

I am glad thet you were there to help. Thanks again.

Paul

more options

You're welcome.

If you can't fix it quickly, either with clearing cache and cookies or via Safe-mode then it is easier to try a new profile.

more options

i have the same page loading problem my website pages does not load fully at times and some times every thing works well , FF loads a blank page and on refreshing the page it loads the full page.

my website has xhtml pages.

please see the below screen shot of partially loaded page

由 vamship 於 修改

more options

Did you try to disable Firebug?

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

more options

MrMuh i don't believe it! i have been battling this beast for a month. i also had a virus that i couldn't find with anything. it redirected when logging into aol email and asked for credit info. i was skeptical i am very hesitant to download anything i don't recognize. YOU FIXED IT! you saved a computer from flying out the window.