Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Failure to connect when clicking on verified url links

  • 2 回覆
  • 0 有這個問題
  • 1 次檢視
  • 最近回覆由 zeroknight

more options

Whenever I get a link whether in an email from a verified sender or from using a site like Amazon, clicking on a link always results in "Hmm. We’re having trouble finding that site." This has happened ever since loading the most recent version of Firefox (124.0.2) and it is very, very frustrating. What is causing this? Even in "safe" mode this occurs. Please rectify this situation. I do not want to have to change browsers after more than 20 years with Firefox.

Robert Jonathan Blue

Whenever I get a link whether in an email from a verified sender or from using a site like Amazon, clicking on a link always results in "Hmm. We’re having trouble finding that site." This has happened ever since loading the most recent version of Firefox (124.0.2) and it is very, very frustrating. What is causing this? Even in "safe" mode this occurs. Please rectify this situation. I do not want to have to change browsers after more than 20 years with Firefox. Robert Jonathan Blue

所有回覆 (2)

more options

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.


Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check the connection settings and check for possible issues with a Proxy or VPN service.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a Proxy to connect to internet, select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See also:

由 cor-el 於 修改

有幫助嗎?

more options

Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection".

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題