搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Must enter Captcha characters every time I try to access the Amazon website

  • 2 回覆
  • 2 有這個問題
  • 209 次檢視
  • 最近回覆由 gerrybroman

more options

For the past few days I get the request to enter captcha characters every time I try to access the Amazon website using Firefox on my Win10 PC. It works fine on my Firefox for android on my phone and also works fine using the Edge browser on this PC.

I've tried resetting Firefox. I've tried troubleshooting mode. I've tried turning off enhanced tracking. What else could cause Amazon.com to feel the need to verify that I am not a robot ?

For the past few days I get the request to enter captcha characters every time I try to access the Amazon website using Firefox on my Win10 PC. It works fine on my Firefox for android on my phone and also works fine using the Edge browser on this PC. I've tried resetting Firefox. I've tried troubleshooting mode. I've tried turning off enhanced tracking. What else could cause Amazon.com to feel the need to verify that I am not a robot ?

被選擇的解決方法

I did try in Private Mode. In fact I was just coming back here to report a possible solution.

I started a new Firefox Profile and can access the Amazon site from it with no problem, so I am assuming at this point that there is some corruption in my current profile that is causing me to look suspicious to the captcha engine. I will rebuild my profile with all of my add-ons, bookmarks etc to confirm.

I'll mark this as solved if it works.

從原來的回覆中察看解決方案 👍 0

所有回覆 (2)

more options

Detail like websites remembering you and log you in automatically is stored in cookies, so make sure you aren't clearing important cookies.

You can use these steps to make a website recognize and remember you.

  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" keeps cookies with an allow exception
  • using "Clear history when Firefox closes" to clear cookies clears all cookies including cookies with an allow exception you may want to keep
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

選擇的解決方法

I did try in Private Mode. In fact I was just coming back here to report a possible solution.

I started a new Firefox Profile and can access the Amazon site from it with no problem, so I am assuming at this point that there is some corruption in my current profile that is causing me to look suspicious to the captcha engine. I will rebuild my profile with all of my add-ons, bookmarks etc to confirm.

I'll mark this as solved if it works.

由 gerrybroman 於 修改