搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

此討論串已經關閉並封存。 如果您有需要幫助,請新增一個新問題

Other Bookmarks popped up in Toolbar

  • 33 回覆
  • 10 有這個問題
  • 8833 次檢視
  • 最近回覆由 Chris Ilias

more options

On 1/5/21 at about 1200 PST, Other Bookmarks popped up in my Toolbar. I am trying to remove it but have had no success. I deleted the one website that was in Other Bookmarks but it is still in my Toolbar. How do I remove, Other Bookmarks from my Toolbar?

附加的畫面擷圖

被選擇的解決方法

The browser.toolbars.bookmarks.2h2020 pref controls whether to enable new features for the Bookmarks Toolbar that are currently under development. Having this pref enabled also adds new options for showing the Bookmarks Toolbar (never|always|newtab). Disabling this pref (i.e. set its value to false) shouldn't cause issues apart from disabling the new features.

從原來的回覆中察看解決方案 👍 5

所有回覆 (20)

more options

If the Other Bookmarks folder is empty then you shouldn't see this folder on the toolbar.

Did you try to close (Quit) and restart Firefox after removing all bookmarks from this folder ?

You might be part of a study that has enabled some new bookmark features.

You can check this pref on the about:config page and make sure it is false.

  • browser.toolbars.bookmarks.2h2020 = false

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Note that Firefox 85 will come with a pref to control whether to display this folder on the Bookmarks Toolbar, in Firefox 86 you can right-click empty space on the Bookmarks Toolbar.

more options

I checked and browser.toolbars.bookmarks.2h2020 is set to true. If I toggle to false will this change anything else?

more options

選擇的解決方法

The browser.toolbars.bookmarks.2h2020 pref controls whether to enable new features for the Bookmarks Toolbar that are currently under development. Having this pref enabled also adds new options for showing the Bookmarks Toolbar (never|always|newtab). Disabling this pref (i.e. set its value to false) shouldn't cause issues apart from disabling the new features.

more options

Thank you for your help on this matter!

more options

Solution only works if you kill and restart firefox and removes the Bookmark This Page option from the bookmark menus. Useless !!! Why do you guys insist on adding half hearted extras without the ability to enable/disable those we wish to use.

more options

Note that in Firefox 85+ you can hide this folder on the Bookmarks Toolbar if you right-click this folder (Show Other Bookmarks).

more options

I will try to write a very positive comment... this is Firefox and I like it very much. Please keep it looks, no need to have "The Chrome" looks here ;)

more options

Thank you Cor-el !

This issue was driving me crazy; the "Other Bookmarks" folder had suddenly appeared and crowded out bookmarks I needed to be visible on my bookmarks toolbar. Other solutions I tried didn't work. Based on what you said above, I upgraded to Firefox Beta (v. 85), and lo and behold -- now when I right-click on that rogue "Other Bookmarks" folder there is now an option to "Hide Other Bookmarks." And it worked like a charm and solved my issue. Thank you!

more options

ofer_davidi said

I will try to write a very positive comment... this is Firefox and I like it very much. Please keep it looks, no need to have "The Chrome" looks here ;)

Actually Firefox used to have this button and it went missing in some of the UI changes. My muscle memory loves having it back.

more options

What kind of rubbish is this? Why do they fix what is not broken?

由 buzzme 於 修改

more options

buzzme said

Why do they fix what is not broken?

Installing Beta v85 did the trick, just right click on "Other Bookmarks" and uncheck the box at the bottom. It seems they add annoying features and force users to use "Beta" versions. "By default Beta sends your information and data to Mozilla and our partners".

The more liberal this organization has become, the more obvious their nefarious actions. Liberals (def): Say one thing publicly, do the opposite privately. Creating a new tab for every new web page (Android browser) is another example.

more options

These new features are currently grouped under browser.toolbars.bookmarks.2h2020 and this pref is normally false in Firefox 84. There has been a shield study started that enables this pref and its new features for a small selected group of users to check their response, so if browser.toolbars.bookmarks.2h2020 pref is true then you can check the about:studies page to see if you participate in this study.

more options

Other Bookmarks appeared and I don't want it on my toolbar. I downloaded the "latest" Firefox and there's no option to remove it.

I know you thought I'd love it, and therefore there needn't be an option to remove it, but guess what?

I don't want it.

Thanks, anyway.

more options

Next week Firefox 85 will be released and in that version you can remove the added Other Bookmarks button via the right-click context menu. If Firefox 84 you will have to set browser.toolbars.bookmarks.2h2020 = false on the about:config page.

more options

They dont really explain how to remove it easily to people like me or someone like Big Brid. It took me a little bit to figure it out. Here is how you remove it.

1.Just copy this: about:config Paste it to your address bar 2. A warning page may appear. Click Accept the Risk and Continue to continue to the about:config page. 3. Then click on show all 4. scroll down until you see: 'browser.toolbars.bookmarks.2h2020 5. on the right you will see some arrows click on them to change from True TO False 6. YOUR DONE

由 buzzme 於 修改

more options

browser.bookmarks.autoExportHTML has nothing to do with this issue. browser.bookmarks.autoExportHTML sets whether to export the bookmarks to an bookmarks.html file in the profile folder each time you close Firefox. For the issue with the Other Bookmarks appearing at the far right (i.e. to the right of a possible overflow chevron) on the Bookmarks Toolbar you need to modify browser.toolbars.bookmarks.2h2020 and set its value to false.

You likely participate in a shield study that sets this pref to true if you see this button appearing in Firefox 84.

由 cor-el 於 修改

more options

Setting to false worked for me. The bloody folder just popped up on my toolbar today

more options

I'm Not Using Google Chrome. How about some "INSTRUCTIONS as to where to find this; "set browser.toolbars.bookmarks.2h2020 = false + restart". I tried Searching by putting it in the Browser. It led to here... Again. It's not on/in my PC's Menu, nor is there a place to search in the Mozilla Firefox Side Bar. I tried "eenie meenie miny moe"... That didn't work either. "about:config" is a dead end, as it tried (And failed) to open an IE page. "Navigation to the webpage was canceled". Couldn't take a Screenshot... That feature doesn't work on a Failed IE page. I don't know if you people realize it or not, but not everyone knows everything about this stuff.

由 koa 於 修改

more options

Hi kingofnicepeople, I'm not sure what you mean here when you refer to an IE page:

"about:config" is a dead end, as it tried (And failed) to open an IE page. "Navigation to the webpage was canceled".

about:config is an internal page in Firefox, you need to access it through Firefox's address bar.

Alternately, can you open this internal page through Firefox's address bar:

about:about

Important: do not put anything before about: or after the second about. That is the entire address. If that page will load, it gives access to about:config.

more options

IE is Internet Explorer... The worst Browser ever. All I want to do is get rid of the "Other Bookmarks" in my Bookmarks Toolbar, without losing my Other Bookmarks in my Menu Bar, and get the Bookmarks Toolbar Menu back to normal... The way it was before it changed last night. I know I'm not the only person who hates it. There are some who thanked the person who Posted "set browser.toolbars.bookmarks.2h2020 = false + restart" for fixing the problem. I must be the only who doesn't understand Computer. I can't figure out how someone can Post tha" Code without without Posting how or where to use it. Maybe they did, but didn't put it in English. Maybe it's in Computer Gibberish. When I Copy and Paste it to my Browser... All I get is a list of Sites to this page. The other fixes were a load of bunk.

  1. 1
  2. 2