搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Bookmarks drop-down missing

  • 10 回覆
  • 1 有這個問題
  • 87 次檢視
  • 最近回覆由 jscher2000

more options

WTF. I'm having an issue with your software and trying to get to your support bulletin board and all it does is take me round and round through the same set of menus giving me a bunch of pre-written articles. Stop with this shit. I want to ask a question, not read your stupid articles that don't apply. This is your lazy attempt to avoid having to answer people. You mask it under the idea that these "articles" will discuss common issue and how to fix them, but all it really does is distract people to the point that they give up.


I am having a problem with my bookmarks. I am using Firefox 74. If I bookmark a page it used to add it to my Bookmarks drop down. Sometime ago it stopped working. Now it only shows Bookmarks under "Recent Bookmarks" and they drop off the menu after I think 10 bookmarks.

I can still find them when I show "all bookmarks" under the "show all bookmarks" option in the Bookmark drop down menu, but otherwise if I don't immediately drag them from "Recent bookmarks" to an existing Bookmark folder, then they drop off the menu entirely and can only be found when showing all bookmarks.

Is this a holdover from when you guys eliminated showing the file drop down menus by default?

Why isn't this working properly. When I bookmark a page it used to bring up a dialogue box asking me where I'd like to bookmark it. Bring this back.

title edited to represent issue. See Mozilla Support rules and guidelines

由 Andrew 於 修改

被選擇的解決方法

Mathius said

Yes, the top menu bar used to be the default and then they removed it from the default setup presumably because they thought a more streamlined look was better. I did not like this, so I turned it back on.

It's a Windows platform guideline to hide the menu bar by default.

New Bookmarks used to get placed under this menu automatically if you did not place them somewhere else. This no longer happens.

They should be added to the end of "Other Bookmarks" which has a tiny scroll arrow at the top and bottom.

What I do not understand is why I no longer get a dialogue box to let me place my new bookmark the moment I set a web page as a bookmark.

You can turn the drop-down panel back on by either of these methods:

(A) On a bookmarked page, click the blue star, then check the box to show the editor:

<center></center>

(B) Use the about:config preferences editor:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste newbook and pause while the list is filtered

(3) If needed, double-click the browser.bookmarks.editDialog.showForNewBookmarks preference to switch the value from false to true

從原來的回覆中察看解決方案 👍 1

所有回覆 (10)

more options

And now the title of my message is screwed because I thought I was contacting a member of your support team with a private message, not posting to an open bulletin board.

You guys are so backwards.

more options

Hi,

The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers.

If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. Your feedback gets collected by a team of people who read it and gather data about the most common issues.

more options

Let's start with, If you are using any sync, sign out of them first.

[v57+] Places Maintenance is built into Firefox.

Type about:support<enter> in the address bar.

You will find Places Database near the bottom. Press the Verify Integrity button.

When done, copy and post the results here.

more options

FredMcD said

Let's start with, If you are using any sync, sign out of them first. [v57+] Places Maintenance is built into Firefox. Type about:support<enter> in the address bar. You will find Places Database near the bottom. Press the Verify Integrity button. When done, copy and post the results here.

Not using sync. Not even signed in. This is the results:

> Task: checkIntegrity + The places.sqlite database is sane + The favicons.sqlite database is sane > Task: invalidateCaches + The caches have been invalidated > Task: checkCoherence + The database is coherent > Task: expire + Database cleaned up > Task: originFrecencyStats + Recalculated origin frecency stats > Task: vacuum + Initial database size is 25600KiB + The database has been vacuumed + Final database size is 25600KiB > Task: stats + Places.sqlite size is 25600KiB + Favicons.sqlite size is 25888KiB + pragma_user_version is 53 + pragma_page_size is 32768 + pragma_cache_size is -2048 + pragma_journal_mode is wal + pragma_synchronous is 1 + History can store a maximum of 148664 unique pages + Table moz_places has 44776 records + Table moz_historyvisits has 60850 records + Table moz_inputhistory has 13 records + Table moz_hosts has 0 records + Table moz_bookmarks has 2029 records + Table moz_keywords has 0 records + Table sqlite_sequence has 0 records + Table moz_anno_attributes has 3 records + Table moz_annos has 1951 records + Table moz_items_annos has 0 records + Table sqlite_stat1 has 18 records + Table moz_bookmarks_deleted has 5 records + Table moz_meta has 5 records + Table moz_origins has 5531 records + Index sqlite_autoindex_moz_inputhistory_1 + Index sqlite_autoindex_moz_hosts_1 + Index sqlite_autoindex_moz_keywords_1 + Index sqlite_autoindex_moz_anno_attributes_1 + Index sqlite_autoindex_moz_bookmarks_deleted_1 + Index sqlite_autoindex_moz_origins_1 + Index moz_places_hostindex + Index moz_places_visitcount + Index moz_places_frecencyindex + Index moz_places_lastvisitdateindex + Index moz_historyvisits_placedateindex + Index moz_historyvisits_fromindex + Index moz_historyvisits_dateindex + Index moz_bookmarks_itemindex + Index moz_bookmarks_parentindex + Index moz_bookmarks_itemlastmodifiedindex + Index moz_places_url_hashindex + Index moz_places_guid_uniqueindex + Index moz_bookmarks_guid_uniqueindex + Index moz_keywords_placepostdata_uniqueindex + Index moz_annos_placeattributeindex + Index moz_items_annos_itemattributeindex + Index moz_bookmarks_dateaddedindex + Index moz_places_originidindex > Task: _refreshUI

more options

FredMcD said

Hi, The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers. If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. Your feedback gets collected by a team of people who read it and gather data about the most common issues.

Thank you. It is very frustrating. It is identical to the experience I have on Steam. They make it impossible to talk to someone who can make a difference.

I am not intimately familiar with the code and systems of firefox, but I am not a novice either and I am capable of using a Google search to solve my issues. I do not need to come here and get more articles to read. I came to support because I have exhausted my search.

由 Mathius 於 修改

more options

Hi Mathius, by default, new bookmarks are added to the "Other Bookmarks" bucket. There is a fly-out menu for Other Bookmarks on the two optional bookmarks menus. Perhaps you used to have one of these displayed but currently it is missing?

  • top menu bar > Bookmarks -- on Windows, this bar is optional: tap the Alt key or F10 key to activate it, or Alt+B to drop the Bookmarks menu directly (use View > Toolbars > Menu Bar to keep it displayed persistently)

If Firefox doesn't give you a panel to save the bookmarks in a particular folder at the time you add it, or it clears too quickly, you can click the blue star in the address bar to drop the panel. More info: Bookmarks in Firefox.

You also can use an add-on to set your own default folder:

https://addons.mozilla.org/firefox/addon/default-bookmark-folder/

more options

jscher2000 said

Hi Mathius, by default, new bookmarks are added to the "Other Bookmarks" bucket. There is a fly-out menu for Other Bookmarks on the two optional bookmarks menus. Perhaps you used to have one of these displayed but currently it is missing?
  • top menu bar > Bookmarks -- on Windows, this bar is optional: tap the Alt key or F10 key to activate it, or Alt+B to drop the Bookmarks menu directly (use View > Toolbars > Menu Bar to keep it displayed persistently)
If Firefox doesn't give you a panel to save the bookmarks in a particular folder at the time you add it, or it clears too quickly, you can click the blue star in the address bar to drop the panel. More info: Bookmarks in Firefox. You also can use an add-on to set your own default folder: https://addons.mozilla.org/firefox/addon/default-bookmark-folder/

Yes, the top menu bar used to be the default and then they removed it from the default setup presumably because they thought a more streamlined look was better. I did not like this, so I turned it back on. New Bookmarks used to get placed under this menu automatically if you did not place them somewhere else. This no longer happens.

I do know how to organize my bookmarks manually.

I have also seen the "Other Bookmarks" menu, it is there, but it also seems to only show a certain number of bookmarks and then they are no longer there.

What I do not understand is why I no longer get a dialogue box to let me place my new bookmark the moment I set a web page as a bookmark.

more options

選擇的解決方法

Mathius said

Yes, the top menu bar used to be the default and then they removed it from the default setup presumably because they thought a more streamlined look was better. I did not like this, so I turned it back on.

It's a Windows platform guideline to hide the menu bar by default.

New Bookmarks used to get placed under this menu automatically if you did not place them somewhere else. This no longer happens.

They should be added to the end of "Other Bookmarks" which has a tiny scroll arrow at the top and bottom.

What I do not understand is why I no longer get a dialogue box to let me place my new bookmark the moment I set a web page as a bookmark.

You can turn the drop-down panel back on by either of these methods:

(A) On a bookmarked page, click the blue star, then check the box to show the editor:

<center></center>

(B) Use the about:config preferences editor:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste newbook and pause while the list is filtered

(3) If needed, double-click the browser.bookmarks.editDialog.showForNewBookmarks preference to switch the value from false to true

more options

jscher2000 said

Mathius said
Yes, the top menu bar used to be the default and then they removed it from the default setup presumably because they thought a more streamlined look was better. I did not like this, so I turned it back on.

It's a Windows platform guideline to hide the menu bar by default.

New Bookmarks used to get placed under this menu automatically if you did not place them somewhere else. This no longer happens.

They should be added to the end of "Other Bookmarks" which has a tiny scroll arrow at the top and bottom.

What I do not understand is why I no longer get a dialogue box to let me place my new bookmark the moment I set a web page as a bookmark.

You can turn the drop-down panel back on by either of these methods:

(A) On a bookmarked page, click the blue star, then check the box to show the editor:

<center></center>

(B) Use the about:config preferences editor:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste newbook and pause while the list is filtered

(3) If needed, double-click the browser.bookmarks.editDialog.showForNewBookmarks preference to switch the value from false to true

I do not see the blue star you have referenced, but the second method did exactly what I needed.

Thank you very much. I do not know how this option got turned off, but this is the fix I needed.

more options

Mathius said

I do not see the blue star you have referenced, but the second method did exactly what I needed.

Hmm, the transparent star in the address bar should turn blue if the current page URL matches a bookmarked URL. If the star is completely missing, you can add it back by dropping the Page Actions menu (•••), right-clicking Bookmark This Page, and clicking Add to Address Bar.