搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Hardware Acceleration works everywhere except in Firefox.

  • 8 回覆
  • 2 有這個問題
  • 5090 次檢視
  • 最近回覆由 TyDraniu

more options

The Problem: I recently noticed that decoding youtube videos in 2160p60fps is choppy beyond recognition.

Diagnose: While playing said videos in firefox i was able to observe in the task manager that actually none of my graphics cards video decoding capabilities were used. At lower video qualities/resolutions the hardware accelerated video decoding of the graphics card was also not kicking in, but in these cases my cpu was still able to cope with the decoding load, so I never noticed the missing hardware acceleration. To narrow the origin of problem down I tried watching the same videos in edge, chrome and even downloaded a short 2160p60fps clip to play with VLC and everything worked fine, just not in my favorite browser firefox :(

What i already did trying to solve the problem (in order): -Restart Firefox without addons -Refresh Firefox -Create a new Profile

Additional Info: Nvidia Driver Version 441.20

If there is anymore useful info I'm more than happy to provide it.

Thanks for taking the time reading this an providing help.

被選擇的解決方法

David said

So does anybody know of a way to make firefox tell youtube to only provide the non-HDR versions of a video?

OK. You should get non-HDR version of a video (we don't support HDR yet for real).

According to bug 1580695 this is somehow mutual bug (ours and yt's) and it's fixed on our side in version 71.

從原來的回覆中察看解決方案 👍 1

所有回覆 (8)

more options

Start Firefox in Safe Mode {web link} While you are in safe mode;

Disable Hardware Acceleration {web link}

Restart Firefox. Are there any problems?

more options

FredMcD said

Start Firefox in Safe Mode {web link} While you are in safe mode; Disable Hardware Acceleration {web link} Restart Firefox. Are there any problems?

Did what you said.

Did't help.

And I don't see how it could. See, I WANT to use Hardware acceleration (i.e. use my graphics cards video decoding capabilities), because without it I'm not able to decode 2160p60fps vids properly. As stated in my original post my system actually CAN do that. Just not with Firefox.

more options

Make sure that all programs/files are up to date.

I called for more help.

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Now in the Reply Box on the forum page, do a right-click in the box and select Paste.

This will show us your system details. No Personal Information Is Collected.

more options

Thought its the same info you find under "Question Details/System Details" next to my original post.

The Info from about:support won't fit completely into this reply box. Do you want me to do it anyway?

And no offense but this general "Update all your sh*t" advice sounds not very helpful to me. All programs that I could identify as related to this problem e.g. Firefox, graphics card driver and maybe Windows itself ARE up to date. If there are any more programs related I'm happy to check if they are up to date, but chances are high that they are.

more options

1. Can you provide the url to the video, and your Statistics for nerds? 2. Try to install this extension: https://addons.mozilla.org/firefox/addon/h264ify/

more options

David said

The Info from about:support won't fit completely into this reply box. Do you want me to do it anyway?

Post what will fit.

more options

Okay, so I figured out that the problem only occurs on vp9 HDR Videos. My guess is that these videos use the 10 or 12bit version of the vp9 codec which is not supported by my graphics card.

https://developer.nvidia.com/video-encode-decode-gpu-support-matrix

Then I have a related question:

As I mentioned before watching said videos using hardware decoding ( e.g. https://www.youtube.com/watch?v=tO01J-M3g0U ) with edge or chrome works. I realized it does, because these browsers somehow force youtube to provide the video still in 2160p60fps but not in HDR.

I tried using enhanced-h264ify for the same effect, but it only enables you to block vp9 encoded videos altogether.

So does anybody know of a way to make firefox tell youtube to only provide the non-HDR versions of a video?

more options

選擇的解決方法

David said

So does anybody know of a way to make firefox tell youtube to only provide the non-HDR versions of a video?

OK. You should get non-HDR version of a video (we don't support HDR yet for real).

According to bug 1580695 this is somehow mutual bug (ours and yt's) and it's fixed on our side in version 71.