Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Beginning today, I cannot reach https://www.wsj.com/ What is going on, please?

  • 4 回覆
  • 1 有這個問題
  • 1 次檢視
  • 最近回覆由 FredMcD

more options

Browser shows this:

The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

   This problem can sometimes be caused by disabling or refusing to accept cookies

Never happened before, and things work fine in Chrome (FWIW). I tried changing Privacy Settings, Tracking Protection from "Always" to "Only in Provate Windows", but that didn't help. Tried adding an exception for WSJ, but that dialog is "dead" (no input allowed)

Browser shows this: The page isn’t redirecting properly Firefox has detected that the server is redirecting the request for this address in a way that will never complete. This problem can sometimes be caused by disabling or refusing to accept cookies Never happened before, and things work fine in Chrome (FWIW). I tried changing Privacy Settings, Tracking Protection from "Always" to "Only in Provate Windows", but that didn't help. Tried adding an exception for WSJ, but that dialog is "dead" (no input allowed)

所有回覆 (4)

more options

Not Redirecting properly = cookies

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

  • make sure your extensions and filters are updated to the latest version

You see the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.

  • click the shield icon for more detail and possibly disable the protection
  • check the Web Console for more detail about what content is blocked by Tracking Protection
  • "3-bar" menu button or Tools -> Web Developer

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

Thanks to both the responders; I'm really impressed with the quick turnaround and the quality of both suggestions. But here's what seems to be the culprit:

I recently read a tweet posted by @cultofmac wherein they posted a positive review of CloudFlare's DNS. Sky is my ISP here in the UK, and they suck really badly, so I tried it. Next day (today) I could no longer reach wsj.com. I figured it was something to do with cookies (per the FIrefox msg), so I tried making a change there to no avail. Then I remembered the DNS change, and so I removed the Cloudflare DNS server (1.1.1.1), and substituted Google's 8.8.8.8. Bingo! Now, it works again.

more options

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.