X
點擊此處開啟此網站的行動版。

技術支援討論區

Adobe flash 14 (latest version) crashes everytime in Firefox 30.0

已張貼

I updated from Firefox 28 to Firefox 30 today. Nowhere that needs Adobe Flash will work. not Youtube or even Speakeasy. Just the dreaded "Flash plugin has crashed" notification. Everything worked in 28 and add on manager says my plugin is up to date but nothing works in 30.

I updated from Firefox 28 to Firefox 30 today. Nowhere that needs Adobe Flash will work. not Youtube or even Speakeasy. Just the dreaded "Flash plugin has crashed" notification. Everything worked in 28 and add on manager says my plugin is up to date but nothing works in 30.

被選擇的解決方法

This is some standard guidance that addresses the most common reasons for Flash problems in Firefox. I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Flash

See this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable the Flash player plugin's protected mode (Windows Vista/7/8)

The following pages/posts provide different ways to do that:

Flash needs to completely unload from memory (restarting Firefox might help) before this would take effect.

Edited for clarity on #3

從原來的回覆中察看解決方案 9

額外的系統細節

已安裝的外掛程式

  • Google Update
  • Shockwave Flash 14.0 r0
  • Shockwave Flash 13.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • Next Generation Java Plug-in 10.60.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Citrix Online App Detector Plugin
  • Garmin Communicator Plug-In 4.1.0.0
  • 5.1.30214.0
  • VLC media player Web Plugin 2.1.0
  • Shockwave Flash 11.9 r900
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Plug-in for detecting Nero Kwik Media.
  • Coupons, Inc. Coupon Printer Plugin
  • AmazonMP3DownloaderPlugin 1.0.15
  • NPWLPG

應用程式

  • Firefox 30.0
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/30.0/WINNT/en-US/

擴充套件

  • Big Buttons 1.1.5 (BigButtons@kensaunders)
  • Classic Theme Restorer 1.2.0 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Default Full Zoom Level 5.8 ({D9A7CBEC-DE1A-444f-A092-844461596C4D})
  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF})
  • NetVideoHunter 1.15 (netvideohunter@netvideohunter.com)
  • Theme Font & Size Changer 8.3 ({f69e22c7-bc50-414a-9269-0f5c344cd94c})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Webroot Filtering Extension 1.0.0.32 (webrootsecure@webroot.com)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: AMD Radeon HD 7660D
  • adapterDescription2:
  • adapterDeviceID: 0x9901
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 3-19-2013
  • driverDate2:
  • driverVersion: 12.102.1.1000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7660D Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140605174243
  • browser.startup.homepage: https://www.google.com/
  • browser.startup.homepage_override.buildID: 20140605174243
  • browser.startup.homepage_override.mstone: 30.0
  • browser.tabs.onTop: False
  • browser.zoom.siteSpecific: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 30.0
  • font.internaluseonly.changed: False
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1403134096
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: audio/wav,audio/x-wav,audio/mpeg,audio/x-mpeg,audio/x-ms-wma,video/x-ms-wmv,application/x-mplayer2,video/x-ms-asf,video/x-ms-asf-plugin,video/x-ms-wvx,application/pdf
  • plugin.importedState: True
  • plugin.state.flash: 1
  • plugin.state.java: 2
  • privacy.clearOnShutdown.cache: False
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1403111717

其他

  • User JS: 否
  • 輔助功能: 是
jscher2000
  • Top 10 Contributor
8635 個解決方法 70623 個答案

Your "More System Details" shows 3 Flash plugins. Could you make sure the older ones are disabled on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Then find the older "Shockwave Flash" plugins and set them to "Never Activate" to disable them.

Does that help?

Your "More System Details" shows 3 Flash plugins. Could you make sure the older ones are disabled on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Then find the older "Shockwave Flash" plugins and set them to "Never Activate" to disable them. Does that help?
jscher2000
  • Top 10 Contributor
8635 個解決方法 70623 個答案

選擇的解決方法

This is some standard guidance that addresses the most common reasons for Flash problems in Firefox. I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Flash

See this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable the Flash player plugin's protected mode (Windows Vista/7/8)

The following pages/posts provide different ways to do that:

Flash needs to completely unload from memory (restarting Firefox might help) before this would take effect.

Edited for clarity on #3

This is some standard guidance that addresses the most common reasons for Flash problems in Firefox. I'm sure you've seen some of it before, but just in case: (1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them. (2) Disable hardware graphics acceleration in Flash See this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues (3) Disable ''the Flash player plugin's'' protected mode (Windows Vista/7/8) The following pages/posts provide different ways to do that: * Adobe support article under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?] * Manual steps: https://support.mozilla.org/questions/968190?page=5#answer-509209 * Batch file to automate the manual steps: https://support.mozilla.org/questions/982093#answer-518078 Flash needs to completely unload from memory (restarting Firefox might help) before this would take effect. ''Edited for clarity on #3''

由 jscher2000 於 修改

提出問題者

Nothing worked until I disabled protected mode. Now it's working again. Thanks

Nothing worked until I disabled protected mode. Now it's working again. Thanks
bobsd 0 個解決方法 3 個答案

(update) after following the instructions posted above by jscher2000 and looking at the batch file, I realized that protected mode can be set individually for Flash. I am still concerned about this being a red herring. Does anyone know if Flash is actually accessing memory incorrectly, or is it a false positive when windows flags it?

==

(original) Thanks for the steps, but I don't understand how disabling Windows protected mode should be part of a solution. Isn't that like removing a seat-belt because it was too tight?

I have had this ongoing problem for a year or so, through each version of Flash and Firefox. I update each patch from Adobe, and run the latest Firefox. I disable hardware acceleration, and the older "Shockwave Flash" plugins are set to "Never Activate". I also removed any RealPlayer code on my PC.

Are we saying that the flash code is NOT accessing protected memory, so the crash is a false positive on the part of Windows?

Does anyone know if there are public bug reports on this?

Regards, Bob

(update) after following the instructions posted above by jscher2000 and looking at the batch file, I realized that protected mode can be set individually for Flash. I am still concerned about this being a red herring. Does anyone know if Flash is actually accessing memory incorrectly, or is it a false positive when windows flags it? ======== (original) Thanks for the steps, but I don't understand how disabling Windows protected mode should be part of a solution. Isn't that like removing a seat-belt because it was too tight? I have had this ongoing problem for a year or so, through each version of Flash and Firefox. I update each patch from Adobe, and run the latest Firefox. I disable hardware acceleration, and the older "Shockwave Flash" plugins are set to "Never Activate". I also removed any RealPlayer code on my PC. Are we saying that the flash code is NOT accessing protected memory, so the crash is a false positive on the part of Windows? Does anyone know if there are public bug reports on this? Regards, Bob

由 bobsd 於 修改

AliceWyman
  • Moderator
240 個解決方法 2593 個答案

dougaa, you wrote (in reply to jscher2000)

Nothing worked until I disabled protected mode. Now it's working again.  Thanks 

Based on the above I'm marking his answer above as the solution, since it included links to different ways to disable Flash protected mode.

dougaa, you wrote (in reply to jscher2000) Nothing worked until I disabled protected mode. Now it's working again. Thanks Based on the above I'm marking [/questions/1006932#answer-593158 his answer above] as the solution, since it included links to different ways to disable Flash protected mode.
AliceWyman
  • Moderator
240 個解決方法 2593 個答案

bobsd, If you are having similar issues, try the suggestions posted by jscher2000. Note the links under (3) Disable protected mode (Windows Vista/7/8) refer to disabling protected mode in FLASH, which applies to Windows Vista and above. You can also refer to http://kb.mozillazine.org/Flash#Flash_Protected_Mode_issues_on_Windows_Vista_and_above for more information.

If you need more help and the suggested solutions don't work for you, please ask a new question (start your own thread). See Forum rules and guidelines: For support requests, do not re-use existing threads started by others, even if they are seemingly on the same subject. Ask a new question instead.

Edit: I see you already started a new thread: /questions/1007926 Flash 14.0.0.125 crashes on Firefox 30.0. Please post any new reply to that thread.

'''bobsd''', If you are having similar issues, try the suggestions posted by jscher2000. Note the links under (3) Disable protected mode (Windows Vista/7/8) refer to disabling protected mode in FLASH, which applies to Windows Vista and above. You can also refer to http://kb.mozillazine.org/Flash#Flash_Protected_Mode_issues_on_Windows_Vista_and_above for more information. If you need more help and the suggested solutions don't work for you, please ask a new question (start your own thread). See [[Forum rules and guidelines]]: ''For support requests, do not re-use existing threads started by others, even if they are seemingly on the same subject. [https://support.mozilla.org/questions/new Ask a new question] instead.'' <sub>Edit: I see you already started a new thread: [/questions/1007926] ''Flash 14.0.0.125 crashes on Firefox 30.0.'' Please post any new reply to that thread.</sub>

由 AliceWyman 於 修改