Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox very slow, sluggish and unresponsive on Windows 8.1

  • 17 trả lời
  • 104 gặp vấn đề này
  • 25982 lượt xem
  • Trả lời mới nhất được viết bởi kop48

more options

Basically everything is very slow and every action takes a whole lot of time to complete - Switching tabs takes about half a second to a full second (About 5 seconds if there's another tab currently loading/refreshing), clicking the middle mouse button takes again, about half a second to a full second for the scroll arrows to show up, same exact thing with regularly clicking the scroll bar on the right, Firefox pretty much freezes for about a whole second before reacting to the click.

I've tried running Firefox with addons disabled, that hasn't helped, which I was sure it wouldn't since this problem started out before I even got any addons - pretty much the second I installed Firefox. I've running Firefox on a brand new SSD card and a fresh installation of Windows 8.1. I've tried both Aurora and Nightly (currently using Nightly), both are just as slow.

I haven't tried resetting, since again, issue was already there when I first installed Firefox.

Giải pháp được chọn

Figured out what the problem is -- it's a DisplayFusion software that I use for multiple monitor support that's causing the issue. I'll just look for an alternative until (if ever) the issue ceases to exist.

Thanks for the help.

Đọc câu trả lời này trong ngữ cảnh 👍 2

Tất cả các câu trả lời (17)

more options

Although extensions are disabled in Firefox's Safe Mode, plugins are not...

As a diagnostic to see whether Flash might be the culprit, try setting the Shockwave Flash plugin to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

When you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

Of course, some pages use Flash just for nice advertising or to store/retrieve tracking data on your computer, so you really only need to allow it where there is some media you want to play.

Any improvement?


By the way, are you running the regular Nightly or the UX Nightly?

more options

No improvement whatsoever. I thought Flash might have been the problem, because of which I tried to install an earlier version of it (some people reported their browsers not performing as well with newer versions of flash), but that was of no help either.

I'm running the regular Nightly right now.

more options

How would I go about backing up everything, including extensions and what not, before trying to reset firefox?

more options

When you use Reset on a regular version of Firefox, your old settings folder is moved to the desktop in a folder named Old Firefox Data. But I'm not sure about Nightly; a manual backup sounds like a good idea.

You can open your currently active Firefox profile folder using either:

  • Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table of information, click the button to "Show Folder". This should be everything.

For future reference: Recovering important data from an old profile.

more options

Alright, resetting had no effect on the performance, unfortunately.

more options

Do you recall the last version of Firefox that ran normally on this system?

Or did the problem start after something else updated, such as Windows, graphics card drivers, security suite?

more options

This started after I upgraded to an SSD and installed a fresh copy of Win 8.1 (Which is what I was running prior to the upgrade too).

more options

In earlier versions of Windows, it sometimes was useful to restart Windows in "Safe Mode with Networking" and test Firefox there. I don't know how that works in Windows 8.1.

more options

Firefox performs "way" better while running windows in safe mode. All of the problems I've listed are gone there. This obviously does not solve the problem, though.

more options
more options

Hi Syth, it's a useful data point. I wonder whether there is a way to grab a list or snapshot of all the active processes in both modes and compare them to see the difference... I'm not very familiar with the tools for that.

more options

Giải pháp được chọn

Figured out what the problem is -- it's a DisplayFusion software that I use for multiple monitor support that's causing the issue. I'll just look for an alternative until (if ever) the issue ceases to exist.

Thanks for the help.

more options

I've done everything suggested and nothing works. It's an impossible situation so I no longer use Firefox. Very disappointing because I really liked it and used it for years.

more options

Hi mtatters, if you decide you miss Firefox and want to try some new ideas, please start a new question including your system information. There is a link at the top of each page here ("Ask a question").

Được chỉnh sửa bởi jscher2000 vào

more options

I'm also seeing horrible performance in Firefox on my Surface and it's driving me crazy. It gets even worse when using Flash. This is also happening on my desktop PC which is far more powerful than this device. Can I provide any info to help troubleshoot this?

more options

Hi kop48, does your device also use the DisplayFusion software mentioned in the solution for this thread?

If not, could you start a new question at the following link. Scroll down past the suggestions to continue with the form (I think it has 3 different screens). https://support.mozilla.org/questions/new/desktop/fix-problems

more options