X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Can I change search engine when typing in address bar?

Được đăng

If I type a search in the address bar, I am automatically transferred to google. Can this be changed or am I stuck with google? I know I can select one in the upper right. Thank you.

If I type a search in the address bar, I am automatically transferred to google. Can this be changed or am I stuck with google? I know I can select one in the upper right. Thank you.

Giải pháp được chọn

Update try Keyword Search see my post under

Hi msgtedret,
I thought you had solved that problem with the above post from alco


Everyone
If anyone else has problems it is best to start your own thread using /questions/new, but you may find the solution by following the advice and links given in this thread that you are reading now. (Scroll up the page.)

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • GEPlugin
  • iTunes Detector Plug-in
  • NPWLPG
  • 5.1.10411.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

Thông tin chi tiết

user832823 16 giải pháp 141 câu trả lời
Được đăng

Câu trả lời hữu ích

Hi msgtedret,
in Firefox type about:config in the address bar and press ENTER.
Search for keyword.url
Locate and double-click the entry for keyword.URL
Modify it by adding your preferred value. Examples :


Hope that helped you! Please report back!

Hi msgtedret,<br> in Firefox type about:config in the address bar and press ENTER. <br> Search for keyword.url <br> Locate and double-click the entry for keyword.URL <br> Modify it by adding your preferred value. Examples : <br> * Yahoo: http://search.yahoo.com/ * Ask: http://www.ask.com/ * Google: http://www.google.com/ <br> Hope that helped you! Please report back!

Người tạo câu hỏi

I followed the instructions. I wished to have "bing" as the search engine for the address bar. The attempt proved unsuccessful. I typed "http://www.bing.com/" for the keyword.url. When I performed a search in the address bar, the following appeared:

That web page doesn't exist.

Let's see if we can help you find what you are looking for. Tips

   Check that the web address that you entered doesn't contain a typo.
   Use the search box instead of your browser's address bar.
   Go to the Bing homepage.
   Find more search tips in Help.
I followed the instructions. I wished to have "bing" as the search engine for the address bar. The attempt proved unsuccessful. I typed "http://www.bing.com/" for the keyword.url. When I performed a search in the address bar, the following appeared: That web page doesn't exist. Let's see if we can help you find what you are looking for. Tips Check that the web address that you entered doesn't contain a typo. Use the search box instead of your browser's address bar. Go to the Bing homepage. Find more search tips in Help.
user832823 16 giải pháp 141 câu trả lời
Được đăng

Hi msgtedret,
Please type http://www.bing.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= for the keyword.url and report back if it worked!

Hi msgtedret,<br> Please type '''http://www.bing.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=''' for the keyword.url and report back if it worked!

Người tạo câu hỏi

Thank you, Alco. Situation solved.

Thank you, Alco. Situation solved.
reza_083 0 giải pháp 1 câu trả lời
Được đăng

Câu trả lời hữu ích

Hello, Just to sum up here is what I did to solve my problem inspiring by "alco":

1- in Firefox type about:config in the address bar and press ENTER.

2- Search for keyword.url Locate and double-click the entry for keyword.URL

3- Modify it by adding your preferred value like this:

http://***/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

4- in the above link instead of *** put the search engine address you like. Examples:

Google: http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=na...

Bing: http://www.bing.com/search?ie=UTF-8&oe=UTF-8&sourceid=na...

Hope this works for you.

Hello, Just to sum up here is what I did to solve my problem inspiring by "alco": 1- in Firefox type about:config in the address bar and press ENTER. 2- Search for keyword.url Locate and double-click the entry for keyword.URL 3- Modify it by adding your preferred value like this: http://***/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= 4- in the above link instead of *** put the search engine address you like. Examples: Google: [http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=] Bing: [http://www.bing.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=] Hope this works for you.
tuck791 0 giải pháp 1 câu trả lời
Được đăng

Recently I went to a website that changed my url search results for firefox to {http://search.conduit.com/?ctid=CT3296477&searchsource=69&CUI=MC08045270674931048&UM=2&lay=1} I tried to replace the keyword:URL within the about:config with the available terms within this forum to restore Google search results with no avail. Does anyone know what to type into the Keyword:URL?

THe above post just takes me to the Google home page to then search

Recently I went to a website that changed my url search results for firefox to {http://search.conduit.com/?ctid=CT3296477&searchsource=69&CUI=MC08045270674931048&UM=2&lay=1} I tried to replace the keyword:URL within the about:config with the available terms within this forum to restore Google search results with no avail. Does anyone know what to type into the Keyword:URL? THe above post just takes me to the Google home page to then search

Được chỉnh sửa bởi tuck791 vào

mnco3 0 giải pháp 2 câu trả lời
Được đăng

I've tried replacing string in KEYWORD URL with the short string " http://search.yahoo.com/" and get a 404 error along with some guesses. At least it was a Yahoo reply.

I also replaced string in KEYWORD URL with long string http://***/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

Replaced *** with: http://www.bing.com/search?ie=UTF-8&oe=UTF-8&sourceid=na... . The string show up in config. After I close config, the address space on the navigation toolbar is still google.

I even tried restarting Firefox and restarting the whole pc.

I tried repeating both routines to be sure they didn't work. And now I can't even get to 'about:config'. I have no idea what is in there now.

I've tried replacing string in KEYWORD URL with the short string " http://search.yahoo.com/" and get a 404 error along with some guesses. At least it was a Yahoo reply. I also replaced string in KEYWORD URL with long string http://***/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= Replaced *** with: http://www.bing.com/search?ie=UTF-8&oe=UTF-8&sourceid=na... . The string show up in config. After I close config, the address space on the navigation toolbar is still google. I even tried restarting Firefox and restarting the whole pc. I tried repeating both routines to be sure they didn't work. And now I can't even get to 'about:config'. I have no idea what is in there now.
cor-el
  • Top 10 Contributor
  • Moderator
17473 giải pháp 157926 câu trả lời
Được đăng

You can check for problems with preferences and rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
You can check for problems with preferences and rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Người tạo câu hỏi

Let me rephrase: When I search from the address bar, the default engine is Google. Is it possible to change that default?

Let me rephrase: When I search from the address bar, the default engine is Google. Is it possible to change that default?
John99 971 giải pháp 13138 câu trả lời
Được đăng

Giải pháp được chọn

Update try Keyword Search see my post under

Hi msgtedret,
I thought you had solved that problem with the above post from alco


Everyone
If anyone else has problems it is best to start your own thread using /questions/new, but you may find the solution by following the advice and links given in this thread that you are reading now. (Scroll up the page.)

Update try [https://addons.mozilla.org/en-US/firefox/addon/keyword-search/ Keyword Search] see [/questions/950758#answer-464209 my post] under Hi msgtedret, <br /> I thought you had solved that problem with the above [/questions/950758#answer-409283 post from ''alco''] * See also http://kb.mozillazine.org/Keyword.URL *And http://kb.mozillazine.org/Resetting_preferences *Other useful articles ** [[Search the web from the Address Bar]] **[[Search bar - Easily choose your favorite search engine]] **[[Remove a toolbar that has taken over your Firefox search or home page]] ** https://addons.mozilla.org/en-US/firefox/addon/searchreset/ ------ '''Everyone''' <br /> If anyone else has problems it is best to start your own thread using [/questions/new], but you may find the solution by following the advice and links given in this thread that you are reading now. (Scroll up the page.)

Được chỉnh sửa bởi John99 vào

mnco3 0 giải pháp 2 câu trả lời
Được đăng

I asked a question the other day. The replies were helpful and I did solve the problem. here is my new question: AM I SUPPOSED TO GO TO THE THREAD AND TELL EVERYONE IT IS SOLVED? Thanks.

I asked a question the other day. The replies were helpful and I did solve the problem. here is my new question: AM I SUPPOSED TO GO TO THE THREAD AND TELL EVERYONE IT IS SOLVED? Thanks.
John99 971 giải pháp 13138 câu trả lời
Được đăng

Hi mnco3,

It does help if you let the forum know when a question you ask is solved. Others may find the information useful. And contributors will know that you do not need further advice.

However I only see one question you asked and that was in 2011.

Are you talking about your comment in this thread above on 6/6/13 6:01 PM

Hi mnco3, It does help if you let the forum know when a question you ask is solved. Others may find the information useful. And contributors will know that you do not need further advice. However I only see one question you asked and that was in 2011. *See your profile [/user/543608 mnco3] **& link to the old closed thread [/questions/879852 Does FF 7 support Avast security?] Are you talking about your comment in this thread [/questions/950758#answer-443409 above] on ''6/6/13 6:01 PM''

Người tạo câu hỏi

Thank you. I had forgotten about this reply. After following these instructions, all is well. This time I saved the information in my documents. Thanks, again.

Thank you. I had forgotten about this reply. After following these instructions, all is well. This time I saved the information in my documents. Thanks, again.
cor-el
  • Top 10 Contributor
  • Moderator
17473 giải pháp 157926 câu trả lời
Được đăng

Note that future Firefox 23+ versions will no longer use the keyword.URL pref, but will use the default search engine that is selected in the search bar.

See also comment 122:

  • Bug 738818 - consolidate Firefox search preferences

Please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Note that future Firefox 23+ versions will no longer use the keyword.URL pref, but will use the default search engine that is selected in the search bar. * http://mycroftproject.com/search-engines.html?name=Google+%28Browse+by+Name%29 See also comment 122: *Bug 738818 - consolidate Firefox search preferences <i>Please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>
szolnokij1231 0 giải pháp 1 câu trả lời
Được đăng

Hello tuck791,

This "conduit" issue also happens to me. It's so annoying....

I have tried the following and it's works for me. You should modify the "searchAddresUrl" settings value to one of the search providers link posted above.

-if we faced the same issue than you should see "...search.conduit.com...." in the value field of the searhAddresUrl record. -if you have still encounter some issue try to find another "hijacked" records by type the the suspicios keywork of the provider (like conduit.com) and search for default or recommended setting in support.mozilla.org

I hope it helped!

Hello ''tuck791'', This "conduit" issue also happens to me. It's so annoying.... I have tried the following and it's works for me. You should modify the "searchAddresUrl" settings value to one of the search providers link posted above. -if we faced the same issue than you should see "...search.conduit.com...." in the value field of the searhAddresUrl record. -if you have still encounter some issue try to find another "hijacked" records by type the the suspicios keywork of the provider (like conduit.com) and search for default or recommended setting in support.mozilla.org I hope it helped!
John99 971 giải pháp 13138 câu trả lời
Được đăng

Everyone

Note a useful new addon is


Conduit issue,

Please start a new thread if you wish to discuss a new subject

Everyone Note a useful new addon is *Keyword Search ** from: https://addons.mozilla.org/en-US/firefox/addon/keyword-search/ ** developers comments see: https://addons.mozilla.org/en-US/firefox/addon/keyword-search/developers ------ Conduit issue, Please start a new thread if you wish to discuss a new subject * use [/questions/new].