Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Bookmark Spacing too much since going from Win7 to Windows 10

  • 9 trả lời
  • 0 gặp vấn đề này
  • 59 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I recently upgraded from Window 7 to windows 10. Ever since, the spacing between the bookmarks has significantly increased. I read several post about this and they all seem to be looking for something in Firefox. I think it has to do with something in windows 10, not Firefox. Any ideas? I've already done the Density/Compact thing. Slight improvement, but not anything like it was under Window 7.

I recently upgraded from Window 7 to windows 10. Ever since, the spacing between the bookmarks has significantly increased. I read several post about this and they all seem to be looking for something in Firefox. I think it has to do with something in windows 10, not Firefox. Any ideas? I've already done the Density/Compact thing. Slight improvement, but not anything like it was under Window 7.

Tất cả các câu trả lời (9)

more options

I want to add that it's the same version of Firefox (115.5.0) with both versions of Windows.

Hữu ích?

more options

Why would you keep using Firefox 115 ESR with Windows 10? In Window 7 you can't update beyond 115, but for Windows 10 there is not need to it.

Could you please update to the current Firefox 123.0.1 release.

You probably need to use code in userChrome.css if compact mode isn't good enough.

Hữu ích?

more options

If I go into help/about Firefox, it shows "Update to 115.8.0esr", not 123.0.1. If i try to do that update, it sits forever and never performs the update. How can I get to 123?

Được chỉnh sửa bởi Stumann666 vào

Hữu ích?

more options

You can't switch the update channel via "Help -> About Firefox" or otherwise via updating. This can only be done by installing the full version. You may have to uninstall the current version to cleanup the Windows Registry.

You can find the full installer of the current Firefox release (123.0.1) in all languages and all operating systems here:

Hữu ích?

more options

Try using compact density by changing browser.uidensity to 1 in about:config.

Hữu ích?

more options

Thanks, cor-el, I was able to update Firefox to 124.0, but IT didn't change my issue with the line spacing. I hope Firefox will look into this, I'm not the only one mentioning that problem. I don't trust myself enough to do that Chrome.css thing.

Hữu ích?

more options

You can add CSS code to the userChrome.css file in the chrome folder in the Firefox profile folder.


:root[uidensity=compact] menupopup :is(menu,menuitem) {
 padding-block: 2px !important; /*adjust: 0px-4px*/
 min-height: 22px !important;   /*adjust: 21px-24px or unset*/
 height: 26px !important;       /*adjust*/
}
:root[uidensity=compact] {
 --arrowpanel-menuitem-margin: 0 4px !important;
 --arrowpanel-menuitem-padding: 2px 6px !important; /*adjust 2px value*/
}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder with the random name (xxxxxxxx.default-release).

You can find the button to go to the profile folder under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in the profile folder with the random name (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted further up.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt or .css file extension and you end up with a file like userChrome.css.txt or userChrome.css.css. To avoid this, you need to make sure to select "All files" in the "Save File" dialog in the text editor. You can verify this by dragging the file in an empty Firefox tab or use "Ctrl+O".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

More info about userChrome.css/userContent.css in case you are not familiar:

In Firefox 69 and later you need to set this pref to true in about:config to enable userChrome.css and userContent.css.

Hữu ích?

more options

Thanks, cor-el. I successfully created the *css file and put in the Chrome folder I made. Works great! I even experimented with changing some of the values. I change height step by step to 22 px. Not it looks close to or even better that it was before.

Được chỉnh sửa bởi Stumann666 vào

Hữu ích?

more options

You're welcome If you want to tighten he sidebar as well then try this code:

.sidebar-placesTree treechildren::-moz-tree-row { min-height:22px !important; }
.placesTree         treechildren::-moz-tree-row { min-height:22px !important; }

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.