Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox on Linux

  • 17 trả lời
  • 0 gặp vấn đề này
  • 33 lượt xem
  • Trả lời mới nhất được viết bởi Abe Sternberg

more options

I am using a Samsung Chromebook Pro V2, running Debian, and installed Firefox using the Flatpak command "flatpak install flathub org.mozilla.firefox". The Firefox icon appears in the Linux apps group and I have opened Firefox using that icon.

How do I get links in my Linux apps to open Firefox and take me to the URL?

Thank you and Happy New Year, Abe

I am using a Samsung Chromebook Pro V2, running Debian, and installed Firefox using the Flatpak command "flatpak install flathub org.mozilla.firefox". The Firefox icon appears in the Linux apps group and I have opened Firefox using that icon. How do I get links in my Linux apps to open Firefox and take me to the URL? Thank you and Happy New Year, Abe

Giải pháp được chọn

I have done everything the article directs me to do so it was no help. My instinct tells me that some switch in Firefox or Linux is blocking the acceptance of, and the search for URLs.

Abe

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (17)

more options

Hi Abe

What desktop environment are you using with Debian? I use Xfce where there is a option in the settings to set the default browser - you may find that the same in the desktop that you are using.

Hữu ích?

more options

I am not using any desktop, I just start Linux apps using the icons.

Thanks for responding.

Abe

Hữu ích?

more options

Hi Abe

I am not sure what you mean.

Was the Chromebook running ChromeOS which you have replaced with Debian? If so, you will need to have installed a desktop environment to be able to run any apps with a graphical user interface.

Or, have you installed Firefox on ChromeOS using this guide? https://support.mozilla.org/en-US/kb/run-firefox-chromeos

Hữu ích?

more options

In Debian GNOME, go to Settings > Default Apps > Web > Firefox.

Hữu ích?

more options

Thank you both for your answers.

Zeroknight - I am not running Gnome. At least I didn't knowingly install it.

Paul - I didn't use that particular article; the instructions I used were pretty much identical. I am using the beta mode of ChromeOS. I believe the Google people call this Crostini.

Abe

Hữu ích?

more options

Try running:

xdg-settings set default-web-browser org.mozilla.firefox.desktop

Hữu ích?

more options

Curiouser and curiouser, said Alice.

I opened your response in Thunderbird and clicked on didn't solve the problem (more on that later). Firefox opened with the proper URL in the search window and went nowhere. I could not get Firefox to go to the support URL or any other URL.

As to your suggestion. I ran xdg-settings set default-web-browser org.mozilla.firefox.desktop and received the following response from Linux - xdg-settings: $BROWSER is set and can't be changed with xdg-settings. Judging from my first paragraph Linux is using Firefox as my designated browser. Now the question becomes why doesn't Firefox do anything?

Hữu ích?

more options

Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection" and in Connection Settings change "Use system proxy settings" to "No proxy".

Does it still happen in Troubleshoot Mode?

Hữu ích?

more options

This did not solve my problem which seems deeper than originally reported.

First, I looked to see DoH was turned off and it was. Then I looked at No Proxy was the active selection, and it was. Next, I tried to go into Troubleshoot mode, but my system rejected that command with "-bash: firefox: command not found". I tried "sudo -bash: firefox: command not found", which was similarly found to be in error.

I have attached a screenshot of Firefox as it appears when I open it. The initial size of Firefox is quite small, the top right does not show any of the three size icons, minimize, etc. I cannot enter any URLs into the search bar. The Firefox icon on the Task Bar shows an owl, not Firefox. I get the owl with other Linux apps, but not all.

As it sits, Firefox is not viable for use.

Thanks for your help,

Abe

Hữu ích?

more options

Do you see error messages if you start Firefox via a terminal window ?

cd <path_to _firefox>
./firefox

Hữu ích?

more options

Did you follow the guide: Run Firefox on ChromeOS?

Does it still happen in a new profile (without signing into sync account)? Alternatively you can refresh your existing profile.

Hữu ích?

more options

Np, no error messages at all.

Abe

Hữu ích?

more options

I have not read that document, I had not heard of its existence. I will read it during the week and post my results.

Abe

Hữu ích?

more options

That document did not help as I have Flatpak installed and use it for my installs. I did not use Flatpak for Firefox as it listed an older version.

Abe

Hữu ích?

more options

Is this an ARM chromebook or an Intel/AMD chromebook?

Hữu ích?

more options

Giải pháp được chọn

I have done everything the article directs me to do so it was no help. My instinct tells me that some switch in Firefox or Linux is blocking the acceptance of, and the search for URLs.

Abe

Hữu ích?

more options

I was just fooling around with Firefox and got everything working OK. It runs slow, but it does work. Thanks for all the help and understanding.

Abe

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.