Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How can I disable searching when typing a question mark in the awesomebar?

  • 4 trả lời
  • 0 gặp vấn đề này
  • 1 lượt xem
  • Trả lời mới nhất được viết bởi zeroknight

more options

I use a lot of keyword search engines. This means I can type something like `kagi foobar` to search Kagi for `foobar`. However the awesome bar has a "feature" where if you type a question mark (?) anywhere it instead uses the default search engine. This means that `kagi How do I cook a turkey?` searches my default search engine for "kagi How do I cook a turkey?" rather than searching Kagi (based on the `kagi` keyword). Is there a way to disable this behaviour?

I have searched about:config and "Search Shortcuts" in preferences doesn't have a `?`. I never use `?` as a shortcut to search (I just type the keyword for the engine I want) so completely removing it would be perfect.

I use a lot of keyword search engines. This means I can type something like `kagi foobar` to search Kagi for `foobar`. However the awesome bar has a "feature" where if you type a question mark (?) anywhere it instead uses the default search engine. This means that `kagi How do I cook a turkey?` searches my default search engine for "kagi How do I cook a turkey?" rather than searching Kagi (based on the `kagi` keyword). Is there a way to disable this behaviour? I have searched about:config and "Search Shortcuts" in preferences doesn't have a `?`. I never use `?` as a shortcut to search (I just type the keyword for the engine I want) so completely removing it would be perfect.

Giải pháp được chọn

This should be fixed in Firefox 123 by Bug 1667639.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (4)

more options

You can install Kagi as a search engine and assign it a keyword which is not affected by question marks.

Hữu ích?

more options

Thanks, that is a good workaround!

Unfortunately search engines don't sync via Firefox Sync while keyword search engines do, so it doesn't work well for my use case.

Hữu ích?

more options

You can avoid triggering the default search engine by adding punctuation immediately after the question mark:

kagi How do I cook a tofurkey?.

kagi "How do I cook a tofurkey?"

Hữu ích?

more options

Giải pháp được chọn

This should be fixed in Firefox 123 by Bug 1667639.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.