Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Domain Guessing

  • 6 trả lời
  • 4 gặp vấn đề này
  • 11 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

With the latest update domain guessing is no longer working. I like just typing the name of the website and having Firefox add the prefix (https) and suffix (.com, org, etc. so I can move aorund the web just a little faster. The setting I used to turn it on is no longer in the about:config menu. Is there a way to get this back? For example, I was able to type in Amazon and the amazon.com website would automatically open in the tab. Now I get this

With the latest update domain guessing is no longer working. I like just typing the name of the website and having Firefox add the prefix (https) and suffix (.com, org, etc. so I can move aorund the web just a little faster. The setting I used to turn it on is no longer in the about:config menu. Is there a way to get this back? For example, I was able to type in Amazon and the amazon.com website would automatically open in the tab. Now I get this
Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (6)

more options

What was the name of the about:config setting?

You can add "www." and ".com" by pressing Ctrl+Enter.

more options

See also:

  • 1850902 - Remove browser.fixup.alternate.enabled pref and its code path [119]

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

With a site you have visited before, you normally would have address bar autofill:

type amazon in the address bar => default action is to visit https://www.amazon.com/

(Of course, if you do not keep history, then that may not work.)

If you were to disable address bar autofill (browser.urlbar.autoFill => false), the behavior would change:

type amazon in the address bar => default action is to send it to your default search engine

If you were to also disable address bar search (keyword.enabled => false), then Firefox would do the DNS lookup of your exact text.

Is that your configuration, more of a Firefox 1 approach without the newer behaviors?

more options

Thanks for the replies.

I have browser.url.autofill set to true.

the pic below shows the rest of the settings, which have not changed. Before the update, with these same settings, the address bar worked as I wanted it to. After the update, with the same settings, it does not. I know that hitting Ctrl+Enter does the same thing but for years I didn't have to and was curious as to what changed.

more options

Do other autofills work or have they all stopped working? If they all stopped working, and history wasn't cleared, maybe there is a file corruption problem. Suggestions for that:

First, if you haven't already, please do a normal shutdown and/or restart of your system. Restarting Windows can help by freeing up locked files, completing any deferred updates, and resolving temporary file permission issues.

Next, run the "Verify Integrity" diagnosis and repair function. That's here:

Open Firefox's Troubleshooting Information page using any of these methods:

  • "3-bar" menu button > Help > More Troubleshooting Information
  • (menu bar) Help > More Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Near the bottom, there is a section titled Places Database -- that's the file which stores history and bookmarks. Click the button labeled Verify Integrity. There may be a 10-15 second delay before results appear.

If all is well, the report that appears below the button should start with:

> Task: checkIntegrity
+ The places.sqlite database is sane
+ The favicons.sqlite database is sane
> Task: invalidateCaches
+ The caches have been invalidated
> Task: checkCoherence
+ The database is coherent

Hopefully all that is fine. The table relevant to autofill is moz_origins so if it reports a problem with that one, that could be the problem. This diagnostic may clean up the problem without detecting that there is a problem, so it's good to try in any event.

more options

Note that browser.fixup.alternate no longer works in 119. Your screenshot doesn't show the full width of the the about:config page, but this pref should have a trashcan at the far right, meaning that the pref is no longer there by default. You can click the trashcan to reset and remove this not functioning pref. browser.fixup.alternate defaults to true, i.e. you can no longer disable this feature.