Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Bookmarks are BROKEN

  • 5 trả lời
  • 1 gặp vấn đề này
  • 1 lượt xem
  • Trả lời mới nhất được viết bởi zeroknight

more options

Took me a long time to nail this issue down. Recently (past 1-2 years?), Firefox has started suggesting the base website when you have bookmarks that include the base domain - and it's really bothersome from a UX perspective. E.g. if i have "adobe.com/express" or any other adobe bookmarks, the FIRST autocompleted url Firefox gives me is "adobe.com" which I DO NOT have as a bookmark. In my Firefox settings I also have Shortcuts and other search suggestions disabled.

Why is Firefox doing this?

Took me a long time to nail this issue down. Recently (past 1-2 years?), Firefox has started suggesting the base website when you have bookmarks that include the base domain - and it's really bothersome from a UX perspective. E.g. if i have "adobe.com/express" or any other adobe bookmarks, the FIRST autocompleted url Firefox gives me is "adobe.com" which I DO NOT have as a bookmark. In my Firefox settings I also have Shortcuts and other search suggestions disabled. Why is Firefox doing this?

Giải pháp được chọn

If you want to search or browse from the address bar, autofilling specific URLs can be intrusive. You can still get to bookmark suggestions quickly by pressing the down arrow key.

Some full URL autofilling for regularly visited URLs is being experimented with recently, you can try it by going to about:config and changing browser.urlbar.autoFill.adaptiveHistory.enabled to true.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (5)

more options

Everything seems to be disabled

more options

This is what the bug looks like:

more options

This has always been the case, autofill is incremental for each component of the address. If you want a bookmark to autofill in its entirety, you can give it a keyword.

more options

zeroknight said

This has always been the case, autofill is incremental for each component of the address. If you want a bookmark to autofill in its entirety, you can give it a keyword.

I don't think that's the case - but my next question (for Mozilla/Firefox) would be: why is it like that? I obviously want to go to my bookmark, not the root URL - that's what bookmarks are for.

more options

Giải pháp được chọn

If you want to search or browse from the address bar, autofilling specific URLs can be intrusive. You can still get to bookmark suggestions quickly by pressing the down arrow key.

Some full URL autofilling for regularly visited URLs is being experimented with recently, you can try it by going to about:config and changing browser.urlbar.autoFill.adaptiveHistory.enabled to true.