Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

The menu disappears when a hint shows up.

  • 18 trả lời
  • 1 gặp vấn đề này
  • 23 lượt xem
  • Trả lời mới nhất được viết bởi jnbrains

more options

Firefox 102.0.1 (64bit), Linux, Sway (Wayland), MOZ_DBUS_REMOTE=1, MOZ_ENALBE_WAYLAND=1 When I hover over a menu item, the hint shows up and the menu disappears visually, it is still there, as I can interact with it (mouse click or enter).

Firefox 102.0.1 (64bit), Linux, Sway (Wayland), MOZ_DBUS_REMOTE=1, MOZ_ENALBE_WAYLAND=1 When I hover over a menu item, the hint shows up and the menu disappears visually, it is still there, as I can interact with it (mouse click or enter).

Giải pháp được chọn

Firefox 106.0.1 (64-bit) no longer exhibits the reported issue. Thanks.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (18)

more options

screenshot (gif) attached

more options

Wayland... What OS? Just as a test, I would suggest you try KDE and X11 see what happens.


Operating System: openSUSE Tumbleweed 20220714 KDE Plasma Version: 5.25.3 KDE Frameworks Version: 5.96.0 Qt Version: 5.15.5 Kernel Version: 5.18.9-2-default (64-bit) Graphics Platform: X11 Processors: 12 × Intel® Core™ i7-9850H CPU @ 2.60GHz Memory: 15.0 GiB of RAM Graphics Processor: Mesa Intel® UHD Graphics 630 Manufacturer: HP Product Name: HP ZBook 17 G6

more options

OS: ArchLinux, using sway (wayland), no X11

Installed and configured i3 (X11) - there is no problem, works fine. Didn't try KDE - too heavy/bloated for my preferences/setup.

more options

Cool... So there is no browser issue, just a Wayland issue. Good luck with that.

more options

Yes, I surmised that much. I wouldn't classify it as "Wayland issue" as much as a "Firefox with Wayland issue". Firefox does officially supports wayland. I don't have any other apps exsibiting this behaviour, so I cannot conclude it's a wayland issue (generalization). What would be the proper way to troubleshoot this issue - debug mode, monitoring syscalls, etc...

more options

Open a bug with bugzilla.mozilla.org and see what they say.

more options

I see, thanks anyway.

more options

Hi

Are you using a copy of Firefox from the Arch repo, or are you using the version directly available from Mozilla?

more options

Yes, I'm using the package from archlinux 'extra' repo, currently version 102.0.1-1.

more options

Be sure to take a backup of your Firefox profile beforehand, but you may wish to try a version directly from Mozilla first just be sure it is not an issue with the Arch repo version.

more options

Following your advice, I downloaded the latest version from the Firefox website (102.0.1), and tried it - the same issue. Purged my profile and cache once again - same results.

more options

I'm confused... I thought you already tried Firefox from Mozilla and had the same result. You then tried the same steps in the X11 graphic environment instead of Wayland and Firefox had no issues. So you determined that the issue is in Wayland and that you were going to open a bug right... ;-))

more options

Correct. I've tried running the distribution package of Firefox under x11 (i3) using my existing profile and then a new profile. The issue appears to be wayland related. Then I tried with binary from the Firefox website, to exclude the distribution packaging issues introduced. Next step, as I see it, before opening a bugzilla ticket, is to downgrade Firefox - to determine when this issue appeared, as I've used Firefox with Wayland for some time. I'd like to get as much info as I can before opening that ticket. Meanwhile I continue to troubleshoot when I get new ideas.

more options

Firefox 99.0 is the last version not exhibiting this issue. Went backwards testing with binaries from https://ftp.mozilla.org/pub/firefox/releases/

more options

There are a few issues on bugzilla already 1766198 and 1767533 related to this issue, I think. Both still unresolved (status: UNCONFIRMED).

more options

Please add any further information you have to those tickets to raise the priority and hopefully get this matter looked into and resolved.

more options

Thanks. Updated Bugzilla issue 1767533

more options

Giải pháp được chọn

Firefox 106.0.1 (64-bit) no longer exhibits the reported issue. Thanks.