Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Add Add-on Icon to toolbar

  • 6 trả lời
  • 1 gặp vấn đề này
  • 45 lượt xem
  • Trả lời mới nhất được viết bởi FredMcD

more options

according to the add-on page in Settings, the AdBlock Plus add-on is enabled in my browser, but it doesn't appear to be working. so I am trying to access the menu options to control it. to do that, I need to add the icon to my toolbar.

this article: https://support.mozilla.org/bm/questions/955157

explains two methods:

1. go to Settings --> Customize Toolbars, and drag the icon to the toolbar. this doesn't work, because the icon is not there to be dragged (even after I restore defaults).

2. go to the View Menu --> Toolbars --> Add-on Bar and move the icon from one toolbar to another.

quite apart from the fact that it took me two days to figure out how to get the View Menu to appear, that procedure doesn't work either because after View Menu --> Toolbars --> the Add-on Bar is not listed.

can someone please tell me what I'm doing wrong.


thank you,

Giải pháp được chọn

I finally solved this and want to put the solution here where it might help others.

I emailed AdBlock Plus to see if they could shed any light on this and they solved the problem in a heartbeat.

if you go to: Settings --> Privacy & Security --> History -->

if you have this set to Private Browsing Mode, then, irrespective of anything it says anywhere else in your browser, AdBlock Plus has not downloaded, is not installed, and is not in fact enabled in your browser.

as soon as I set this to "Use custom settings for history" a pop-up appeared telling me that 1) AdBlock Plus had downloaded and was installed and enabled in my browser, and 2) inviting me to make a contribution.

I write this with the Adblock Plus icon in my toolbar.

I'd like to thank everyone who tried to help. your generosity is appreciated.


thank you.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (6)

more options

Have you checked the toolbar overflow list? >>


It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address box and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files"

+++++++++++++++++++++++++++ You may have to approve the updating once again.

Hữu ích?

more options

thank you for engaging,

if by Overflow Menu you mean that thing with a blue fish in it, then that is empty.

I followed the rest of your suggestion. there were two files extension* which I deleted. there was no compatibility.ini, but there was a compatibility with no visible file extension. it was a text file and I deleted that.

I then re-booted the computer. the three files I deleted have been replaced, but this has made no difference.


thank you,

Hữu ích?

more options

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

Hữu ích?

more options

thank you for engaging,

I'm afraid that didn't work either.

thank you,

Hữu ích?

more options

Giải pháp được chọn

I finally solved this and want to put the solution here where it might help others.

I emailed AdBlock Plus to see if they could shed any light on this and they solved the problem in a heartbeat.

if you go to: Settings --> Privacy & Security --> History -->

if you have this set to Private Browsing Mode, then, irrespective of anything it says anywhere else in your browser, AdBlock Plus has not downloaded, is not installed, and is not in fact enabled in your browser.

as soon as I set this to "Use custom settings for history" a pop-up appeared telling me that 1) AdBlock Plus had downloaded and was installed and enabled in my browser, and 2) inviting me to make a contribution.

I write this with the Adblock Plus icon in my toolbar.

I'd like to thank everyone who tried to help. your generosity is appreciated.


thank you.

Hữu ích?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.