Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox 89 on Raspberry Pi - visual codec artifacts

  • 5 trả lời
  • 2 gặp vấn đề này
  • 526 lượt xem
  • Trả lời mới nhất được viết bởi vw

more options

Firefox 89 on my Raspberry Pi 4 is displaying what I'm guessing is a codec issue. Videos can be watched but the picture is corrupted by brightly coloured patches around areas of detail.

Prior to the version 89 upgrade, version 88 was working perfectly.

I have Firefox 89 on a Raspberry Pi and a PC. On the PC it still works perfectly, on the Pi video is displayed badly.

On the Pi Firefox 89 is running under Ubuntu 21.04. On the PC Firefox 89 is running under Ubuntu 18.04

Am I alone in this or have others seen the same issue ?

Assuming I am not alone, does anybody have any idea what has gone wrong ?

Firefox 89 on my Raspberry Pi 4 is displaying what I'm guessing is a codec issue. Videos can be watched but the picture is corrupted by brightly coloured patches around areas of detail. Prior to the version 89 upgrade, version 88 was working perfectly. I have Firefox 89 on a Raspberry Pi and a PC. On the PC it still works perfectly, on the Pi video is displayed badly. On the Pi Firefox 89 is running under Ubuntu 21.04. On the PC Firefox 89 is running under Ubuntu 18.04 Am I alone in this or have others seen the same issue ? Assuming I am not alone, does anybody have any idea what has gone wrong ?
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

You can try to disable WebRender if it currently is enabled.

  • about:config => gfx.webrender.force-disabled = true

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Đọc câu trả lời này trong ngữ cảnh 👍 2

Tất cả các câu trả lời (5)

more options

Hi

Have you tried turning off hardware acceleration? This support article should help:

https://support.mozilla.org/en-US/kb/performance-settings?as=u&utm_source=inproduct

more options

Thank you for your reply, I hadn't tried that but I have now and it has made no difference.

The screenshot I included in my previous post shows an example which is more extreme than most. It starts at about 14 seconds into the following YouTube video: https://youtu.be/9GxHQ1FnjPs

This issue is not limited to YouTube, I see a similar effect in video from the BBC.

I have just done a network speed test which tells me I have a download speed of 45Mbps, upload 18Mbps so no problem there.

more options

Although I turned off hardware acceleration in Firefox as per the suggestion, I don't believe it would ever have been operational to start with. I know Raspberry Pi graphics acceleration works if you are using Raspberry Pi OS, but I don't think it has ever worked for 64 bit Ubuntu.

Raspberry Pi OS is not very Firefox friendly and this is one of the reasons I use Ubuntu instead.

more options

Giải pháp được chọn

You can try to disable WebRender if it currently is enabled.

  • about:config => gfx.webrender.force-disabled = true

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

more options

cor-el, you are a STAR, thank you, that appears to have fixed the problem.

There is one detail that I failed to mention earlier. Although I am using Ubuntu 21.04 which has Wayland enabled by default, I am running with Xorg not Wayland. Wayland on the Pi has a problem with Logitech wireless keyboards, hence I am still using Xorg.

Thank you again, VW